Szoftvertelepítés

A Szoftvertelepítés beépülő modul segítségével meghatározható a szervezetben az alkalmazások telepítésének módja és azok karbantartásának módja.

Egy csoportházirend-objektumban egy alkalmazást kezel, mely viszont egy meghatározott Active Directory tárolóval van társítva, mely lehet egy hely, tartomány vagy szervezeti egység. Az alkalmazások a következő két mód egyike szerint kezelhetők: telepítésre kijelölt vagy közzétett.

Az alkalmazás telepítésre kijelölése akkor használható, amikor azt szeretné, hogy az alkalmazás a felhasználók saját számítógépén helyezkedjen el. Tegyük fel például, hogy azt szeretné, hogy a marketing részlegen minden felhasználó számára rendelkezésre álljon a Microsoft Excel alkalmazás a saját számítógépen. A marketing részlegen egy csoportházirend-objektum kezeli az összes felhasználót. Ha a Microsoft Excel alkalmazást telepítésre kijelöli a marketing csoportházirend-objektumban, akkor az a marketing részleg minden felhasználójának számítógépén meg lesz hirdetve. Ha egy telepítésre kijelölt alkalmazást a rendszer meghirdet, az valójában nincs telepítve a számítógépen. Ebben az esetben az alkalmazás hirdetménye csak a Microsoft Excel számára elegendő adatokat telepíti, melyek lehetővé teszik a Start menüben a Microsoft Excel parancsikonjának megjelenítését, valamint a rendszerleíró adatbázisban a szükséges fájltársítások (.xls) bejegyzését.

Ha a felhasználó ilyen számítógépre jelentkezik be, a Microsoft Excel programcsoport megjelenik a Start menüben. Amikor a számítógépen a Start menüből első alkalommal kiválasztja a Microsoft Excel parancsot, a rendszer telepíti a Microsoft Excel alkalmazást. Az alkalmazással társított dokumentum megnyitásával is (a fájlnévkiterjesztéssel társított vagy COM alapú aktiválású) telepíthető a meghirdetett alkalmazás. Ha a felhasználó a Start menüben lévő Microsoft Excel parancsra kattintással még nem aktiválta a Microsoft Excel programot, és egy Microsoft Excel dokumentumra kattint, hogy azt megnyissa, a rendszer telepíti az alkalmazást és megnyitja a táblázatot.

A felhasználó a telepítésre kijelölt alkalmazást törölheti, de azt a rendszer újra közzéteszi a felhasználó következő bejelentkezésekor. Ha a Start menüből az alkalmazás indítóparancsát kiválasztja, a rendszer újra telepíti az alkalmazást.

Ha a felhasználónak szüksége van az alkalmazásra, annak közzététele akkor célszerű, ha azt a csoportházirend-objektum által kezelt személyek számára kívánja elérhetővé tenni. A közétett alkalmazások esetén a felhasználó dönti el, hogy telepítse-e vagy sem a közzétett alkalmazást.

Ha például a Microsoft Image Composer alkalmazást teszi közzé a marketing csoportházirend-objektum által kezelt felhasználók számára, és a marketing részlegen lévő felhasználó telepíteni szeretné az Image Composer alkalmazást, akkor a telepítéshez a Vezérlőpulton lévő Programok hozzáadása/eltávolítása segédprogram is használható, a közzétett alkalmazások listájában lévő Image Composer elemre való kattintással. Ha a felhasználó nem telepíti az Image Composer alkalmazást a Vezérlőpulton lévő Programok hozzáadása/eltávolítása segédprogrammal, vagy ha a .jpg képdokumentum kiterjesztése az Image Composer alkalmazással van társítva, akkor a .jpg dokumentumra való előszöri kattintással telepíthető az Image Composer alkalmazás.

Lásd még:

  • A Szoftvertelepítés beépülő modul használata
  • Szoftvertelepítés ismertetése


A Szoftvertelepítés beépülő modullal gyakran használt fájltípusok

A végrehajtható fájlok (például Setup.exe és Install.exe) mellett a rendszergazda általában a következő fájltípusokkal dolgozik.

Fájltípus | Fájlkiterjesztés | Leírás
Windows Installer csomagok | .msi | Ezekről a fájlokról általában a szoftverforgalmazó gondoskodik egy megadott alkalmazás telepítésének elősegítésére. Ezeket a fájlokat a többi szükséges fájllal együtt a kezelt szoftver szoftverterjesztési pontjában kell tartania.
Átalakító fájlok | .mst | Más néven módosítások. Ezek a fájlok testreszabják a Windows Installer csomagok telepítését az alkalmazás telepítésre történő kijelölésekor vagy annak közzétételekor. Ezek a fájlok például alkalmazáscsomagok részhalmazát is megadhatják.
Szervizcsomagok .msp Hibajavítás, javítócsomagok és hasonló fájlok oszthatók el ilyen módon.

A szervizcsomagok jelentős módosításokhoz nem használhatók, továbbá hatásuk a következőképpen korlátozott:

  • Nem távolíthat el összetevőket vagy szolgáltatásokat.
  • Nem módosíthat termékkódokat.
  • Nem távolíthatja el a parancsikonokat, a fájlokat vagy rendszerleíró kulcsokat, és nem módosíthatja azok nevét.
.zap fájlok | .zap | Ezek az .ini fájlokhoz hasonló fájlok szövegszerkesztő program, például a Jegyzettömb segítségével hozhatók létre. Ezek a fájlok csak közzétehetők (telepítésre nem kijelölhetők), továbbá egy olyan végrehajtható telepítőprogramot határoznak meg (például \\kiszolgáló\megosztás\Excel\Setup.exe), amely a felhasználó számára a Vezérlőpult Programok telepítése/törlése segédprogramjában jelenik meg. A helyi számítógépen a felhasználó rendszergazdai jogokkal rendelkezik.
Alkalmazáskijelölő parancsfájlok | .aas | Ezek a fájlok a csomag telepítésre kijelölésével vagy közzétételével kapcsolatos utasításokat tartalmazzák.


Felügyeleti sablonok

A csoportházirend Felügyeleti sablonok csomópontja tartalmazza az összes rendszerleíró adatbázis alapú házirend-információt. A felhasználó konfigurációját a HKEY_CURRENT_USER (HKCU) rendszerleíró kulcs, a számítógép konfigurációját a HKEY_LOCAL_MACHINE (HKLM) rendszerleíró kulcs tárolja. A szoftver házirend-beállításai minden program csoportházirendjét tartalmazzák, beleértve a Windows 2000 operációs rendszerét és annak összetevőit is.

A rendszer .adm fájlokkal vagy egy csoportházirend-bővítménnyel tölti fel a Felügyeleti sablon csomópont alatti névteret. A csomópont első alkalommal történő használatakor az .adm kiterjesztésű fájlok automatikusan telepítésre kerülnek.

Amennyiben a Felügyeleti sablonok csomóponthoz bejegyzéseket szeretne létrehozni, a névteret fel kell töltenie az alábbi elnevezési konvenció használatával (ez a rendszerleíró adatbázisban ugyancsak használatos):
\Cégnév\termék\verzió (vagy \Cégnév\termék&verizó)
Például a Windows 2000 operációs rendszer beállításai a \Microsoft\Windows 2000 könyvtárban találhatók.

A rendszer .adm kiterjesztésű fájlok segítségével tölti fel a Felügyeleti sablonok csomópontjai alatt megjelenő felhasználói felületet. Ebből a célból a Windows 2000 rendszert számos .adm kiterjesztésű fájllal látták el. Ezen fájlok leírását megtalálhatja A Windows 2000 rendszerben található .adm fájlok témakörben.

Az .adm kiterjesztésű fájlok hozzáadásával kapcsolatos további tudnivalókért tanulmányozza a Felügyeleti sablon (.adm fájl) hozzáadása vagy eltávolítása témakört.

Registry.pol fájlok

A Felügyeleti sablonok csoportházirend-bővítmény az adatokat Registry.pol fájlokba menti. Ezek a fájlok tartalmazzák a testreszabott rendszerleíróadatbázis-beállításokat, melyet a rendszerleíró adatbázis számítógéppel vagy a felhasználóval kapcsolatos részéhez adhatók meg (a csoportházirend felhasználásával). A Registry.pol fájlok egyike a HKEY_LOCAL_MACHINE rendszerleíró kulcsra vonatkozó rendszerleíróadatbázis-beállításokat tartalmazza; ez a GPT\Machine mappában tárolódik. A másik Registry.pol fájl a HKEY_CURRENT_USER kulcsra vonatkozó rendszerleíróadatbázis-beállításokat tartalmazza; ezt a rendszer a GPT\User alkönyvtárban tárolja.

Lásd még:

  • Felügyeleti sablonok által biztosított nézet használata
  • A Felügyeleti sablonok szerepe
  • Haladó felhasználóknak: Testreszabott .adm fájlok létrehozása


A Felügyeleti sablonok szerepe

A Windows 2000 rendszerben a Felügyeleti sablonok .adm fájlnévkiterjesztéssel szerepelnek, hasonlóan a Windows NT 4.0 rendszerhez. Azonban a szerepük kis mértékben különbözik.

A korábbi Windows verziókban betöltött szerepük

A Windows korábbi verzióiban a Felügyeleti sablonok ANSI kódolású szövegfájlok voltak. Ezek a fájlok névteret hoztak létre a Rendszerházirend-szerkesztőben a rendszerleíró adatbázis kényelmes szerkesztése érdekében. A Felügyeleti sablonok barátságosabb felhasználói felületről gondoskodtak, mint a Rendszerleíróadatbázis-szerkesztő (Regedit.exe). Ezzel a sablonok biztonsága is fokozódott, mivel csak az .adm kiterjesztésű fájlban említett rendszerleíró kulcsok lettek felfedve.

A sablonok szerepe a Windows 2000 rendszerben

A Windows 2000 számos .adm kiterjesztésű fájlt tartalmaz, melyeket felsorolva A Windows 2000 rendszerben található .adm fájlok témakörben tanulmányozhat. További .adm kiterjesztésű fájlok is írhatók. Az .adm nyelv új verziója az előző változat szülőhalmaza (bővített változat) — a korábbi sablonok létre tudnak hozni felhasználói felületeket a csoportházirendben, de az újabb sablonok erre a műveletre nem képesek a Rendszerházirend-szerkesztőben. Az új .adm nyelvvel kapcsolatos további tudnivalókért tanulmányozza a Testreszabott .adm fájlok létrehozása témakört.

A Windows 2000 támogatja a Unicode alapú .adm fájlokat.

A Windows NT 4.0 rendszerű .adm fájlok Windows 2000 környezetben való használatával kapcsolatos előírásokért tanulmányozza a Windows NT 4.0 rendszerházirendjei témakört.


Felügyeleti sablonok

A csoportházirendnek olyan forrásra van szüksége, melyből a rendszergazda által megadható felhasználói felület beállításait létre tudja hozni. Ebből a célból a csoportházirend használhatja a Microsoft Management Console csoportházirend bővítő modulját, vagy egy Felügyeleti sablon néven ismert (.adm fájl) ASCII fájlt.

Az .adm fájl egy kategóriákból és alkategóriákból felépülő struktúrából áll, mely együttesen határozza meg a beállítások csoportházirendben történő megjelenítését. A fájl továbbá a rendszerleíró adatbázis beállításait is jelzi, melyek a csoportházirenddel és az alábbiakkal módosíthatók:

  • Rendszerleíró adatbázisban lévő helyek, ahol a módosításokat el kell végezni egy bizonyos kijelölés esetén.
  • A kijelöléssel kapcsolatos beállítások vagy (értékbeli) korlátozások.
  • Bizonyos esetben a kijelölés aktiválásakor használatos alapértelmezett érték.

A rész tartalma:

  • A Windows 2000 rendszerben található .adm fájlok
  • Haladó felhasználóknak: Testreszabott .adm fájlok létrehozása


Felügyeleti sablonok használata

  • Felügyeleti sablon (.adm fájl) hozzáadása vagy eltávolítása
  • Felügyeleti sablonok által biztosított nézet használata


Alkalmazáscsomag módosításainak hozzáadása és eltávolítása

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. Kattintson az egér jobb gombjával a részletek ablaktáblára, kattintson az Új parancsra, majd a Csomag elemre.
  3. A Megnyitás párbeszédpanelen kattintson a Windows Installer csomagra, majd a Megnyitás gombra.
  4. A Szoftver központi telepítése párbeszédpanelen kattintson a Speciálisan közzétett vagy kötelező beállítása, majd az OK gombra.
  5. A csomag tulajdonságlapján kattintson a Módosítások elemre.
  6. Amennyiben módosításokat kíván a Módosítások párbeszédpanelen hozzáadni, kattintson a Hozzáadás gombra, majd a Megnyitás párbeszédpanelen keresse meg az átalakító fájlt (.mst), majd kattintson a Megnyitás gombra.
  7. Módosítások eltávolításához a Módosítások párbeszédpanelen kattintson az eltávolítani kívánt módosításra, majd kattintson az Eltávolítás gombra. Addig ismételje meg a műveletet, amíg a nem kívánt módosításokat el nem távolította.
  8. Ellenőrizze, hogy a módosítások konfigurálása pontosan a kívánt módon történjen, majd kattintson az OK gombra.

Figyelem!

  • Csak akkor kattintson az OK gombra, amikor az összes módosítás konfigurálását befejezte. Amikor az OK gombra kattint, a rendszer azonnal telepítésre kijelöli vagy közzéteszi a csomagot. Ha a módosításokat helytelenül konfigurálta, a csomagot el kell távolítania, illetve frissítenie kell azt a megfelelően konfigurált verzióval.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Több módosító fájl (átalakítás) is hozzáadható. Az átalakító fájlokat a rendszer a Módosítások listában megadott sorrendben fentről lefelé haladva alkalmazza. A lista elemeinek átrendezéséhez a listából válasszon ki egy módosító elemet, majd kattintson a Fel vagy a Le gombra.

Kapcsolódó témakörök


Alkalmazás kijelölése telepítésre

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. Kattintson az egér jobb gombjával a részletes ablaktáblára, majd kattintson az Új parancsra, végül a Csomag parancsra.
  3. A csomag kijelöléséhez a Megnyitás párbeszédpanelen kattintson a Windows Installer csomagra, majd a Megnyitás gombra. (A Megnyitás párbeszédpanel az alapértelmezettként megadott szoftverterjesztési pontban elhelyezkedő alkalmazáscsomagokat jeleníti meg. Az alapértelmezett szoftverterjesztési pont megadásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.)

    Ha a Windows Installer csomag egy másik hálózati megosztáson helyezkedik el, kattintson a Tallózás gombra, majd keresse meg a csomag szoftverterjesztési pontját.

  4. A Szoftver központi telepítése párbeszédpanelen kattintson a Telepítésre kijelölt elemre majd az OK gombra.

Kapcsolódó témakörök


Fájlnévkiterjesztésen alapuló automatikus telepítési beállítások megadása

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon az egér jobb gombjával kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. Kattintson a Tulajdonságok parancsra, majd a Fájlkiterjesztés fülre.
  3. A Fájlkiterjesztés tulajdonságlapon adja meg a használni kívánt beállításokat, majd kattintson az OK gombra.

    4. Fájlkiterjesztés: Megjeleníti a kezelt szoftver összes fájlnévkiterjesztését. Egy kiterjesztés kijelölésekor a kiválasztott fájlnévkiterjesztéssel társított összes, Active Directory címtárban lévő alkalmazás megjelenik az Alkalmazások sorrendje listában. Például a .htm kiterjesztéssel számos alkalmazás társítva van, például a Microsoft Word 97, a Microsoft Internet Explorer 5, a Netscape Communicator 5.0 stb.

    Alkalmazások sorrendje: A kijelölt fájlkiterjesztéssel társított alkalmazásokat sorolja fel. Az alapértelmezés szerint legnagyobb elsőbbséggel rendelkező alkalmazás a lista legfelső sorába kerül.

    Fel: A kiválasztott alkalmazást a prioritási listában felfelé mozgatja. A lista legfelső sorában lévő alkalmazás automatikusan telepítésre kerül, ha az alkalmazás telepítése előtt egy dokumentumot a felhasználó a kijelölt fájlnévkiterjesztéssel megnyit. A Fel funkció nem használható, ha a kiválasztott alkalmazás a lista legfelső sorában helyezkedik el.

    Le: A kiválasztott alkalmazást a prioritási listában lefelé mozgatja. A Le funkció nem használható, ha a kiválasztott alkalmazás a lista legalsó sorában helyezkedik el.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Alkalmazás frissítésekor ne feledje, hogy a korábbi verzió automatikus telepítési beállítását kapcsolja ki.

Kapcsolódó témakörök


Alkalmazás automatikus telepítésének megadása

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Felhasználó konfigurációja
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. A részletek ablaktáblán kattintson a jobb oldali egérgombbal az automatikusan telepíteni kívánt alkalmazásra.
  3. Kattintson a Tulajdonságok parancsra, majd a Központi telepítés fülre.
  4. A Központi telepítési lehetőségek területen ellenőrizze, hogy az Automatikus telepítés a fájlkiterjesztés használatának hatására jelölőnégyzet be van-e jelölve, majd kattintson az OK gombra.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Alkalmazás frissítésekor ne feledje a korábbi verzió automatikus telepítési beállítását kikapcsolni.

Kapcsolódó témakörök


Alkalmazás telepítési beállításainak módosítása

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. A részletek ablaktáblán kattintson az egér jobb oldali gombjával arra az alkalmazásra, melynek telepítési beállításait meg szeretné adni, majd kattintson a Tulajdonságok parancsra.
  3. Az alkalmazás Tulajdonságok lapján kattintson a Központi telepítés fülre.
  4. A Központi telepítés tulajdonságlapon kattintson a Központi telepítés típusa mezőben az alábbi központi telepítéstípusok egyikére:

    Közzétett: A kiválasztott helyen, tartományban vagy szervezeti egységben a felhasználó telepítheti az alkalmazást a Vezérlőpulton lévő Programok telepítése/törlése segédprogram használatával, illetve fájl aktiválásával.

    Telepítésre kijelölt: A kiválasztott helyen, tartományban vagy szervezeti egységben a felhasználó megkapja az alkalmazást a következő bejelentkezéskor (telepítésre kijelölés felhasználók számára) vagy a számítógép újraindításakor (telepítésre kijelölés számítógépek számára).

  5. A Központi telepítési lehetőségek mezőben válasszon az alábbi lehetőségek közül:

    Automatikus telepítés a fájlkiterjesztés használatának hatására: Válassza ezt a beállítást, ha a Szoftvertelepítési beállítások párbeszédpanel Fájlkiterjesztés lapján meghatározott alkalmazások sorrendjét kívánja használni a fájlnevek kiterjesztéséhez.

    Amennyiben a szoftver még nincs telepítve, a beállítás kiválasztása a szoftver telepítését eredményezi, ha a felhasználó például dupla kattintással nyit meg egy ilyen kiterjesztésű fájlt.

    A rendszer az alkalmazást eltávolítja, ha a csoportházirend-objektum már nem vonatkozik a felhasználókra vagy számítógépekre. Válassza ezt a beállítást, ha azt szeretné, hogy (felhasználói) bejelentkezéskor vagy (számítógép) indításkor a rendszer eltávolítsa az alkalmazást, amennyiben a felhasználó vagy a számítógép egy olyan helyre, tartományba vagy szervezeti egységbe költözik, melyhez az adott alkalmazás nincs központilag telepítve.

    A csomag ne jelenjen meg a Vezérlőpult Programok telepítése/törlése paneljén: Ez a beállítás meggátolja a felhasználót a program egyszerű eltávolításában. Ez hasznos lehet időről időre a szoftverélettartam során.

  6. A Felhasználói felület lehetőségei telepítéskor területen kattintson az alábbi beállítások egyikére:

    Alapvető: A rendszer csak a folyamatjelző sávot és a hibaüzeneteket jelzi ki.

    Maximális: A rendszer megjeleníti a csomag által támogatott teljes felhasználói felületet.

  7. Ha speciális beállításokat szeretne megadni, kattintson a Speciális gombra:

    Nyelv figyelmen kívül hagyása a csomag központi telepítésekor: Használja ezt a beállítást, ha az operációs rendszer nyelvétől eltérő nyelvű alkalmazást szeretne telepíteni.

    A termék előző telepítéseinek eltávolítása a számítógépekről, ha terméket nem a csoportházirend alapú szoftvertelepítés telepítette: Ez a beállítás hasznos lehet például, ha a vállalati irányelv szerint a felhasználók nem telepíthetnek alkalmazásokat saját CD-lemezről.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Speciális gombra kattintáskor megjelenő Speciális központi telepítési lehetőségek lap a hibaelhárításhoz hasznos speciális diagnosztikai információkról gondoskodik.
    Mező | Adat
    Termékkód | A terméket jelző globális egyedi azonosító (GUID)
    Központi telepítés számlálója | A csomag központi telepítésének száma ebben a csoportházirend-objektumban
    Parancsfájl neve | Az alkalmazás telepítésre kijelölő parancsfájljainak (.aas kiterjesztésű fájl) teljes elérési útja, beleértve a globális egyedi azonosítókat is (GUID)

Kapcsolódó témakörök


Csomagmódosítási műveletek

A módosításokat (.mst fájlok) a rendszer a Windows Installer csomagokra alkalmazza (.msi kiterjesztés), a rendszergazda által megadott sorrendben. Ezt a sorrendet meg kell határozni az alkalmazás telepítésre kijelölése vagy annak közzététele előtt.

A módosításokat átalakításoknak is nevezik.

A csomagmódosítási műveletekkel kapcsolatos tudnivalókért tanulmányozza az Alkalmazáscsomag módosításainak hozzáadása és eltávolítása témakört.


Alkalmazás közzététele

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Felhasználó konfigurációja
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. Kattintson az egér jobb gombjával a részletes ablaktáblára, majd kattintson az Új parancsra, végül a Csomag parancsra.
  3. A Megnyitás párbeszédpanelen kattintson a Windows Installer csomagra annak közzétételéhez, majd kattintson a Megnyitás gombra. (A Megnyitás párbeszédpanel az alapértelmezettként megadott szoftverterjesztési pontban elhelyezkedő alkalmazáscsomagokat jeleníti meg. Az alapértelmezett szoftverterjesztési pont megadásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.)

    Ha a Windows Installer csomag egy másik hálózati megosztáson helyezkedik el, kattintson a Tallózás gombra, majd keresse meg a csomag szoftverterjesztési pontját.

  4. A Szoftver központi telepítése párbeszédpanelen kattintson a Közzétett elemre majd kattintson az OK gombra.

    Az alkalmazást a felhasználók a Vezérlőpultban lévő Programok telepítése/törlése segédprogram segítségével telepíthetik, illetve olyan fájl megnyitásával, melynek kiterjesztése az alkalmazással társítva van. A kiterjesztés alkalmazással történő társításával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A csomagok csak felhasználók számára tehetők közzé, számítógépek számára nem.

Kapcsolódó témakörök


Kezelt alkalmazás eltávolítása

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd a konzolon kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. A részletek ablaktáblán kattintson a jobb oldali egérgombbal az eltávolítani kívánt alkalmazásra.
  3. Kattintson a Minden feladat pontra, majd az Eltávolítás parancsra.
  4. A Szoftver eltávolítása párbeszédpanelen válassza ki az alább részletezett eltávolítási lehetőségek egyikét, majd kattintson az OK gombra:

    A szoftver azonnali eltávolítása a felhasználóktól és a számítógépekről: A beállítás kiválasztásával megadható, hogy a felhasználó következő bejelentkezésekor vagy a számítógép újraindításakor a rendszer eltávolítsa az alkalmazást.

    A felhasználók tovább használhatják a szoftvert, de többet nem lehet telepíteni: A beállítás kiválasztásával megadható, hogy ha már az alkalmazást a rendszer telepítette, a felhasználók folytathatják az alkalmazás használatát. Ha a felhasználó eltávolítja az alkalmazást, illetve annak telepítése még nem történt meg, akkor a felhasználó nem tudja az alkalmazást telepíteni.

Megjegyzés

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Engedélyek megadása szoftvertelepítéséhez

  1. Nyissa meg a szerkeszteni kívánt csoportházirend-objektumot.
  2. Kattintson a jobb oldali egérgombbal a konzolgyökér azon elemére, ahol az alábbi nevet látja:
    Csoportházirend-objektum_neve [tartománynév] házirend
  3. Kattintson a Tulajdonságok parancsra, majd a Biztonság fülre.
  4. Kattintson arra a biztonsági csoportra, melynek az engedélyeit meg kívánja adni.

    A gombok segítségével biztonságcsoportok hozzáadhatók és eltávolíthatók, amennyiben szükség van a csoportházirend-objektumra vonatkozó biztonságcsoportok megváltoztatására.

  5. Ha a biztonságcsoport a rendszergazdákat jelzi (akik a felhasználói szoftvereket és a számítógépeket kezelik a szervezetben), válassza a Teljes hozzáférés elemhez az Engedélyezve beállítást.

    Ha a biztonságcsoport a felhasználókat jelzi (akik a rendszergazda által telepítésre kijelölt vagy közzétett szoftvereket használják), válassza a Csoportházirend alkalmazása és az Olvasás elemekhez az Engedélyezve beállítást.

  6. A csoportházirend-objektum tulajdonságlapján kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az eljárással megadott engedélyek csak a csoportházirend-objektumra vonatkoznak. Továbbá a hálózatnak a telepítendő csomagokat tartalmazó megosztott mappával kell rendelkeznie (szoftverterjesztési pont). A rendszergazdának a szoftverterjesztési ponthoz teljes hozzáféréssel, a felhasználóknak Olvasás engedéllyel kell rendelkezniük. Megosztott mappák engedélyeinek megadásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Szoftvertelepítés beépülő modul alapértelmezéseinek beállítása

  1. Nyissa meg a Szoftvertelepítés beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Szoftvertelepítés csomópontra, majd a Tulajdonságok parancsra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  3. Kattintson az Általános fülre, majd válassza ki a kívánt beállításokat:

    A csomag(ok) alapértelmezett helye: Adja meg az alapértelmezett szoftverterjesztési pontot.

    Új csomagok: Alapértelmezés szerint a csomagok közzétehetők vagy telepítésre kijelölhetők (számítógépekhez csak telepítésre kijelölhetők). Ha az egyes csomagokra vonatkozóan kívánja ezeket a beállításokat elvégezni, válassza a Szoftver központi telepítése párbeszédpanel megjelenítése elemet. A csomagonkénti finombeállítás elvégzéséhez válassza a Speciálisan közzétett vagy kötelező elemet.

    Felhasználói felület lehetőségei telepítéskor: Kattintson az Alapvető vagy a Maximális választógombra attól függően, hogy milyen részletezettséggel kívánja a felhasználót a telepítési folyamatról tájékoztatni.

    A rendszer az alkalmazást eltávolítja, ha a csoportházirend-objektum már nem érvényes a felhasználókra vagy a számítógépekre: Válassza ezt a beállítást, ha (felhasználói) bejelentkezéskor vagy (számítógép) indításkor azt szeretné, hogy a rendszer eltávolítsa a szoftvert, amennyiben a felhasználó vagy a számítógép egy olyan helyre, tartományba vagy szervezeti egységbe költözik, melyhez az adott szoftver nincs központilag telepítve.

Megjegyzés

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Szoftvertelepítés beépülő modul beállításainak megadása

  • A Szoftvertelepítés beépülő modul alapértelmezéseinek beállítása
  • Fájlnévkiterjesztésen alapuló automatikus telepítési beállítások megadása
  • A kezelendő alkalmazások kategóriáinak megadása


Alkalmazások tulajdonságainak megadása

  • Kezelt alkalmazások tulajdonságainak megtekintése
  • Az alkalmazások beállításainak módosítása
  • Kategóriák megadása a Vezérlőpulton lévő Programok telepítése/törlése segédprogram számára
  • Alkalmazások automatikus telepítésének beállítása
  • Szoftvertelepítési engedélyek megadása


A kezelendő alkalmazások kategóriáinak megadása

  1. Nyissa meg a Szoftvertelepítés beépülő modult.
  2. Kattintson a jobb oldali egérgombbal a Szoftvertelepítés csomópontra, majd a Tulajdonságok parancsra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  3. Kattintson a Kategóriák fülre.
  4. A Vezérlőpulton lévő Programok telepítése/törlése panel programjai számára hozza létre vagy módosítsa a kategóriák listáját a megfelelő gombok segítségével:

    5. Hozzáadás: Egy párbeszédpanelt nyit meg, melybe beírhatja az új kategória megadásához a szöveget. Ha kategóriák hozzáadásához nincs jogosultsága, a funkció nem használható.

    Módosítás: Egy párbeszédpanelt nyit meg, melyben módosíthatja a kijelölt kategóriához tartozó szöveget. Ha kategóriák módosításához nincs jogosultsága, a funkció nem használható.

    Eltávolítás: Eltávolítja a kijelölt kategóriát a Kategóriák listából.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az alkalmazáskategóriákon végzett módosításokat a rendszer abban a tartományban alkalmazza, melyben a Csoportházirend-objektum tárolva van.
  • A művelet végrehajtásához tartománygazdai vagy azzal egyenértékű jogosultság szükséges.

Kapcsolódó témakörök


Kategóriák megadása a Vezérlőpulton lévő Programok telepítése/törlése segédprogram számára

Alkalmazáskategóriák megadása a Vezérlőpulton lévő Programok telepítése/törlése segédprogram számára

  1. Nyissa meg a Szoftvertelepítés beépülő modult.
  2. A részletek ablaktáblán kattintson duplán arra a kezelt alkalmazásra, melynek kategóriáit be szeretné állítani, majd az alkalmazás tulajdonságlapján kattintson a Kategóriák elemre.
  3. A Kategóriák tulajdonságlapon adja meg a használni kívánt beállításokat, majd kattintson az OK gombra:

    4. Rendelkezésre álló kategóriák: Felsorolja a szervezethez meghatározott alkalmazáskategóriákat.

    Kijelölés: A kiválasztott alkalmazáskategóriát társítja az alkalmazással. A beállítás kiválasztásához a Rendelkezésre álló kategóriák listából válaszon ki egy kategóriát, majd kattintson a Kijelölés gombra.

    Eltávolítás: Egy kategóriát távolít el a Választott kategórák listából. A beállítás kiválasztásához a Rendelkezésre álló kategóriák listából válaszon ki egy kategóriát, majd kattintson a Kijelölés gombra.

    Kijelölt kategórák: Megjeleníti az alkalmazással társított kategóriákat.

Megjegyzések

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A párbeszédpanelen megadott kategóriák általában csak a közzétett alkalmazásokra vonatkoznak, mivel a telepítésre kijelölt alkalmazások nem jelennek meg a Vezérlőpult Programok telepítése/törlése panelén. Az alkalmazás megjelenik a kijelölt kategóriákban az alkalmazások telepítésére használatos Programok telepítése/törlése panelen.
  • A művelettel nem lehet kategóriákat létrehozni vagy törölni, csak az alkalmazásokat meglévő kategóriákhoz kijelölni. A kategóriák kezelésével kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Szoftvertelepítés beépülő modul megnyitása

A Szoftvertelepítő beépülő modul megnyitása

  1. Nyissa meg a Csoportházirend beépülő modult az Active Directory - helyek és szolgáltatások lehetőség Active Directory - felhasználók és számítógépek ablakjából, vagy különálló Microsoft Management Console Beépülő modulként.
  2. Ha a szoftvert számítógépekhez kívánja telepítésre kijelölni, kattintson duplán a Számítógép konfigurációja elemre. A szoftver felhasználók számára telepítésre kijelöléséhez vagy közzétételéhez kattintson duplán a Felhasználó konfigurációja elemre.
  3. Kattintson duplán a Szoftverbeállítások elemre.
  4. A konzolfán kattintson a Szoftvertelepítés elemre.

    Helye:

    • házirendnév házirend
    • [Számítógép | Felhasználó] konfigurációja
    • Szoftverbeállítások
    • Szoftvertelepítés

Megjegyzés

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Kezelt alkalmazások tulajdonságainak megtekintése

  1. Nyissa meg a Szoftvertelepítés beépülő modult.
  2. A részletes ablaktáblán kattintson a jobb oldali egérgombbal a megtekinteni kívánt szolgáltatásra, majd a Tulajdonságok parancsra.

Megjegyzés

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Házirend öröklődésének blokkolása

  1. Ha egy helyen a házirend öröklődésének blokkolását kívánja elvégezni, nyissa meg az Active Directory - helyek és szolgáltatások beépülő modult.

    Ha egy tartományban vagy szervezeti egységben a házirend öröklődését blokkolni szeretné, nyissa meg az Active Directory - felhasználók és számítógépek beépülő modult.

  2. A konzolon kattintson a jobb oldali egérgombbal a helyre, tartományra vagy szervezeti egységre, ahol a házirend öröklődésének blokkolását el kívánja végezni, majd kattintson a Tulajdonságok parancsra.
  3. Kattintson a Csoportházirend fülre, majd ellenőrizze, hogy a Házirend öröklődésének blokkolása jelölőnégyzet be van-e jelölve, végül kattintson az OK gombra.

Megjegyzések

  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.
  • Az Active Directory - felhasználók és számítógépek párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A Házirend öröklődésének blokkolása beállítás azokat a Csoportházirend-objektumokat blokkolja, melyek az Active Directory címtárban lévő helyek, tartományok és szervezeti egységek hierarchiájában magasabb szintre akarnak lépni. Ha a Nincs felülírás beállítás engedélyezve van, a rendszer nem blokkolja a csoportházirend-objektumokat.
  • Csak a nem egyedi csoportházirend-objektumok helyein, tartományain és szervezeti egységein lehet a Házirend öröklődésének blokkolása beállítást megadni.

Kapcsolódó témakörök


Feladatlisták

A rész tartalma:

  • Feladatlista: Csoportházirend megvalósítása az Active Directoryban
  • Feladatlista: Helyi csoportházirend megvalósítása
  • Feladatlista: A Szoftvertelepítés beépülő modul megnyitása


Csoportházirendek házirendjei: Számítógép konfigurációja

Ez a témakör a számítógépek csoportházirendben való kezelésével foglalkozik. Mivel a System.adm fájl tartalmazza ezeket a házirendeket, azoknak alapértelmezés szerint a számítógépen kell lenni. E házirendek konfigurálásával kapcsolatos tudnivalókért tanulmányozza A Csoportházirend beépülő modul megnyitása témakört. A konzolfán kattintson a Csoportházirend csomópontra.

Helye:

  • házirendnév házirend
  • Számítógép konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Csoportházirend

Csoportházirend háttérben történő frissítésének letiltása

Megakadályozza a csoportházirendek frissítését a számítógép használata közben. Ez a házirend a számítógépek, felhasználók és tartományvezérlők csoportházirend-beállításaira vonatkozik. Ha ezt a házirendet engedélyezi, a rendszer a számítógép- és a felhasználói házirendek frissítése előtt addig vár, amíg a jelenlegi felhasználó ki nem jelentkezik a rendszerből.

Ha ezt a házirendet letiltja, a frissítés akkor is alkalmazható, ha a felhasználó éppen használja a számítógépet. A frissítések gyakoriságát a Számítógépek csoportházirendjének frissítési időköze és a Felhasználók csoportházirendjének frissítési időköze beállítás határozza meg.

Csoportházirend aszinkron alkalmazása számítógépekre rendszerindításkor

Arra utasítja a rendszert, hogy várja meg a bejelentkezési párbeszédpanel megjelenítése előtt, míg a csoportházirend frissítése befejeződik. Ez a házirend csak a Számítógép konfigurációja csomóponton lévő csoportházirend-beállításokra vonatkozik.

Ha ezt a házirendet engedélyezi, a felhasználó addig nem tud a rendszerre bejelentkezni, amíg a számítógép csoportházirendjének frissítése be nem fejeződött.

Ha ezt a házirendet letiltja, a rendszer a felhasználó bejelentkezése előtt nem várja meg, míg a csoportházirend frissítése befejeződik. Így elképzelhető, hogy a bejelentkezési párbeszédpanel előbb jelenik meg, ellenben a Windows felület az összes csoportházirend-beállítás alkalmazása előtt lesz látható.

Keresse meg a Csoportházirend aszinkron alkalmazása számítógépekre rendszerindításkor házirendet annak meghatározásához, hogy a rendszer szinkronizálja-e a felhasználói csoportházirend-beállításokat és a Windows Intézőt.

Csoportházirend aszinkron alkalmazása felhasználókra bejelentkezéskor

Arra utasítja a rendszert, hogy várja meg a bejelentkezési párbeszédpanel megjelenítése előtt, míg a csoportházirend frissítése befejeződik. Ez a házirend csak a Felhasználó konfigurációja csomóponton megjelenő csoportházirend beállításokra érvényes. Ha ezt a házirendet engedélyezi, a felhasználó addig nem tud a rendszerre bejelentkezni, amíg a felhasználó csoportházirend-beállításainak frissítése be nem fejeződik.

Ha ezt a házirendet letiltja, a rendszer a felhasználók bejelentkezése előtt nem várja meg, amíg a házirend frissítése befejeződik. Így elképzelhető, hogy a Bejelentkezés a Windows rendszerbe párbeszédpanel később jelenik meg, ellenben a Windows felület az összes házirend alkalmazása előtt lesz látható. Keresse meg a Csoportházirend aszinkron alkalmazása számítógépekre rendszerindításkor házirendet annak meghatározásához, hogy a rendszer szinkronizálja-e a számítógép házirendjeit és a Windows Intézőt.

Számítógépek csoportházirendjének frissítési időköze

Megadja, hogy a rendszer milyen gyakran frissíti a számítógépek csoportházirendjét a számítógép használata közben (a háttérben). Ez a házirend csak a Számítógép konfigurációja csomóponton lévő csoportházirend-beállításokra vonatkozóan adja meg a háttérben történő frissítés gyakoriságát.

A frissítési időközökön kívül a számítógépek csoportházirendje a rendszer indításakor mindig frissítődik.

Ha ezt a házirendet letiltja, a csoportházirend 90 percenként frissítődik (alapértelmezés szerint) – amely 0-30 perccel eltolódhat. A frissítési időköz 0 és 64 800 perc (45 nap) között adható meg. Ha 0 percet választ, a számítógép a csoportházirendet 7 másodpercenként próbálja meg frissíteni. A frissítés félbeszakíthatja a felhasználó munkáját és növelheti a hálózat leterheltségét, így a rövid frissítési időköz legtöbb telepítéshez nem javasolt.

Ha meg szeretné adni, hogy a számítógép használatakor a rendszer ne frissítse a csoportházirendet, jelölje ki a Csoportházirend háttérben történő frissítésének letiltása házirendet.

A Számítógépek csoportházirendjének frissítési időköze házirend is használható a tényleges frissítési időköz változásának megadásához. Ugyanolyan frissítési időköz beállítású ügyfelek frissítésének egyidejű kérését a rendszer úgy akadályozza meg, hogy véletlenszerű időtartammal elcsúsztatja az egyes ügyfelek frissítési időközeit. A véletlenszerű időközt megadó mezőben lévő szám megadja az időköz módosításának felső határát. Például a mezőben 30 perc megadásakor a rendszer az időköz megváltoztatására 0 és 30 perc közötti értéket választ ki. Nagy szám megadása széles tartományt eredményez, így kisebb az esély az ügyfelek kéréseinek átfedésére. Ez azonban a frissítések jelentős mértékű késésével járhat.

Ez a házirend állítja be a számítógép csoportházirendjének frissítési időközét. A felhasználói házirendek frissítési időközének beállításához használja a Felhasználók csoportházirendjének frissítési időköze házirendet (megtalálható a Felhasználó konfigurációja\Felügyeleti sablonok\Rendszer\Csoportházirend csomóponton).

Ez a házirend csak akkor használatos, amikor a Csoportházirend háttérben történő frissítésének letiltása házirend le van tiltva.

Megjegyzés

  • Hogy a házirend frissítéséről tudomással legyenek, javasolt a felhasználók értesítése arról, hogy házirendjük időközönként frissül. A csoportházirend frissítésekor a Windows Asztal is frissül oly módon, hogy rövid ideig villog, és a megnyitott menük bezárulnak. Továbbá a csoportházirend-beállításokban megszabott korlátozások (például a felhasználók által futtatható programok korlátozása) gátolhatják a folyamatban lévő feladatok elvégzését.

Tartományvezérlők csoportházirendjének frissítési időköze

Megadja, hogy milyen gyakran frissítse a rendszer tartományvezérlők (háttérben) futása közben azok csoportházirendjét. A házirend által megadott frissítés a rendszer indításakor végrehajtott frissítéseken felül történik.

Alapértelmezés szerint a tartományvezérlők csoportházirendje 5 percenként frissül.

A frissítési időköz 0 és 64 800 perc (45 nap) között adható meg. Ha 0 percet választ, a tartományvezérlő a csoportházirendet 7 másodpercenként próbálja meg frissíteni. A frissítés félbeszakíthatja a felhasználó munkáját és növelheti a hálózat leterheltségét, így a rövid frissítési időköz legtöbb telepítéshez nem javasolt.

Ha ezt a házirendet letiltja, a tartományvezérlő a csoportházirendet 5 percenként frissíti (alapértelmezés szerint). Ha meg szeretné adni, hogy a számítógép használatakor a rendszer ne frissítse a felhasználók csoportházirendjét, válassza a Csoportházirend háttérben történő frissítésének letiltása házirendet.

A házirend ugyancsak használható a tényleges frissítési időköz változásának megadásához. Ugyanolyan frissítési időköz beállítású tartományvezérlők frissítésének egyidejű kérését a rendszer úgy akadályozza meg, hogy véletlenszerű időtartammal elcsúsztatja az egyes tartományvezérlők frissítési időközeit. A véletlenszerű időközt megadó mezőben lévő szám megadja az időköz módosításának felső határát. Például a mezőben 30 perc megadásakor a rendszer az időköz megváltoztatására 0 és 30 perc közötti értéket választ ki. Nagy szám megadása széles tartományt eredményez, így kisebb az esély a frissítés kéréseinek átfedésére. Ez azonban a frissítések jelentős mértékű késésével járhat.

Megjegyzés

  • Ez a házirend csak egy tartomány, hely, szervezeti egység vagy testreszabott csoport házirendjeinek létrehozásakor használatos. Ha csak egy helyi számítógép számára hoz létre házirendet, a rendszer figyelmen kívül hagyja ezt a házirendet.

Felhasználói csoportházirend visszacsatolás-feldolgozó mód

Alternatív felhasználói házirend-beállításokat alkalmaz, amikor a felhasználó olyan számítógépre jelentkezik be, melyen ez a házirend-beállítás van érvényben. A lehetséges beállítások a következők: Normál, Összefésülés és Csere.

Ez a házirend a rendszert arra utasítja, hogy minden olyan felhasználóra alkalmazza a számítógép csoportházirend objektumainak halmazát, akik ezzel a házirend-beállítással felügyelt számítógépre jelentkeznek be. Ez olyan speciális használatú számítógépekre készült (például nyilvános helyeken, laboratóriumokban és tantermekben), melyek felhasználói házirend-beállításait a használt számítógéptől függően kell módosítani.

Alapértelmezés szerint a felhasználó csoportházirend-objektumai határozzák meg, hogy mely felhasználói házirend-beállítások vannak érvényben. Ha ennek a házirendnek az engedélyezése esetén a számítógépre egy felhasználó bejelentkezik, a számítógép csoportházirend-objektumai határozzák meg, hogy a csoportházirend-objektumok melyik halmaza van érvényben.

E házirend használatához válassza ki az alábbi házirendmódok egyikét a Mód mezőből:

A Csere beállítás azt jelzi, hogy ezen számítógép csoportházirend-objektumaiban meghatározott felhasználói házirend-beállítások felülbírálják a felhasználóra általában érvényes felhasználói házirend-beállításokat.

Az Összefésülés beállítás azt jelzi, hogy a rendszer e számítógép csoportházirend-objektumaiban meghatározott felhasználói házirend-beállításokat és a felhasználóra általában érvényes felhasználói házirend-beállításokat egyesíti. Ha a házirend-beállítások ütköznek, akkor a számítógép csoportházirend-objektumában lévő felhasználói beállításoknak elsőbbségi joguk van a felhasználóra általában érvényes házirend-beállításokkal szemben.

Ha ezt a házirendet letiltja, vagy nem konfigurálja, a felhasználó csoportházirend-objektumai határozzák meg, hogy mely felhasználói házirendek vannak érvényben.

Lassú csoportházirend-kapcsolat felismerése

Lassú kapcsolatot ad meg a csoportházirend beállítások alkalmazására és frissítésére.

Ha a tartományvezérlőről átvitt adat – amely a számítógép házirendfrissítését biztosítja ebben a csoportban – átviteli sebessége lassabb, mint az ebben a házirendben meghatározott átviteli sebesség, a rendszer a kapcsolatot lassúnak tekinti.

A házirendek átvitelére lassú kapcsolat esetén a rendszer válaszideje változhat, a házirendektől függően. A házirendet megvalósító program megadhatja a lassú kapcsolatra adott választ. A mappa házirend-feldolgozó házirendjei felhasználhatók a program által a lassú kapcsolatokra meghatározott válaszok érvénytelenítésére.

A házirend használatához a Kapcsolat sebessége mezőbe írjon be egy 0 és 4 294 967 200 (0xFFFFFFA0) közötti számot, mely az átviteli sebességet jelenti kilobit/másodpercben. Az ennél lassabb átviteli sebességű kapcsolatokat a rendszer lassúnak tekinti. Ha a mezőben nullát ad meg, a rendszer minden kapcsolatot gyorsnak tekint.

Ha ezt a házirendet letiltja vagy nem állítja be, a rendszer az 500 kilobit/másodperces értéket használja alapértelmezettként.

Ez a házirend a Számítógép konfigurációja és Felhasználó konfigurációja csomóponton jelenik meg. A Számítógép konfigurációja csomóponton található házirend a Számítógép konfigurációja csomóponton lévő házirendekre határozza meg a lassú kapcsolatot. A Felhasználó konfigurációja csomóponton található házirend a Felhasználó konfigurációja csomóponton lévő házirendekre határozza meg a lassú kapcsolatot.

A Rendszerleíró adatbázis házirend frissítése

E házirend konfigurálásához használható a Ne alkalmazza háttérben történő rendszeres feldolgozás közben és a Frissítés változatlan csoportházirend-objektumok esetén is beállítás. A két beállítás egymástól független.

Ez a házirend azt határozza meg, hogy a rendszerleíró adatbázis házirendjei mikor frissüljenek, és a Felügyeleti sablonokban lévő összes házirendre és a rendszerleíró adatbázisban értékeket tároló házirendekre van hatással. Felülbírálja azokat a testreszabott beállításokat, melyeket egy rendszerleíró adatbázis házirendet megvalósító program adott meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

A Mappaátirányítás házirend frissítése

Ezen házirend konfigurálására használható a Ne alkalmazza háttérben történő rendszeres feldolgozás közben és a Frissítés változatlan csoportházirend-objektumok esetén is beállítás. A két beállítás egymástól független.

Ez a házirend azt határozza meg, hogy a mappaátirányítási házirendek mikor frissüljenek, továbbá ez a csoportházirend Mappaátirányítás összetevőjét használó összes házirendjére hatással van (például a Windows beállításai\Mappa átirányítása csomóponton lévőkre). A mappaátirányítási házirendet csak az Active Directoryban tárolt csoportházirend-objektumokra lehet beállítani, a helyi számítógépen lévő csoportházirend-objektumokra nem.

Felülbírálja azokat a testreszabott beállításokat, melyeket egy mappaátirányítási házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok éppen a lassú hálózati kapcsolaton átvitel alatt állnak (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

A Lemezkvóta házirend frissítése

Ha ez a házirend van beállítva, a független választási lehetőségek a következők: Frissítés engedélyezése lassú hálózati kapcsolaton keresztül, Ne alkalmazza háttérben történő rendszeres feldolgozás közben és Frissítés változatlan csoportházirend-objektumok esetén is.

Ez a házirend meghatározza, hogy a lemezkvóta házirendek mikor frissüljenek, továbbá hatással van a csoportházirend lemezkvóta összetevőjét használó valamennyi házirendre (például a Számítógép konfigurációja\Felügyeleti sablonok\Rendszer\Lemezkvóták csomóponton lévőkre). Felülbírálja azokat a testreszabott beállításokat is, melyeket egy lemezkvóta házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok lassú hálózati kapcsolaton kerülnek továbbításra (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

A Parancsfájlok házirend frissítése

Ha ez a házirend van beállítva, a független választási lehetőségek a következők: Frissítés engedélyezése lassú hálózati kapcsolaton keresztül, Ne alkalmazza háttérben történő rendszeres feldolgozás közben és Frissítés változatlan csoportházirend-objektumok esetén is.

Ez a házirend meghatározza, hogy a megosztott parancsfájlokat kijelölő házirendek mikor frissüljenek, továbbá hatással van a csoportházirend Parancsfájl összetevőjét használó valamennyi házirendre (például a Windows beállításai\Parancsfájlok csomóponton lévőkre). Felülbírálja azokat a testreszabott beállításokat is, melyeket egy parancsfájl-házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok éppen a lassú hálózati kapcsolaton átvitel alatt állnak (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

A Biztonság házirend frissítése

Ezen házirend beállításakor a következő független választási lehetőségek használhatók: Ne alkalmazza háttérben történő rendszeres feldolgozás közben és Frissítés változatlan csoportházirend-objektumok esetén is.

A házirend azt határozza meg, hogy a biztonsági házirendek mikor frissüljenek, továbbá ez a csoportházirend biztonsági összetevőjét használó valamennyi házirendre hatással van (például a Windows beállításai\Biztonsági beállítások csomóponton lévőkre). Felülbírálja azokat a testreszabott beállításokat is, melyeket egy biztonsági házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok lassú hálózati kapcsolaton kerülnek továbbításra (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

Az EFS-helyreállító házirend frissítése

Ha ez a házirend van beállítva, a független választási lehetőségek a következők: Frissítés engedélyezése lassú hálózati kapcsolaton keresztül, Ne alkalmazza háttérben történő rendszeres feldolgozás közben és Frissítés változatlan csoportházirend-objektumok esetén is.

Ez a házirend azt határozza meg, hogy a titkosítási házirendek mikor frissüljenek, és a csoportházirend titkosítási összetevőjét használó valamennyi házirendre hatással van (például a Windows beállításai\Biztonsági beállítások csomóponton lévőkre). Felülbírálja azokat a testreszabott beállításokat is, melyeket egy titkosítási házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok lassú hálózati kapcsolaton kerülnek továbbításra (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

A Szoftvertelepítés házirend frissítése

Ezen házirend beállításakor a következő független választási lehetőségek használhatók: Frissítés engedélyezése lassú hálózati kapcsolaton keresztül és Frissítés változatlan csoportházirend-objektumok esetén is.

A házirend azt határozza meg, hogy a szoftvertelepítési házirendek mikor frissüljenek, és a csoportházirend szoftvertelepítési összetevőjét használó valamennyi házirendre hatással van (például a Szoftverbeállítások\Szoftvertelepítés csomóponton lévőkre). A szoftvertelepítési házirendet csak az Active Directoryban tárolt csoportházirend-objektumokra lehet beállítani, a helyi számítógépen lévő csoportházirend-objektumokra nem.

Felülbírálja azokat a testreszabott beállításokat, melyeket egy szoftvertelepítési házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok lassú hálózati kapcsolaton kerülnek továbbításra (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

Az IP-biztonság házirend frissítése

Ha ez a házirend van beállítva, a független választási lehetőségek a következők: Frissítés engedélyezése lassú hálózati kapcsolaton keresztül, Ne alkalmazza háttérben történő rendszeres feldolgozás közben és Frissítés változatlan csoportházirend-objektumok esetén is.

Ez a házirend azt határozza meg, hogy az IP-biztonsági házirendek mikor frissüljenek, és a csoportházirend IP-biztonsági összetevőjét használó valamennyi házirendre hatással van (például a helyi számítógépen lévő Számítógép konfigurációja\Windows beállításai\Biztonsági beállítások\IP-biztonsági házirendek csomóponton lévőkre). Felülbírálja azokat a testreszabott beállításokat is, melyeket egy IP-biztonsági házirendet megvalósító program ad meg telepítéskor.

Ha ezt a házirendet engedélyezi, a jelölőnégyzetek használhatók a beállítások megváltoztatására. Ha ezt a házirendet letiltja vagy nem állítja be, a házirend nincs hatással a rendszerre.

A Frissítés engedélyezése lassú hálózati kapcsolaton keresztül beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti, ha azok lassú hálózati kapcsolaton kerülnek továbbításra (például telefonvonalon). A lassú kapcsolaton történő frissítés jelentős késéssel járhat.

A Ne alkalmazza háttérben történő rendszeres feldolgozás közben beállítás megakadályozza, hogy a háttérben a rendszer frissítse az érintett házirendeket a számítógép használatakor. A háttérben történő frissítés megszakíthatja a felhasználó munkáját, mely a felhasznált program leállásához vagy nem megfelelő működéséhez vezethet, sőt olykor adatkárosodással is járhat.

A Frissítés változatlan csoportházirend-objektumok esetén is beállítás kiválasztásakor a rendszer a házirendeket még akkor is frissíti és újra alkalmazza, ha a házirendek nem változtak. Számos házirend-megvalósítás meghatározza, hogy csak a házirendek megváltozásakor frissítse a rendszer a házirendeket. Javasolt azonban a módosítatlan házirendek frissítése, például ha egy felhasználó megváltoztat egy beállítást, és azt újra érvénybe kívánja helyezni.

Hiányzó COM-komponensek letöltése

Arra utasítja a rendszert, hogy az Active Directoryban a programok által igényelt hiányzó Component Object Model (COM) elemeket keresse.

Számos Windows alapú program, például a Microsoft Management Console beépülő modulok, a COM által biztosított illesztőket használja. Ezek a programok csak akkor képesek minden funkciójukat végrehajtani, ha a szükséges összetevők a Windows 2000 rendszerben jegyezve lettek.

Ha ezt a házirendet engedélyezi és egy összetevőbejegyzés hiányzik, a rendszer az Active Directoryban keresi a hiányzó elemet, és ha megtalálta, letölti azt. Az ebből adódó keresési eljárások bizonyos programok indítását vagy futását lelassíthatják.

Ha ezt a házirendet letiltja vagy be sem állítja, a program regisztráció nélkül folytatódik. Így lehetséges, hogy a program nem képes végrehajtani összes funkcióját, sőt a futása is leállhat.

Ez a házirend számítógépekre vonatkozik. A házirend felhasználókra történő alkalmazásához használja a Felhasználó konfigurációja\Felügyeleti sablonok\Rendszer\Csoportházirend csomóponton lévő Hiányzó COM-komponensek letöltése házirendet.


Csoportházirend konfigurálása

  • Csoportházirend hatókörének kibővítése
  • Csoportházirend azonnali frissítése
  • Engedélyek megadása csoportházirend kezeléséhez
  • A számítógépre vonatkozó csoportházirend frissítési időközének beállítása
  • Csoportházirend egyéb házirendjeinek beállítása


Új csoportházirend-objektum létrehozása

  1. Egy tartományhoz vagy szervezeti egységhez csatolt csoportházirend létrehozásához nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

    vagy

    Egy helyhez csatolt csoportházirend létrehozásához nyissa meg az Active Directory - helyek és szolgáltatások ablakot.

  2. A konzolfán a jobb oldali egérgombbal kattintson az újonnan létrehozott csoportházirendhez csatolandó helyre, tartományra vagy szervezeti egységre. (A rendszer ezt a jelenlegi tartományban fogja tárolni.)
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. Kattintson az Új gombra, írja be a csoportházirend-objektum nevét, majd kattintson a Bezárás gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.
  • Alapértelmezés szerint a rendszer az újonnan létrehozott csoportházirend-objektumot ahhoz a helyhez, tartományhoz vagy szervezeti egységhez csatolja, amelyiket a Microsoft Management Console segédprogramban kijelölte annak létrehozásakor. Ezáltal annak beállításai az adott helyre, tartományra vagy szervezeti egységre vonatkoznak. Elképzelhető, hogy a csoportházirend-objektumot szét kívánja választani a helytől, tartománytól vagy a szervezeti egységtől, hogy beállításai ne vonatkozzanak azokra. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Alapértelmezett engedélyek

A csoportházirend-objektumok alapértelmezett engedélyei a következők:

Biztonsági csoport | Alapértelmezett beállítások
Hitelesített felhasználók | Olvasás, Csoportházirend alkalmazása
Helyi rendszer | Teljes hozzáférés (beleértve a Csoportházirend alkalmazását is)
Tartománygazdák | Olvasás, Írás, Gyermekobjektum létrehozása, Gyermekobjektum törlése, Csoportházirend alkalmazása
Rendszergazdák | Olvasás, Írás, Gyermekobjektum létrehozása, Csoportházirend alkalmazása

Alapértelmezés szerint egy rendszergazda nem törölheti az Alapértelmezett tartományi házirend csoportházirend-objektumot. Ez megakadályozza e tartományhoz szükséges és fontos beállításokat tartalmazó csoportházirend-objektum véletlen törlését. Ha annak törlésére valóban szükség van — például azért, mert a házirendek beállítása egy másik csoportházirend-objektumban történt meg --, akkor a Törlés hozzáférés-szabályozási bejegyzést vissza kell adni a megfelelő csoportnak.


Csoportházirend-objektum törlése

  1. Nyissa meg az Active Directoy - felhasználók és számítógépek ablakot.

  2. A konzolfán kattintson a tartományban a jobb oldali egérgombbal a tartományra vagy a szervezeti egységre.
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A tartományban tárolt összes csoportházirend-objektum megkereséséhez kattintson a Hozzáadás gombra, hogy megnyissa a Csoportházirend-objektumok hivatkozásainak hozzáadása párbeszédpanelt, majd kattintson a Minden fülre.
  5. Kattintson a jobb oldali egérgombbal a törölni kívánt csoportházirend-objektumra, majd kattintson a Törlés gombra.
  6. A törlés jóváhagyásának megkérdezésekor kattintson az Igen gombra, majd az OK gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • A Csoportházirend-objektum törlése után az már nincs hatással a csatolt helyekre, tartományokra vagy szervezeti egységekre. Elképzelhető, hogy inkább le szeretné tiltani a csoportházirend-objektumot. További tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csoportházirend-objektum Számítógép konfigurációja beállításainak letiltása

  1. Nyissa meg a szerkeszteni kívánt csoportházirend-objektumot.
  2. Kattintson a jobb oldali egérgombbal az alábbi módon megjelenő konzolgyökérre:
    Csoportházirend-objektum_neve [tartománynév] házirend
  3. Kattintson a Tulajdonságok parancsra.
  4. Bizonyosodjon meg arról, hogy a Számítógép-konfigurációs beállítások tiltása jelölőnégyzet be legyen jelölve, majd kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A csoportházirend-objektumban a Számítógép konfigurációja beállítások letiltásakor a beállítások nincsenek hatással a csoportházirend-objektumhoz csatolt helyekre, tartományokra vagy szervezeti egységekre.

Kapcsolódó témakörök


Hely, tartomány vagy szervezeti egység csoportházirend-objektumának letiltása

  1. Egy tartomány vagy szervezeti egység csoportházirend-objektumának letiltásához nyissa meg az Active Directory - felhasználók és számítógépek ablakot.

    vagy

    A hely csoportházirend-objektumának letiltásához nyissa meg az Active Directory - helyek és szolgáltatások ablakot.
  2. A konzolon kattintson a jobb oldali egérgombbal arra a helyre, tartományra vagy szervezeti egységre, melytől a csoportházirend-objektumot szét kívánja választani (hogy az adott helyre, tartományra vagy szervezeti egységre vonatkozzon a letiltás).
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. Válassza ki a törölni kívánt csoportházirend-objektumot, majd kattintson a Törlés gombra. Megjelenik a Törlés párbeszédpanel.
  5. Ellenőrizze, hogy A hivatkozás eltávolítása a listából választógomb ki legyen választva, majd a Törlés párbeszédpanelen kattintson az OK gombra.

Fontos

  • Ha kiválasztja A hivatkozás eltávolítása és a csoportházirend-objektum végleges törlése választógombot, akkor ezek a csoportházirend-beállítások már nem vonatkoznak csoportházirend-objektumhoz csatolt helyekre, tartományokra vagy szervezeti egységekre.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.


Csoportházirend-objektum Felhasználó konfigurációja beállításainak letiltása

  1. Nyissa meg a szerkeszteni kívánt csoportházirend-objektumot.
  2. Kattintson a jobb oldali egérgombbal az alábbi módon megjelenő kezelőpult-gyökérre:
    Csoportházirend-objektum_neve [tartománynév] házirend
  3. Kattintson a Tulajdonságok parancsra, majd bizonyosodjon meg arról, hogy a Felhasználókonfigurációs beállítások tiltása jelölőnégyzet be legyen jelölve, majd kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Csoportházirend-objektumban a Felhasználó konfigurációja beállítások nincsenek hatással a csoportházirend-objektumhoz csatolt helyekre, tartományokra vagy szervezeti egységekre.

Kapcsolódó témakörök


Csoportházirend-objektum szerkesztése

  1. Nyissa meg a módosítani kívánt csoportházirend-objektumot.
  2. A beállítások módosításához kattintson duplán a részletes ablaktáblán lévő elemekre.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A csoportházirend-objektum megnyitásához Olvasás és Írás engedéllyel kell rendelkeznie.
  • A csoportházirend-objektum szerkesztése közben javasolt annak letiltása, mivel a csoportházirend-objektum beállításain végzett módosítások azonnal érvénybe kerülnek. Egy csoportházirend-objektum letiltásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csoportházirend hatókörének szűrése biztonsági csoporttagság szerint

  1. Nyissa meg azt a csoportházirend-objektumot, melynek hatókörét szűrni kívánja.
  2. Kattintson a jobb oldali egérgombbal a konzolnak arra a gyökércsomópontjára, amely egy csoportházirend-ikont ábrázol, melyet az alábbi címke követ:
    Csoportházirend-objektum_neve [tartományvezérlő_neve.tartománynév] házirend
  3. Kattintson a Tulajdonságok parancsra, majd a Biztonság fülre, végül arra a biztonsági csoportra, melynek segítségével a csoportházirend-objektumot szűrni kívánja.

    Ha szükség van a csoportházirend-objektum szűréséhez használt biztonsági csoport megváltoztatásra, biztonsági csoportok adhatók hozzá vagy távolíthatók el a Hozzáadás vagy az Eltávolítás gombok használatával.

  4. Adja meg az engedélyeket az alábbi táblázat szerint, majd a csoportházirend-objektum tulajdonságlapján kattintson az OK gombra.
Szándék | Adja meg ezeket az engedélyeket | Eredmény
A biztonsági csoport tagjainak magukra kell alkalmazni ezt a csoportházirend-objektumot. | Állítsa a Csoportházirend alkalmazása elemet az Engedélyezve beállításra. Állítsa az Olvasás elemet az Engedélyezve beállításra. | Ez a csoportházirend-objektum a biztonsági csoport tagjaira érvényes, hacsak azok nem tagjai legalább egy másik olyan biztonsági csoportnak, melynek a Csoportházirend alkalmazása vagy az Olvasás eleme (vagy mindkettő) Megtagadva beállítású.
Ezen biztonsági csoport tagjaira nem vonatkoznak e csoportházirend-objektum beállításai. | Állítsa a Csoportházirend alkalmazása elemet a Megtagadva beállításra. Állítsa az Olvasás elemet a Megtagadva beállításra. | Ennek a csoportházirend-objektumnak a szabályai nem érvényesek erre a biztonsági csoportra, tekintet nélkül a biztonsági csoport tagjainak más biztonsági csoportban megadott engedélyeire.
Ezen biztonsági csoport tagjait nem befolyásolja a csoportházirend-objektum alkalmazása. | Ne állítsa a Csoportházirend alkalmazása elemet se az Engedélyezve beállításra, se a Megtagadva beállításra. Ne állítsa az Olvasás elemet se az Engedélyezve, se a Megtagadva beállításra. | Ezen csoportházirend-objektum szabályai csak, és csakis akkor érvényesek e biztonsági csoport tagjaira, ha mind a Csoportházirend alkalmazása, mind az Olvasás elem az Engedélyezve beállításra van állítva legalább egy másik biztonsági csoport tagjaként. Továbbá a Csoportházirend alkalmazása vagy az Olvasás elem nem lehet a Megtagadva beállításra állítva semmilyen más biztonsági csoport tagjaként.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A csoportházirend-objektumok csak helyekre, tartományokra vagy szervezeti egységekre alkalmazhatók. A csoportházirend-beállítások csak a bennük lévő felhasználókra és a számítógépekre érvényesek. A csoportházirend-objektumok nem alkalmazhatók biztonsági csoportokra.
  • A biztonsági csoport helye az Active Directoryban nem befolyásolja a biztonsági csoportnak ebben az eljárásban leírt szűrését.
  • Ha egy felhasználó vagy egy számítógép nincs azon a helyen, abban a tartományban vagy szervezeti egységben, melyre a csoportházirend-objektum házirendjei hivatkozáson keresztül közvetlenül, illetve öröklés útján közvetetten érvényesek, akkor egyik biztonsági csoport engedélyeinek kombinációi szerint sem lehetséges, hogy ezekre a felhasználókra és számítógépekre a csoportházirend-beállítások érvényben legyenek.
  • Az itt leírt, csoportházirend-objektum szintjén történő szűrés azt eredményezi, hogy a rendszer csoportházirend-objektumot nem teljesen dolgozza fel. A Szoftvertelepítés és a Mappa átirányítása bővítmény a biztonsági csoportokat használja a csoportházirend-objektum szintjénél részletesebb szabályozásra. A Mappa átirányítása és a Szoftvertelepítés bővítmények kivételével a biztonsági csoportok nem használatosak a csoportházirend-objektum egyedi beállításainak, illetve alhalmazainak szűrésére. Az egyedi beállítások szabályozásához szerkesszen vagy hozzon létre e helyett egy csoportházirend-objektumot.

Kapcsolódó témakörök


Csoportházirend-objektumhoz csatolt helyek, tartományok és szervezeti egységek keresése

  1. Nyissa meg a csoportházirendet a kívánt csoportházirend-objektummal a konzolon a gyökércsomópontnál.
  2. Kattintson a jobb oldali egérgombbal a konzol gyökércsomópontjára, majd kattintson a Tulajdonságok parancsra.
  3. Kattintson a Csatolások fülre, majd a Keresés most gombra. A Talált helyek, tartományok és szervezeti egységek mezőben megtekinthetők a Csoportházirend-objektumhoz csatolt helyek, tartományok és szervezeti egységek.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha a Csoportházirend-objektum több tartományhoz van csatolva, a Tartomány legördülő menü segítségével a szervezeti egységek keresése leszűkíthető egyszerre egy tartományra.

Kapcsolódó témakörök


Mappa átirányítása

A Csoportházirend beépülő modul Mappa átirányítása bővítménye révén a Windows 2000 speciális mappáinak hálózati helyekre történő átirányítására végezhető el. Speciális mappa például a Dokumentumok és a Képek mappa, melyek a Documents and Settings mappában találhatók.

A Mappa átirányítása a Csoportházirend konzol Felhasználó konfigurációja csomópontján található.

Helye:

  • házirendnév házirend
  • Felhasználó konfigurációja
  • Windows beállításai
  • Mappa átirányítása

Egy felhasználó átirányított mappájának egyéni beállításához javasolt a %username% elérési útba való beépítése; például:
\\kiszolgáló\megosztás\%username%\Dokumentumok

Emellett a speciális mappa átirányítható mindenki számára ugyanazon hálózati megosztásra (ahogy azt a következő részben megtalálhatja: Speciális mappák egy helyre történő átirányítása a helyen, tartományban vagy szervezeti egységben minden felhasználó számára), valamint az átirányítás tovább finomítható a csoportházirend-objektum szintje felett. Például a Felhasználó biztonsági csoport tagjainak Dokumentumok mappáját át lehet irányítani a
\\kiszolgáló1\megosztás\%username%\Dokumentumok mappára, miközben a Vendégek biztonsági csoport Dokumentumok mappája a
\\kiszolgáló2\megosztás\%username%\Dokumentumok mappára van átirányítva. További tudnivalókért tanulmányozza a Speciális mappák különböző helyekre történő átirányítása biztonsági csoporttagság szerint részt.

A Windows 2000 a következő mappák átirányítását engedélyezi:

Speciális mappák | Megjegyzések
Application Data | A Csoportházirend egy beállítása az Application Data mappa viselkedését határozza meg, ha az ügyféloldali gyorsítótár engedélyezve van. Tekintse meg a Felhasználó konfigurációja\Felügyeleti sablonok\Hálózat\Kapcsolat nélküli fájlok csomópontot a Csoportházirend konzolon.
Asztal |
Dokumentumok | További tájékoztatást A Dokumentumok mappa átirányításának előnyei témakörben kaphat.
Dokumentumok\Képek | A Képek mappa a Dokumentumok mappától függetlenül átirányítható, illetve az alapértelmezéshez hasonlóan követheti a Dokumentumok mappa átirányítását is (a Képek mappa a Dokumentumok mappa átirányításakor annak almappája marad). Az alapértelmezett beállítás javasolt, hacsak nem kell valamiért a Képek mappát a Dokumentumok mappától elkülöníteni (például fájlmegosztás méretezhetősége miatt). Ha a mappák el vannak különítve, a Dokumentumok mappában a Képek mappa helyén egy parancsikon szerepel.
Start menü | A Start menü átirányításakor az almappái mindig követik.

A Dokumentumok mappa átirányításának előnyei

Az alábbi előnyök némelyike bármely mappa átirányítása vonatkozik, azonban a Dokumentumok mappa átirányítása különösen hasznos lehet a mappa nagy mérete esetén.

  • Ha egy felhasználó a hálózaton különböző számítógépekre jelentkezik be, dokumentumai akkor is elérhetők.
  • A kapcsolat nélküli fájltechnológiák révén a felhasználó akkor is elérheti a Dokumentumok mappát, ha az nem kapcsolódik a hálózathoz. További tudnivalókért tanulmányozza a következő témakört: Egy fájl vagy mappa elérhetővé tétele kapcsolat nélkül. Ez különösen hasznos a laptop számítógépet használók számára.
  • Központi felhasználói profil használatakor a Dokumentumok mappa hálózati elérési útját használja a rendszer a központi felhasználói profil részeként, nem pedig magát a Dokumentumok mappát. Ezért a mappa tartalmát nem kell az ügyfélszámítógép és a kiszolgáló között oda-vissza másolni a felhasználó minden egyes be- vagy kijelentkezésekor, így a bejelentkezés vagy a kijelentkezés folyamata sokkal gyorsabban megy végbe, mint a Windows NT 4.0 rendszer esetében.
  • Megosztott hálózati kiszolgálón tárolt adatokról biztonsági másolat készíthető a rutinszerű rendszerfelügyelet részeként. Így a művelet biztonságosabb, mivel ahhoz a felhasználó nem szükséges.
  • A rendszergazda a csoportházirendet használhatja a lemezkvóták beállítására a felhasználó speciális mappái által elfoglalt terület nagyságának korlátozásával.
  • A felhasználó adatai átirányíthatók az operációs rendszer fájljait tároló merevlemezről a felhasználó helyi számítógépén lévő másik merevlemezre. Ez a felhasználó adatait biztonságosabbá teszi, amennyiben az operációs rendszer újratelepítése szükséges.

Mappák átirányításával kapcsolatos tudnivalókért tanulmányozza a Gyakorlati tanácsok témakört.

Mappák alapértelmezett helyei

Nem átirányított speciális mappák alapértelmezett helyei a korábban telepített operációs rendszertől függnek:

Operációs rendszer | Speciális mappák helye
Windows 2000 új telepítése (előző operációs rendszer nem volt még telepítve) | %systemroot%\Documents and Settings; például, C:\Documents and Settings
Frissítés Windows 2000 rendszerre Windows NT 4.0 vagy Windows NT 3.51 rendszerről | %systemroot%\Profiles; például, C:\WinNT\Profiles
Frissítés Windows 2000 rendszerre letiltott felhasználói profilú Windows 95 vagy Windows 98 rendszerről | %systemroot%\Documents and Settings; például, C:\Documents and Settings
Frissítés Windows 2000 rendszerre engedélyezett felhasználói profilú Windows 95 vagy Windows 98 rendszerről | %systemroot%\Profiles; például C:\Windows\System\Profiles

A felhasználói profilokkal kapcsolatos további tudnivalókért tanulmányozza a Felhasználói profilok című témakört.

Házirend eltávolításával kapcsolatos szempontok

A következő táblázat azt foglalja össze, hogy mi történik az átirányított mappákkal és tartalmukkal, ha azokra a csoportházirend-objektum már nem érvényes.

A speciális mappa tartalmának áthelyezése az új helyre beállítás Házirend eltávolítása beállítás A végeredmény a házirend eltávolítása után
Engedélyezve A mappát visszairányítja a felhasználói profil helyhez a házirend eltávolításakor.
  • A speciális mappa újra a felhasználói profil helyen található.
  • Annak tartalmát a rendszer a felhasználói profil helyhez másolja, nem pedig áthelyezi.
  • A rendszer nem törli a mappa tartalmát az átirányított helyről.
  • A felhasználó továbbra is elérheti a mappa tartalmát, de csak a helyi számítógépen.
Letiltva A mappát visszairányítja a felhasználói profil helyhez a házirend eltávolításakor.
  • A speciális mappa újra a felhasználói profil helyen található.
  • A rendszer nem másolja át, és nem is helyezi át a mappa tartalmát a felhasználói profil helyhez.

  • Vigyázat!

    Ha a mappa tartalmát a rendszer nem másolja át a felhasználói profil helyhez, a felhasználó azt már nem érheti el.
Vagy Engedélyezve vagy Letiltva Házirend eltávolításakor hagyja a mappát az új helyen.
  • A speciális mappa az átirányított helyen marad.
  • A mappa tartalma az átirányított helyen marad.
  • A felhasználó továbbra is elérheti az átirányított mappa tartalmát.


A Mappa átirányítása beépülő modul használata

  • Egy helyre történő átirányítás a hely, tartomány vagy szervezeti egység minden felhasználója számára
  • Átirányítás különböző helyekre biztonsági csoporttagság szerint


Csoportházirend – áttekintés

A Csoportházirend beépülő modul azonnali használatához tanulmányozza a Csoportházirend beépülő modul megnyitásának módjai témakört.

A csoportházirend-beállítások a felhasználó munkakörnyezetének olyan összetevőit határozzák meg, melyet a rendszergazdának kell kezelnie; például a felhasználók számára elérhető programokat, a felhasználó Asztalán megjelenő programokat és a Start menü elemeit. A Csoportházirend beépülő modul használható az Asztal adott konfigurációjának létrehozásához egy adott felhasználói csoport számára. A megadott csoportházirend-beállításokat a csoportházirend-objektum tartalmazza, amely viszont a kiválasztott Active Directory objektumokkal van társítva: helyekkel, tartományokkal vagy szervezeti egységekkel.

A csoportházirend a felhasználókat érintő Felhasználó konfigurációja beállításokat és a számítógépeket érintő Számítógép konfigurációja beállításokat tartalmazza.

A Csoportházirend és a bővítményei segítségével az alábbi feladatok végezhetők el:

  • Rendszerleíró adatbázison alapuló házirend kezelése a Felügyeleti sablonok segítségével. A csoportházirend egy rendszerleíróadatbázis-beállításokat tartalmazó fájlt hoz létre, melyet a rendszer beír a rendszerleíró adatbázis User vagy Local Machine részébe. Egy adott munkaállomásra vagy kiszolgálóra bejelentkező felhasználóra jellemző felhasználói profilbeállításokat a rendszer a rendszerleíró adatbázisba írja be a HKEY_CURRENT_USER (HKCU) rendszerleíró kulcs után, valamint a számítógépre jellemző beállításokat a HKEY_LOCAL_MACHINE (HKLM) rendszerleíró kulcs után.
  • Parancsfájlok hozzárendelése (például számítógép indításához és leállításához, valamint bejelentkezéshez és kijelentkezéshez).
  • Mappák átirányítása hálózati helyekre a helyi számítógépen lévő Documents and Settings mappából.
  • Alkalmazások kezelése (telepítésre kijelölés, közzététel, frissítés vagy javítás). Ezek a műveletek a Szoftvertelepítés bővítmény segítségével végezhetők el.
  • Biztonsági beállítások megadása. A biztonsági beállítások megadásával kapcsolatos tudnivalókért tanulmányozza a Biztonsági beállítások online súgót.

A csoportházirend alkalmazásának módja és ideje

Felhasználó és számítógép házirendje

A felhasználó házirendje (a Csoportházirend konzol Felhasználó konfigurációja csomópontján található beállítások) kerül érvénybe a felhasználó bejelentkezésekor.

A számítógép házirendjének beállításai a Számítógép konfigurációja csomóponton találhatók meg, és érvénybe lépnek a számítógép rendszerindításakor.

A Felhasználók és a Számítógépek az egyedüli olyan Active Directory objektum típusok, melyek házirendet kapnak. A biztonsági csoportokra például nem vonatkozik házirend. Ehelyett — a megfelelő teljesítmény érdekében — a biztonsági csoportok a házirend szűrésére használhatók a Csoportházirend alkalmazása hozzáférés-vezérlési bejegyzés (ACE) segítségével. A bejegyzés az Engedélyezve vagy a Megtagadva beállításokra állítható, vagy nem konfigurált állapotban hagyható.

Alkalmazási sorrend

A rendszer a házirendeket a következő sorrendben alkalmazza:

  1. Az egyedi helyi (számítógépen) csoportházirend-objektum.
  2. Helyi csoportházirend-objektumok
    3. (a rendszergazda által megadott sorrendben).
  3. Tartományi csoportházirend-objektumok
    4. (a rendszergazda által megadott sorrendben).
  4. Szervezeti egységre vonatkozó csoportházirend-objektumok, a legnagyobb szervezeti egységektől kezdve a legkisebbekig (szülő-gyermek szervezeti egység), továbbá az egyes szervezeti egység szinteken a rendszergazda által megadott sorrendben.

Alapértelmezés szerint a később alkalmazott házirendek felülírják a korábban alkalmazottakat ütköző házirend-beállítások esetén. Amennyiben a beállítások nem ellentétesek, mind a korábbi, mind a későbbi házirendek hozzájárulnak az érvényes házirendhez.

A házirend szűrhető a biztonsági csoporttagság segítségével

A csoportházirend-objektum ACE biztonsági csoportja a következő beállításokkal rendelkezik: Nem konfigurált (nincs elsőbbség), Engedélyezve vagy Megtagadva. A Megtagadva beállítás elsőbbségi joggal rendelkezik az Engedélyezve beállítással szemben.

Házirend öröklődésének blokkolása

A nagyobb prioritású helyről, tartományról vagy szervezeti egységről a házirendek öröklődése blokkolható a hely, tartomány vagy szervezeti egység szintjén.

Házirend kényszerítése felülről

Azok a házirendek, melyeket egyébként a gyermek szervezeti egységek felülírnának, a csoportházirend-objektum szinten elláthatók a Nincs felülírás beállítással.

Megjegyzés

  • A Nincs felülírás beállítású házirendek nem blokkolhatók.

A rész tartalma:

  • Felhasználó konfigurációja
  • Számítógép konfigurációja
  • Biztonsági beállítások
  • Felügyeleti sablonok
  • Szoftverbeállítások
  • Windows beállításai
  • Szoftvertelepítés
  • Mappa átirányítása


Csoportházirend lehetőségeinek bővítése

  1. Nyissa meg a Csoportházirendet egyedülálló MMC beépülő modulként.
  2. A Konzol menüben kattintson a Beépülő modul hozzáadása/eltávolítása parancsra.
  3. Kattintson a Bővítések fülre, válassza ki a kívánt beépülő modul bővítményeket, majd kattintson az OK gombra.

Megjegyzés

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csoportházirend-objektumok

A rendszer a házirend-beállításokat csoportházirend-objektumokban tárolja. A Csoportházirend beépülő modul egy olyan alkalmazásnak tekinthető, amely csoportházirend-objektum típusú dokumentumokat kezel, hasonlóképpen a szövegszerkesztő programokhoz, melyek .doc vagy .txt fájlokat használnak.

Helyi és nem helyi csoportházirend-objektumok

Kétfajta csoportházirend-objektum létezik. Az egyik típus a tartományvezérlőn tárolt és csak az Active Directory környezetben elérhető nem helyi csoportházirend-objektum. Ezek a csoportházirend-objektumok a csoportházirend-objektummal társított helyen, tartományban vagy szervezeti egységben lévő felhasználókra vagy számítógépekre érvényesek.

A helyi csoportházirend-objektumokat ez egyes Windows 2000 rendszert használó számítógépek tárolják. Egy számítógépen csak egy helyi csoportházirend-objektum lehet, mely a nem helyi csoportházirend-objektumban lévő beállítások egy részhalmazával rendelkezik. A beállítások ütközésekor a helyi csoportházirend-objektum beállításokat a nem helyi beállítások felülbírálhatják; egyébként mindkét beállítás érvényben marad.


Csoportházirend azonnali frissítése

  1. A Futtatás párbeszédpanel megnyitásához kattintson a Start gombra, majd a Futtatás parancsra.

  2. A Számítógép konfigurációja csomópontnál a házirendek frissítéséhez írja be az alábbiakat, majd kattintson az OK gombra:
    secedit /refreshpolicy MACHINE_POLICY

    A Felhasználó konfigurációja csomópontnál a házirendek frissítéséhez írja be az alábbi szöveget, majd kattintson az OK gombra:
    secedit /refreshpolicy USER_POLICY


Forrásmunkák

A Windows 2000 rendszerrel kapcsolatos további tudnivalókért látogassa meg a következő weblapot: Microsoft Windows (http://www.microsoft.com/) webhely.


A számítógépre vonatkozó csoportházirend frissítési időközének beállítása

  1. Nyissa meg a Csoportházirend beépülő modult a Számítógép konfigurációja\Felügyeleti sablonok csomópontnál, a System.adm fájl telepítése után. (Mivel a rendszer a System.adm fájlt alapértelmezés szerint telepítette, semmi mást nem kell tennie.)
  2. Nyissa meg a Számítógép konfigurációja\Felügyeleti sablonok\Rendszer\Csoportházirend csomópontot a házirendek, köztük a Számítógépek csoportházirendjének frissítési időköze házirend megtekintéséhez.

    Helye:

    • házirendnév házirend
    • Számítógép konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend
  3. A részletek ablaktáblán kattintson duplán a Számítógépek csoportházirendjének frissítési időköze ikonra.
  4. Kattintson a Házirend fülre, majd ellenőrizze, hogy a jelölőnégyzet be van-e jelölve, és nem inaktív állapotban jelenik-e meg.
  5. A legördülő lista segítségével válassza ki a kívánt frissítési időközt és véletlenszerű eltolódási értéket, majd kattintson az OK gombra.
  6. Kattintson duplán a Csoportházirend háttérben történő frissítésének letiltása ikonra. Győződjön meg arról, hogy a jelölőnégyzet jelölésének törlésével a házirend Letiltva legyen, majd kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Az ügyfélszámítógépek a házirendet a tartományvezérlőtől kérik, az alábbi események bármelyikének bekövetkezésekor:
    • Számítógép indításakor
    • Felhasználó bejelentkezésekor
    • Ha egy alkalmazás kér frissítést a RefreshPolicy() API felületen.
    • Ha a felhasználó azonnali frissítést kér.
    • Ha a csoportházirend frissítési időközére vonatkozó házirendek valamelyike engedélyezve van és a frissítési időköz letelt az előzőekben leírtak szerint.

    A tartományvezérlő nem határoz meg házirendet, azt az ügyfélszámítógép kéri.

  • A Csoportházirend frissítési időköz minimális beállítása (nulla perc) esetén a frissítéskérések között valójában hét másodperc telik el. Éles környezetben nem használhatók a nagyon rövid idejű beállítások, csak teszteléshez.
    A Csoportházirend beépülő modul Szoftvertelepítés és a Mappa átirányítása bővítményei figyelmen kívül hagyják a házirendfrissítéseket.

Kapcsolódó témakörök


A Windows 2000 rendszerben található .adm fájlok

A Windows 2000 rendszerben öt Felügyeleti sablon található.

Felügyeleti sablon | Leírás
System.adm | Alapértelmezés szerint telepítve a csoportházirendben. Windows 2000 ügyfelek számára.
Inetres.adm | Alapértelmezés szerint telepítve a csoportházirendben. Internet Explorer házirendek a Windows 2000 ügyfelek számára.
Winnt.adm | A Windows NT 4.0. rendszerre jellemző felhasználói felület beállításai. A Rendszerházirend-szerkesztővel való használathoz (Poledit.exe).
Windows.adm | A Windows 95 és a Windows 98 rendszerekre jellemző felhasználói felület beállításai. A Rendszerházirend-szerkesztővel való használathoz (Poledit.exe).
Common.adm | A Windows NT 4.0, a Windows 95 és a Windows 98 rendszerek gyakori felhasználói felület beállításai. A Rendszerházirend-szerkesztővel való használathoz (Poledit.exe).

A System.adm és az Inetres.adm fájl a csoportházirend számára fenntartott négy rendszerleíróadatbázis-területet használja. Ezen területek helyeivel kapcsolatos tudnivalókért tanulmányozza a Windows NT 4.0 Rendszerházirendek témakört. Bár az utolsó három .adm kiterjesztésű fájl csoportházirendbe tölthető, a Rendszerházirend-szerkesztővel történő használatuk csak korlátozott mértékben javasolt a korábbi verziójú Windows rendszerek felügyeletére.

Rendszerházirend-beállítások láthatósága a Csoportházirend konzolon

Az .adm fájlok csoportházirendhez történő hozzáadásakor (ahogy azt a Felügyeleti sablon (.adm fájlok) hozzáadása vagy eltávolítása témakörben megtalálhatja) alapértelmezés szerint csak az eredeti csoportházirend-fákban megtalálható beállítások láthatók a konzolon. Az alapértelmezett felhasználói beállítások megváltoztatásához a Csoportházirend konzol Nézet menüjében törölje a Csak a házirendek megjelenítése menüpont jelölését. (Hogy a Csak a házirendek megjelenítése menüpont megjelenjen a Nézet menüben, ki kell választania a Felügyeleti sablon csomópontok egyikét.)

A Nézet menüben lévő Csak a házirendek megjelenítése menüpont jelölésének törlését a Csak a házirendek megjelenítésének kényszerítése csoportházirend-beállítás engedélyezi.

Helye:

  • Csoportházirend-objektum_neve [tartománynév] Házirend
  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Csoportházirend

Ha a Csoportházirend konzolon a rendszerházirend-beállítások láthatósága engedélyezett, a rendszerházirend-beállítások ikonjai piros színnel jelennek meg. A csoportházirend-beállítások ikonjai kék színnel jelennek meg.

Vigyázat!

  • A Windows 2000 ügyfelek kezelésekor semmiképpen nem ajánlatos a Rendszerházirend típusú .adm fájlok használata, mivel az nem kívánt tartós rendszerleíróadatbázis-beállításokhoz vezet.


Felügyeleti sablonok által biztosított nézet használata

  1. Nyissa meg a Csoportházirend beépülő modult és kattintson a kívánt házirendeket tartalmazó Felügyeleti sablonok alatti mappára, például a részletek ablaktáblán megjelenő házirendek Házirendek és Beállítások elemeire.

    2. Helye:

    • házirendnév házirend
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Felügyeleti sablonok
    • házirendmappa
  2. A házirend tulajdonságlapjának megjelenítéséhez kattintson duplán, vagy kattintson a jobb oldali egérgombbal a házirendre, majd kattintson a Tulajdonságok parancsra.
  3. Ha az .adm fájl szerzője ellátta a házirendet leírással, annak megtekintéséhez kattintson a Magyarázat fülre.
  4. Kattintson a Házirend fülre és adja meg a házirend beállításait, az alábbi táblázatban leírt gombok használatával.
    Gomb | Eredmény
    Nem konfigurált | Nincs módosítás a rendszerleíró adatbázisban.
    Engedélyezve | A rendszerleíró adatbázis azt jelzi, hogy a házirend-beállítás ki van választva.
    Letiltva | A rendszerleíró adatbázis azt jelzi, hogy a házirend-beállítás nincs kiválasztva.
  5. Adja meg a további paramétereket a Házirend lapon, majd kattintson az Alkalmazás gombra.
  6. Használja az Előző házirend és a Következő házirend gombokat az aktuális mappában lévő házirendek eléréséhez, majd hasonlóképpen adja meg a beállításokat. Ha elkészült, kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A Csoportházirend két Felügyeleti sablon csomóponttal rendelkezhet. A HKEY_LOCAL_MACHINE beállításai a Számítógép konfigurációja, a HKEY_CURRENT_USER beállításai pedig a Felhasználó konfigurációja csomópontnál találhatók.
  • Ha a számítógép házirendjei ütköznek a felhasználó házirendjeivel, a számítógép házirendjeinek elsőbbségi joguk van a Windows 2000 rendszerben, a Windows NT 4.0 Rendszerházirendjeihez hasonlóan.

Kapcsolódó témakörök


Engedélyek megadása a Csoportházirend kezeléséhez

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A Csoportházirend konzol gyökerében kattintson a jobb oldali egérgombbal arra a csoportházirend-objektumra, amelynek engedélyeit be kívánja állítani, majd kattintson a Tulajdonságok parancsra, és végül a Biztonság fülre.
  3. A Tulajdonságok párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra:

    4. Hozzáadás: Erre a gombra kattintva megnyithatja a Felhasználók, számítógépek vagy csoportok kijelölése párbeszédpanelt, amelyen kiválaszthatja, hogy mely felhasználók és csoportok számára kíván engedélyeket adni.

    Eltávolítás: E gombra kattintva eltávolíthat felhasználókat és csoportokat ebből az objektumból, hozzárendelt engedélyeikkel együtt.

    Engedélyek: Ez a lista a felhasználók számára engedélyezhető vagy tőlük megtagadható általános engedélyeket sorolja fel, például: Teljes hozzáférés, Olvasás, Írás stb.

    Speciális: Erre a gombra kattintva beállíthatja a kijelölt objektum speciális engedélyeit, naplózási adatait és tulajdonosát.

    Engedélyek öröklésének engedélyezése a szülőtől: Megadja, hogy ezen objektum biztonsági engedélyeit befolyásolja-e az öröklés.

Megjegyzés

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


A Csoportházirend beépülő modul megnyitásának módjai

A beépülő modullal elvégezni kívánt művelettől függően a Csoportházirend többféle módon nyitható meg.

Csoportházirend alkalmazásához | Tennivaló
A helyi számítógépen | A Csoportházirend konzolon szerkessze a csoportházirend-objektumot A helyi csoportházirend-objektum szerkesztése című témakörben leírtak szerint.
Másik számítógépen | Nyissa meg a Windows 2000 hálózati számítógépen tárolt helyi csoportházirend-objektumot A Csoportházirend megnyitása önálló MMC beépülő modulként című témakörben leírtak szerint, majd tallózzon a hálózati számítógépre. A művelet végrehajtásához rendszergazdai jogosultságokkal kell rendelkeznie a hálózati számítógépen.
Egy helyen | Nyissa meg a Csoportházirendet A Csoportházirend megnyitása az Active Directory - helyek és szolgáltatások ablakból című témakörben leírt módon, majd csatoljon egy csoportházirend-objektumot a kívánt helyhez.
Egy tartományban | Nyissa meg a Csoportházirendet A Csoportházirend megnyitása az Active Directory - felhasználók és számítógépek ablakból című témakörben leírtak szerint, majd csatoljon egy csoportházirend-objektumot a kívánt tartományhoz.
Egy szervezeti egységben | Nyissa meg a Csoportházirendet A Csoportházirend megnyitása az Active Directory - felhasználók és számítógépek ablakból című témakörben leírtak szerint, majd csatoljon egy csoportházirend-objektumot a kívánt szervezeti egységhez. Csoportházirend-objektum az Active Directory hierarchiájában magasabb szinten levő szervezeti egységhez is csatolható, így a szervezeti egység örökölheti a Csoportházirend beállításait.
Bármely létező csoportházirend-objektumra vagy csoportházirend-objektumok halmazára | Hozza létre és mentse saját testreszabott MMC konzolját. További tudnivalókat a Microsoft Management Console című témakörben talál.


A Csoportházirend megnyitása az Active Directory - helyek és szolgáltatások ablakból

  1. Nyissa meg az Active Directory - helyek és szolgáltatások ablakot.
  2. A konzolfán kattintson a jobb oldali egérgombbal arra a helyre, amelyen Csoportházirendet kíván megadni.

    Hely:

    • Active Directory - helyek és szolgáltatások [tartományvezérlő_neve.tartománynév]
    • Helyek mappa
    • Hely
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A Csoportházirend-objektumok hivatkozásai lista egyik bejegyzésére kattintva jelöljön ki egy létező csoportházirend-objektumot, majd kattintson a Szerkesztés gombra.

    Új csoportházirend-objektum létrehozásához pedig kattintson először az Új, majd a Szerkesztés gombra.

Megjegyzés

  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.


A Csoportházirend megnyitása az Active Directory - felhasználók és számítógépek ablakból

  1. Nyissa meg az Active Directoy - felhasználók és számítógépek ablakot.
  2. A konzolfán kattintson a jobb oldali egérgombbal arra a tartományra vagy szervezeti egységre, amelyben Csoportházirendet kíván megadni.

    Hely:

    • Active Directory - felhasználók és számítógépek [tartományvezérlő_neve.tartománynév]
    • tartomány
    • szervezeti_egység
    • gyermek_szervezeti_egység...
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A szerkeszteni kívánt csoportházirend-objektum megnyitásához kattintson a Szerkesztés gombra. (Új csoportházirend-objektum létrehozásához kattintson először az Új, majd a Szerkesztés gombra.)

Megjegyzés

  • Az Active Directory - felhasználók és számítógépek párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.


A Csoportházirend megnyitása önálló MMC beépülő modulként

  1. Nyissa meg a Microsoft Management Console segédprogramot.
  2. Az MMC konzol menüsorán kattintson a Konzol menüre, majd a Beépülő modul hozzáadása/eltávolítása parancsra.
  3. Az Egyedülálló lapon kattintson a Hozzáadás gombra.
  4. A Magában álló beépülő modul hozzáadása párbeszédpanelen kattintson a Csoportházirend elemre, majd kattintson a Hozzáadás gombra.
  5. A Csoportházirend-objektum kiválasztása párbeszédpanelen válassza a Helyi számítógép lehetőséget, ha a helyi csoportházirend-objektumot akarja szerkeszteni, vagy tallózva keresse meg a kívánt csoportházirend-objektumot.
  6. Kattintson a Befejezés, majd a Bezárás, végül az OK gombra. Ekkor a Csoportházirend beépülő modul megnyitja szerkesztésre a megadott csoportházirend-objektumot.

Megjegyzés

  • Az MMC konzol megnyitásához kattintson a Start menü Futtatás menüpontjára, gépelje be az mmc parancsot, végül nyomja meg az ENTER billentyűt.


Útmutató

  • A Csoportházirend beépülő modul megnyitása
  • Felügyeleti sablonok használata
  • Parancsfájlok használata
  • A Szoftvertelepítés beépülő modul használata
  • A Mappa átirányítása beépülő modul használata
  • Csoportházirend konfigurálása


Feladatlista: Csoportházirend megvalósítása az Active Directoryban

Lépés Segédkönyvek
Tekintse át az Active Directoryval és csoportházirenddel kapcsolatos kulcsfogalmakat.
Csoportházirend – áttekintés;
Active Directory – felhasználók és számítógépek
Telepítse a Windows 2000 rendszert az ügyfélszámítógépre.
Távtelepítési szolgáltatások
Telepítsen egy Windows 2000 Server tartományvezérlőt.
Tartományvezérlő telepítése
Határozza meg a használni kívánt Active Directory struktúrát.
Gyakorlati tanácsok;
Helystruktúra megtervezése;
Tartománystruktúra megtervezése;
DNS-struktúra megtervezése
Nyissa meg a Csoportházirend beépülő modult.
A Csoportházirend beépülő modul megnyitása;
A Csoportházirend beépülő modul megnyitásának módjai


Felügyeleti sablon (.adm fájlok) hozzáadása vagy eltávolítása

Felügyeleti sablon (.adm kiterjesztésű fájlok) hozzáadása vagy eltávolítása

  1. Nyissa meg a szerkeszteni kívánt csoportházirend-objektumot, majd kattintson a jobb oldali egérgombbal a Felügyeleti sablonok elemre.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Felügyeleti sablonok
  2. Kattintson a Sablon hozzáadása/eltávolítása parancsra, majd a Sablon hozzáadása/eltávolítása párbeszédpanelen kattintson a Hozzáadás gombra.
  3. Egy sablon eltávolításához kattintson a kívánt sablonra, majd kattintson az Eltávolítás gombra.

    Egy sablon hozzáadásához kattintson a Hozzáadás gombra. A Házirendsablonok párbeszédpanelen kattintson a hozzáadni kívánt sablonra, majd a Megnyitás gombra.

  4. A Sablon hozzáadása/eltávolítása párbeszédpanelen kattintson a Bezárás gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Összehasonlítva a Windows NT 4.0 rendszerrel, a Felügyeleti sablonok szerepe a Windows 2000 rendszerben megváltozott, ezért a Windows 2000 ügyfeleken nem javasolt a Windows NT 4.0 rendszerű .adm fájlok használata.

    Ha mégis a régebbi típusú .adm kiterjesztésű fájlokat használja a Csoportházirend konzolban névterek létrehozásához, szabályozható a Windows NT 4.0-rendszerű Rendszerházirend-beállítások láthatósága a részletes ablaktáblán: a konzolfán kattintson a Felügyeleti sablonok csomópontra, majd kattintson a Nézet menüre, majd a Csak a házirendek megjelenítése parancsra a menüpont bejelöléséhez vagy a bejelölés törléséhez. A Csak a házirendek megjelenítésének kikényszerítése csoportházirend-beállítás ugyancsak használható a művelet elvégzéséhez:

    Helye:

    • Csoportházirend-objektum_neve
    • Felhasználó konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend
  • Javasolt a Rendszerházirend tiltása (csak csoportházirend használata) beállítás használata, amely megakadályozza az ügyfelek számára a rendszerházirend-beállítások megjelenését.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend

Kapcsolódó témakörök


Számítógép-leállítási parancsfájlok hozzárendelése

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Parancsfájlok csomópontra.

    Helye:

    • házirendnév házirend
    • Számítógép konfigurációja
    • Windows beállításai
    • Parancsfájlok (indítás/leállítás)
  3. A részletek ablaktáblában kattintson duplán a Leállítás ikonra.
  4. A Leállítás tulajdonságlapon kattintson a Hozzáadás gombra.
  5. A Parancsfájl hozzáadása párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra.

    Parancsfájl neve: Adja meg a parancsfájl elérési útját, vagy a tartományvezérlő Netlogon megosztásában a parancsfájl megkereséséhez kattintson a Tallózás gombra.

    Parancsfájl paraméterei: A parancssori megadáshoz hasonlóan adja meg a használni kívánt paramétereket. Ha például a parancsfájl a //logo (bejelentkező képernyő megjelenítése) és az //I (interaktív mód) paramétereket tartalmazná, a következő begépelése lenne szükséges:
    //logo //I

  6. A Leállítás tulajdonságlapon adja meg a használni kívánt beállításokat:

    Leállítási parancsfájlok: Felsorolja a kijelölt csoportházirend-objektumhoz jelenleg hozzárendelt parancsfájlokat. Több parancsfájl hozzárendelésekor a parancsfájlok feldolgozása a megadott sorrendben történik. A listában egy parancsfájl felfelé mozgatásához kattintson a parancsfájlra, majd a Fel gombra; a lefelé mozgatáshoz kattintson a Le gombra.

    Hozzáadás: Megnyitja a Parancsfájl hozzáadása párbeszédpanelt, amelynek segítségével további parancsfájlok adhatók meg használatra.

    Szerkesztés: Megnyitja a Parancsfájl szerkesztése párbeszédpanelt, melyen a parancsfájl információi módosíthatók, például a név és a paraméterek.

    Eltávolítás: Eltávolítja a kiválasztott parancsfájlt a Leállítási parancsfájlok listából.

    Fájlok megjelenítése: Válassza ezt a beállítást a kijelölt csoportházirend-objektumban tárolt parancsfájlok megtekintéséhez.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A leállítási parancsfájlok futtatása a Helyi rendszerfiók fiók jogaival történik.

Kapcsolódó témakörök


Számítógép-indítási parancsfájlok hozzárendelése

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Parancsfájlok csomópontra.

    Helye:

    • házirendnév házirend
    • Számítógép konfigurációja
    • Windows beállításai
    • Parancsfájlok (indítás/leállítás)
  3. A részletek ablaktáblán kattintson duplán az Indítás ikonra.
  4. Az Indítás tulajdonságlapon kattintson a Hozzáadás gombra.
  5. A Parancsfájl hozzáadása párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra.

    Parancsfájl neve: Adja meg a parancsfájl elérési útját, vagy a tartományvezérlő Netlogon megosztásában a parancsfájl megkereséséhez kattintson a Tallózás gombra.

    Parancsfájl paraméterei: A parancssori megadáshoz hasonlóan adja meg a használni kívánt paramétereket. Ha például a parancsfájl a //logo (bejelentkező képernyő megjelenítése) és az //I (interaktív mód) paramétereket tartalmazná, a következő begépelése lenne szükséges:
    //logo //I

  6. Az Indítás tulajdonságlapon adja meg a használni kívánt beállításokat:

    7. Indítási parancsfájlok: Felsorolja a kijelölt csoportházirend-objektumhoz jelenleg hozzárendelt parancsfájlokat. Több parancsfájl hozzárendelésekor a parancsfájlok feldolgozása a megadott sorrendben történik. A listában egy parancsfájl felfelé mozgatásához kattintson a parancsfájlra, majd a Fel gombra; a lefelé mozgatáshoz kattintson a Le gombra.

    Hozzáadás: Megnyitja a Parancsfájl hozzáadása párbeszédpanelt, amelynek segítségével további parancsfájlok adhatók meg használatra.

    Szerkesztés: Megnyitja a Parancsfájl szerkesztése párbeszédpanelt, melyen a parancsfájl információi módosíthatók, például a név és a paraméterek.

    Eltávolítás: Eltávolítja a kiválasztott parancsfájlt az Indítási parancsfájlok listából.

    Fájlok megjelenítése: Válassza ezt a beállítást a kijelölt csoportházirend-objektumban tárolt parancsfájlok megtekintéséhez.

Megjegyzés

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A indítási parancsfájlok futtatása a Helyi rendszerfiók fiók jogaival történik.

Kapcsolódó témakörök


Bejelentkezési parancsfájlok hozzárendelése

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Parancsfájlok csomópontra.

    Helye:

    • házirendnév házirend
    • Felhasználó konfigurációja
    • Windows beállításai
    • Parancsfájlok (bejelentkezés/kijelentkezés)
  3. A részletek ablaktáblán kattintson duplán a Bejelentkezés ikonra.
  4. A Bejelentkezés tulajdonságlapon kattintson a Hozzáadás gombra.
  5. A Parancsfájl hozzáadása párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra:

    Parancsfájl neve: Adja meg a parancsfájl elérési útját, vagy a tartományvezérlő Netlogon megosztásában a parancsfájl megkereséséhez kattintson a Tallózás gombra.

    Parancsfájl paraméterei: A parancssori megadáshoz hasonlóan adja meg a használni kívánt paramétereket. Ha például a parancsfájl a //logo (bejelentkező képernyő megjelenítése) és az //I (interaktív mód) paramétereket tartalmazná, a következő begépelése lenne szükséges:
    //logo //I

  6. A Bejelentkezés tulajdonságlapon adja meg a használni kívánt beállításokat:

    7. Bejelentkezési parancsfájlok: Felsorolja a kijelölt csoportházirend-objektumhoz jelenleg hozzárendelt parancsfájlokat. Több parancsfájl hozzárendelésekor a parancsfájlok feldolgozása a megadott sorrendben történik. A listában egy parancsfájl felfelé mozgatásához kattintson a parancsfájlra, majd a Fel gombra; a lefelé mozgatáshoz kattintson a Le gombra.

    Hozzáadás: Megnyitja a Parancsfájl hozzáadása párbeszédpanelt, amelynek segítségével további parancsfájlok adhatók meg használatra.

    Szerkesztés: Megnyitja a Parancsfájl szerkesztése párbeszédpanelt, melyen a parancsfájl információi módosíthatók, például a név és a paraméterek.

    Eltávolítás: Eltávolítja a kiválasztott parancsfájlt a Bejelentkezési parancsfájlok listából.

    Fájlok megjelenítése: Válassza ezt a beállítást a kijelölt csoportházirend-objektumban tárolt parancsfájlok megtekintéséhez.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A bejelentkezési parancsfájlok futtatása a Felhasználó, nem a Rendszergazda fiók jogaival történik.

Kapcsolódó témakörök


Kijelentkezési parancsfájlok hozzárendelése

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. A konzolfán kattintson a Parancsfájlok csomópontra.

    Helye:

    • házirendnév házirend
    • Felhasználó konfigurációja
    • Windows beállításai
    • Parancsfájlok (Bejelentkezés/Kijelentkezés)
  3. A részletek ablaktáblán kattintson duplán a Kijelentkezés ikonra.
  4. A Kijelentkezés párbeszédpanelen kattintson a Hozzáadás gombra.
  5. A Parancsfájl hozzáadása párbeszédpanelen adja meg a használni kívánt beállításokat, majd kattintson az OK gombra:

    Parancsfájl neve: Adja meg a parancsfájl elérési útját, vagy a tartományvezérlő Netlogon megosztásában a parancsfájl megkereséséhez kattintson a Tallózás gombra.

    Parancsfájl paraméterei: A parancssori megadáshoz hasonlóan adja meg a használni kívánt paramétereket. Ha például a parancsfájl a //logo (bejelentkező képernyő megjelenítése) és az //I (interaktív mód) paramétereket tartalmazná, a következő begépelése lenne szükséges:
    //logo //I

  6. A Kijelentkezés tulajdonságlapon adja meg a használni kívánt beállításokat, majd kattintson az OK gombra:

    7. Kijelentkezési parancsfájlok: Felsorolja a kijelölt csoportházirend-objektumhoz jelenleg hozzárendelt parancsfájlokat. Több parancsfájl hozzárendelésekor a parancsfájlok feldolgozása a megadott sorrendben történik. A listában egy parancsfájl felfelé mozgatásához kattintson a parancsfájlra, majd a Fel gombra; a lefelé mozgatáshoz kattintson a Le gombra.

    Hozzáadás: Megnyitja a Parancsfájl hozzáadása párbeszédpanelt, amelynek segítségével további parancsfájlok adhatók meg használatra.

    Szerkesztés: Megnyitja a Parancsfájl szerkesztése párbeszédpanelt, melyen a parancsfájl információi módosíthatók, például a név és a paraméterek.

    Eltávolítás: Eltávolítja a kijelölt parancsfájlt a Kijelentkezési parancsfájlok listából.

    Fájlok megjelenítése: Válassza ezt a beállítást a kijelölt csoportházirend-objektumban tárolt parancsfájlok megtekintéséhez.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A kijelentkezési parancsfájlok futtatása Felhasználó, nem pedig Rendszergazda joggal történik.

Kapcsolódó témakörök


Parancsfájlok beállítása a tartományvezérlőn

  • Másolja át a parancsfájlt és a függő fájlokat annak a tartományvezérlőnek a Netlogon vagy más megosztásába, amelyről a parancsfájlt futtatni kívánja.


Speciális mappák átirányítása más helyre biztonsági csoporttagság szerint

  1. Nyissa meg a helyhez, tartományhoz vagy szervezeti egységhez csatolt azon csoportházirend-objektumot, amely azokat a felhasználókat tartalmazza, melyeknek speciális mappáit egy hálózati helyhez kívánja átirányítani.
  2. A konzolfán kattintson duplán a Mappa átirányítása csomópontra az átirányítani kívánt mappa megjelenítéséhez.

    Helye:

    • házirendnév házirend
    • Felhasználó konfigurációja
    • Windows beállításai
    • Mappa átirányítása
  3. Kattintson a jobb oldali egérgombbal a kívánt mappára (például Asztal, Dokumentumok stb.), majd a helyi menün kattintson a Tulajdonságok parancsra.
  4. A Beállítások legördülő menün kattintson a Speciális elemre, majd a Hozzáadás gombra.
  5. A Csoport és hely megadása párbeszédpanelen, a Biztonságicsoport-tagság területen kattintson a Tallózás gombra.
  6. A Csoport kiválasztása párbeszédpanelen kattintson a kívánt biztonsági csoportra, majd az OK gombra.
  7. A Csoport és hely megadása párbeszédpanelen, a Célmappa helye területen kattintson a Tallózás gombra.
  8. A Tallózás a mappák között párbeszédpanelen válassza ki a biztonsági csoporthoz használni kívánt átirányítási helyet.

    Egy meghajtóbetűjel, például a D:\ megadása esetén a felhasználó helyi számítógépén annak egy érvényes elérési útnak kell lennie. Javasolt az univerzális elnevezési konvenciónak (UNC) megfelelő teljes elérési út megadása.

    Ha a helyen, tartományban vagy szervezeti egységben minden egyes felhasználónak saját almappát kíván létrehozni, az UNC elérési útba belefoglalhatja a %username% változót (például \\Win2000profiles\docs\%username%.). A %username% változó elérési útba való befoglalása egy ajánlott módszer.

  9. A Csoport és hely megadása párbeszédpanelen kattintson az OK gombra.
  10. Ha más biztonsági csoportok tagjai számára kíván mappákat átirányítani, ismételje meg a 2.-4. lépéseket minden csoport megadására vonatkozóan.
  11. Kattintson a Beállítások fülre, majd adja meg az alábbi beállításokat. Ajánlatos az alapértelmezett beállításokat használni:

    A felhasználó a speciális mappához kizárólagos jogokat kap: A beállítás alapértelmezés szerint engedélyezett. A felhasználó és a helyi rendszer a mappához teljes körű jogokkal rendelkezik, senki, még a rendszergazda sem rendelkezik a mappához jogokkal. Ha ez a beállítás le van tiltva, a mappa engedélyei nem változnak. Ezáltal az alapértelmezés szerint érvényben lévő engedélyek lesznek hatályban.

    A felhasználó jelenlegi speciális mappájának áthelyezése új helyre: A beállítás alapértelmezés szerint engedélyezett.

  12. Használja az alábbi két beállítás egyikét házirendek eltávolítására. Ajánlatos az alapértelmezett beállítást használni:

    Házirend eltávolításakor a fájlok maradjanak az új helyen.

    Házirend eltávolításakor a mappa visszairányítása a helyi felhasználói profilba.

  13. A speciális mappa Tulajdonságok párbeszédpaneljén kattintson az OK gombra.

    14. Vigyázat!

    • Ha az átirányítási házirend azt határozza meg, hogy a mappa a helyi felhasználói profil helyéhez legyen átirányítva a házirend eltávolításakor, de az nem adja meg az átirányítás során a tartalom áthelyezését, akkor a speciális mappa tartalmát – amely a házirend érvényessége alatt látható volt – a felhasználó nem fogja látni a házirend eltávolításakor. A felhasználó fájljai a házirend érvényessége alatt megadott helyen maradnak. További tudnivalókért tanulmányozza a Házirend eltávolításával kapcsolatos szempontok témakört.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A speciális mappák a gyökérkönyvtárban lévő Documents and Settings mappában találhatók.
  • A Képek mappa egy további lehetőséget is biztosít. Az alapértelmezett viselkedés szerint (melynek használata javasolt) a Dokumentumok mappát a Képek mappa automatikusan követi. Ez megváltoztatható a Képek mappa beállításai házirendben lévő Beállítások legördülő menüre kattintással, illetve a Dokumentumok mappa beállításai házirend Beállítások lapjának a használatával.

Kapcsolódó témakörök


Speciális mappák egy helyre történő átirányítása a helyen, tartományban vagy szervezeti egységben minden felhasználó számára

  1. Nyissa meg a helyhez, tartományhoz vagy szervezeti egységhez csatolt azon csoportházirend-objektumot, amely azokat a felhasználókat tartalmazza, melyeknek speciális mappáit egy hálózati helyhez kívánja átirányítani.
  2. A konzolfán kattintson duplán a Mappa átirányítása csomópontra az átirányítani kívánt speciális mappa megjelenítéséhez.

    Helye:

    • házirendnév házirend
    • Felhasználó konfigurációja
    • Windows beállításai
    • Mappa átirányítása
  3. Kattintson a jobb oldali egérgombbal a kívánt mappára (például Asztal, Dokumentumok stb.), majd a helyi menün kattintson a Tulajdonságok parancsra.
  4. A Beállítások legördülő menüben kattintson az Alapvető elemre, a Tallózás gombra, majd keresse meg a kívánt helyet.

    Egy meghajtóbetűjel, például a D:\ megadása esetén a felhasználó helyi számítógépén annak egy érvényes elérési útnak kell lennie. Javasolt az univerzális elnevezési konvenciónak (UNC) megfelelő teljes elérési út megadása.

    Ha a helyen, tartományban vagy szervezeti egységben minden egyes felhasználónak saját almappát kíván létrehozni, az UNC elérési útba belefoglalhatja a %username% változót (például \\Win2000profiles\docs\%username%). A %username% változó elérési útba való befoglalása egy ajánlott módszer.

  5. A Tallózás a mappák között párbeszédpanelen kattintson az OK gombra.
  6. Kattintson a Beállítások fülre, majd adja meg az alábbi beállításokat. Ajánlatos az alapértelmezett beállításokat használni:

    A felhasználó a speciális mappához kizárólagos jogokat kap: A beállítás alapértelmezés szerint engedélyezett. A felhasználó és a helyi rendszer a mappához teljes körű jogokkal rendelkezik, senki, még a rendszergazda sem rendelkezik a mappához jogokkal. Ha ez a beállítás le van tiltva, a mappa engedélyei nem változnak. Ezáltal az alapértelmezés szerint érvényben lévő engedélyek lesznek hatályban.

    A felhasználó jelenlegi speciális mappájának áthelyezése új helyre: A beállítás alapértelmezés szerint engedélyezett.

  7. Használja az alábbi két beállítás egyikét házirendek eltávolítására. Ajánlatos az alapértelmezett beállítást használni:

    Házirend eltávolításakor a fájlok maradjanak az új helyen.

    Házirend eltávolításakor a mappa visszairányítása a helyi felhasználói profilba.

  8. A speciális mappa Tulajdonságok párbeszédpaneljén kattintson az OK gombra.

    9. Vigyázat!

    • Ha az átirányítási házirend azt határozza meg, hogy a mappa a helyi felhasználói profil helyéhez legyen átirányítva a házirend eltávolításakor, de az nem adja meg az átirányítás során a tartalom áthelyezését, akkor a speciális mappa tartalmát – amely a házirend érvényessége alatt látható volt – a felhasználó nem fogja látni a házirend eltávolításakor. A felhasználó fájljai a házirend érvényessége alatt megadott helyen maradnak. További tudnivalókért tanulmányozza a Házirend eltávolításával kapcsolatos szempontok témakört.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • A speciális mappák a gyökérkönyvtárban lévő Documents and Settings mappában találhatók.
  • A Képek nevű speciális mappa egy további lehetőséget is biztosít. Az alapértelmezett viselkedés szerint (melynek használata javasolt) a Dokumentumok mappát a Képek mappa automatikusan követi. Ez megváltoztatható a Képek mappa beállításai házirendben lévő Beállítások legördülő menüre kattintással, illetve a Dokumentumok mappa beállításai házirend Beállítások lapjának a használatával.

Kapcsolódó témakörök


A Csoportházirend beépülő modul megnyitása

  • A Csoportházirend megnyitása az Active Directory - felhasználók és számítógépek ablakból
  • A Csoportházirend megnyitása az Active Directory - helyek és szolgáltatások ablakból
  • A Csoportházirend megnyitása önálló MMC beépülő modulként

Amennyiben nem biztos abban, hogy melyik módon nyissa meg a Csoportházirend beépülő modult, tanulmányozza A Csoportházirend beépülő modul megnyitásának módjai című témakört.


Csoportházirend-objektum helyhez, tartományhoz vagy szervezeti egységhez való csatolása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek ablakot egy tartományhoz vagy egy szervezeti egységhez való csatoláshoz, illetve az Active Directory - helyek és szolgáltatások ablakot egy helyhez való csatoláshoz.
  2. A konzolfán a jobb oldali egérgombbal kattintson a csoportházirendhez csatolandó helyre, tartományra vagy szervezeti egységre.
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. A csoportházirend-objektum Csoportházirend-objektumok hivatkozásai listához történő hozzáadáshoz kattintson a Hozzáadás gombra. Megjelenik a Csoportházirend-objektumok hivatkozásainak hozzáadása párbeszédpanel.
  5. Kattintson a Minden fülre, majd a kívánt csoportházirend-objektumra, végül az OK gombra.
  6. A hely, tartomány vagy szervezeti egység Tulajdonságok párbeszédpanelén kattintson az OK gombra.

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.
  • A csoportházirend-objektum csatolása azt eredményezi, hogy a csoportházirend-objektum beállításai a helyen, tartományban vagy szervezeti egységben lévő felhasználókra és számítógépekre lesznek alkalmazva, továbbá az Active Directory tárolóban található felhasználókra és számítógépekre, mely a helyről, tartományról vagy szervezeti egységről öröklődik.


Feladatlista: Helyi csoportházirend megvalósítása

Lépés | Hivatkozás
Tekintse át a helyi csoportházirend kulcsfogalmait. | Csoportházirend-objektumok; Helyi csoportházirend
Telepítse a Windows 2000 Server vagy a Windows 2000 Professional operációs rendszert a helyi számítógépre. | Bevezetés
Csoportházirend megnyitása a helyi Csoportházirend beépülő modul szerkesztéséhez. | A Csoportházirend beépülő modul megnyitása; A Csoportházirend beépülő modul megnyitásának módjai


Számítógép konfigurációja

A rendszergazda a Csoportházirend beépülő modulban a Számítógép konfigurációja csomópontot használja a számítógépekre érvényes házirendek megadására, melyek függetlenek a számítógépre bejelentkező felhasználóktól.

A Számítógép konfigurációja általában a következő alcsomópontokat tartalmazza: Szoftverbeállítások, Windows beállításai és Felügyeleti sablonok. Mivel azonban a Csoportházirend beépülő modul hozzáadható vagy eltávolítható bővítményekkel rendelkezik, a látható alcsomópontok pontos halmaza különbözhet.

Lásd még:

  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Szoftverbeállítások
  • Windows beállításai
  • Csoportházirend-objektum Számítógép konfigurációja beállításainak letiltása
  • Számítógép-indítási parancsfájlok hozzárendelése
  • Számítógép-leállítási parancsfájlok hozzárendelése


Áttéréssel kapcsolatos kérdések

A rész tartalma:

  • Ügyfél operációs rendszerek
  • A Felügyeleti sablonok szerepe
  • A Rendszerházirend-szerkesztő szerepe
  • Windows NT 4.0 rendszerházirendek


A Microsoft Management Console házirendje

A System.adm fájl számos csoportházirend-beállítást tartalmaz a Microsoft Management Console (MMC) használatának szabályozására vonatkozóan. Ez fontos, mivel az előzőleg konfigurált konzolok lementése egy módja a rendszergazdai jogok delegálásának.

A konzolfán kattintson a Csoportházirend csomópontra.

Helye:

  • Csoportházirend-objektum_neve
  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Windows-összetevők
  • Microsoft Management Console
  • Korlátozott/engedélyezett beépülő modulok
  • Csoportházirend

Kattintson duplán a csoportházirend azon bővítményeire, melyekhez az MMC-konzolokban lévő bővítmények használatát szabályzó rendszergazdai csoportházirend-beállításokat meg kívánja adni.

További tudnivalókért tanulmányozza a Csoportházirend felügyeletének átadása és a Microsoft Management Console témakört.


Csoportházirend-objektum felülbírálatának megakadályozása

  1. Nyissa meg az Active Directory - felhasználók és számítógépek segédprogramot a tartományhoz vagy szervezeti egységhez csatolt csoportházirend-objektumok használatához, illetve az Active Directory - helyek és szolgáltatások segédprogramot a helyhez csatolt csoportházirend-objektumok használatához.

  2. A konzolfán a jobb oldali egérgombbal kattintson a csoportházirendhez csatolandó helyre, tartományra vagy szervezeti egységre.
  3. Kattintson a Tulajdonságok parancsra, majd a Csoportházirend fülre.
  4. Kattintson a jobb oldali egérgombbal a kikényszeríteni kívánt csoportházirend-objektum hivatkozásra, majd a helyi menün kattintson a Nincs felülbírálás parancsra, azután az OK gombra. (Ez a Nincs felülbírálás beállítást Aktív állapotba kapcsolja át, majd egy pipa jelenik meg a Nincs felülbírálás oszlopban.)

Megjegyzések

  • Az Active Directory - felhasználók és számítógépek segédprogram megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök pontra, végül kattintson az Active Directory - felhasználók és számítógépek parancsra.
  • Az Active Directory - helyek és szolgáltatások párbeszédpanel megnyitásához kattintson a Start gombra, mutasson a Programok, majd a Felügyeleti eszközök menüpontra, végül kattintson az Active Directory - helyek és szolgáltatások parancsra.
  • A csoportházirend-objektum hivatkozásán a Nincs felülbírálás beállítás a helyen, tartományban vagy szervezeti egységben lévő felhasználók, illetve számítógépek csoportházirend-beállításainak, valamint az Active Directory tárolóiban lévő, a csoportházirendet öröklő összes felhasználó és számítógép csoportházirend-beállításainak kikényszerítését eredményezi.
  • A Nincs felülbírálás beállítás által kikényszerített csoportházirend-beállítás nem blokkolható.

Kapcsolódó témakörök


Az alkalmazások szerepe a csoportházirend elsőbbségi sorrendjében

A csoportházirend infrastruktúra nem kényszerítheti az alkalmazásokat a csoportházirend használatára. Például azok az alkalmazások, melyek mindig a csoportházirend számára fenntartott jóváhagyott rendszerleíró fákon kívül keresték a rendszerleíró adatbázis bejegyzéseit, továbbra is ezeken a helyeken folytatják a keresést. A csoportházirend a csoportházirend területeiről nem másolja a rendszerleíró beállításokat a Windows NT 4.0 Rendszerházirend területekre, és nem másolja a Windows NT 4.0 Rendszerházirend beállításokat a fenntartott csoportházirend területekre.

A csoportházirend előnyeit felhasználó alkalmazások írásához a fejlesztők által használt Software Development Kit készletben talál útmutatást. Ahhoz, hogy a rendszergazdák megjósolják a nem ismert alkalmazások viselkedését, ismerniük kell a megfelelően megírt alkalmazások rendszerleíró adatokhoz jutásának lépéseit.

A rendszerleíró adatbázis kezdeti állapota

A számítógép indítása és a felhasználó bejelentkezése után a rendszer újraírja a csoportházirend rendszerleíró területeit, melyek a helyi csoportházirend-objektumból és az Active Directoryból összesített érvényben lévő csoportházirend-beállításokat tárolják. A Windows NT 4.0 Rendszerházirend engedélyezésekor (nem javasolt a Windows 2000 ügyfeleknél) előfordulhat, hogy a bejelentkezés során a többi rendszerleíró terület is módosul.

Események sorozata

  1. A felhasználó elindítja az alkalmazást.
  2. Egy általános felhasználóközpontú alkalmazás a csoportházirend fenntartott területein rendszerleíró adatokat keres (HKEY_LOCAL_MACHINE\Software\Policies). Ha a program megtalálta a szükséges dolgokat, tovább már nem keres.

    Az operációs rendszer szintjén lévő jellemzőket módosító vagy cserélő alkalmazás (például a Futtatás parancs), mely nemcsak a saját, hanem más alkalmazások viselkedését is befolyásolja, a következő, csoportházirend számára fenntartott kulcsokban kereshet:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies.
    Ha a program megtalálta a szükséges dolgokat, tovább már nem keres.

  3. A csoportházirend fenntartott területén kívül az alkalmazás átnézi a HKEY_LOCAL_MACHINE rendszerleíró adatokat, és ha megtalálta a szükséges dolgokat, tovább már nem keres.
  4. A csoportházirend fenntartott területén kívül az alkalmazás átnézi a HKEY_CURRENT_USER rendszerleíró adatokat, és ha megtalálta a szükséges dolgokat, tovább már nem keres.
  5. Az alkalmazás .ini fájlokat használ (nem ajánlott) vagy az alapértelmezés szerinti beállításokat.

Elképzelhető, hogy az újonnan fejlesztett, natív Windows 2000 alkalmazások csak az első három lépést hajtják végre. A Windows 2000 rendszer alatt csoportházirendet használó alkalmazások (melyek a korábbi Windows verziókkal kompatibilisek) korábbi operációs rendszeren futva a negyedik lépéstől folytatják az eljárást. A Windows 2000 rendszer előtti alkalmazások nem látják a kettes és a hármas lépést, így a négyes lépéssel kezdik az eljárást.

Az események egymás után következő sorrendje a következőt jelenti:

  • A Windows 2000 ügyfeleken futó, megfelelően megírt alkalmazásokban a csoportházirend elsőbbségi joggal rendelkezik a Windows NT 4.0 Rendszerházirenddel szemben.
  • A korábbi verziójú alkalmazások (melyek nem ismerik az Active Directoryt és a csoportházirendeket) továbbra is működnek a Windows 2000 rendszeren, akárcsak a Windows NT 4.0 rendszeren.
  • A HKEY_LOCAL_MACHINE beállítások elsőbbségi joggal rendelkeznek a HKEY_CURRENT_USER beállításokkal szemben, akárcsak a Windows NT 4.0 rendszeren.


Események sorrendje rendszerindításkor és bejelentkezéskor

A következő eseménysor azt a sorrendet mutatja, amelyben a számítógép házirendje és a felhasználó házirendje alkalmazásra kerül a számítógép indításakor és a felhasználó bejelentkezésekor:

  1. Hálózat indítása. Távoli eljáráshívás rendszerszolgáltatás (RPCSS) és Többszörös univerzális elnevezési konvenció szolgáltató (MUP) indítása.
  2. A csoportházirend-objektumok rendezett listáját a számítógép megkapja. A lista az alábbi tényezőktől függhet:
    • A Windows 2000 tartomány része-e a számítógép, és így azt az Active Directory révén a csoportházirend határozza meg.
    • A számítógép helye az Active Directoryban.
    • Amennyiben a csoportházirend-objektumok listája nem változott, feldolgozás nem történik. Házirend-beállítás használatával ez a viselkedés megváltoztatható.
  3. A számítógép házirendje alkalmazásra kerül. Az összegyűjtött listából ezek a Számítógép konfigurációja csomóponton lévő beállítások. A rendszer alapértelmezés szerint szinkron módon végzi el ezt, mégpedig az alábbi sorrendben: számítógép, hely, tartomány, szervezeti egység, gyerek szervezeti egység stb. A számítógép-házirendek feldolgozása alatt felhasználói felület nem jelenik meg.

    A beállítások feldolgozásának sorrendjével kapcsolatosan a felhasználó vagy a számítógép házirendjének alkalmazásakor további tudnivalókért tanulmányozza a Beállítások feldolgozásának sorrendje témakört.

  4. Rendszerindítási parancsfájlok futása. Ez alapértelmezés szerint rejtve és szinkron módon hajtódik végre; a következő parancsfájl előtt az egyes parancsfájlok futásának be kell fejeződnie vagy időtúllépést kell okoznia. Az alapértelmezés szerinti időtúllépési érték 600 másodperc. Számos házirend-beállítás használható ennek a viselkedésnek a megváltoztatására.
  5. A felhasználó megnyomja a CTRL-ALT-DEL billentyűket.
  6. A felhasználó érvényesítését követően a felhasználói profil betöltődik, melyet az érvényben lévő házirend-beállítás szabályoz.
  7. A csoportházirend-objektumok rendezett listáját a felhasználó megkapja. A lista az alábbi tényezőktől függhet:
    • A felhasználó a Windows 2000 tartomány része-e, és így azt az Active Directory révén a csoportházirend határozza meg.
    • A visszacsatolás engedélyezett-e, valamint a visszacsatolási házirend-beállítás állapota (Összefésülés vagy Csere).
    • A felhasználó helye az Active Directoryban.
    • Amennyiben az alkalmazandó csoportházirend-objektumok listája nem változott, feldolgozás nem történik. Házirend-beállítás használatával ez a viselkedés megváltoztatható.
  8. A felhasználó házirendje alkalmazásra kerül. Az összegyűjtött listából ezek a Felhasználó konfigurációjában lévő beállítások. A rendszer alapértelmezés szerint szinkron módon végzi el ezt, mégpedig az alábbi sorrendben: számítógép, hely, tartomány, szervezeti egység, gyerek szervezeti egység stb. A felhasználó-házirendek feldolgozása alatt felhasználói felület nem jelenik meg.

    A beállítások feldolgozásának sorrendjével kapcsolatosan a felhasználó vagy a számítógép házirendjének alkalmazásakor további tudnivalókért tanulmányozza a Beállítások feldolgozásának sorrendje témakört.

  9. Bejelentkezési parancsfájlok futása. A Windows NT 4.0 parancsfájljaitól eltérően a csoportházirend alapú bejelentkezési parancsfájlok futása alapértelmezés szerint rejtett és aszinkron módon megy végbe. A rendszer legutolsóként a felhasználói objektum parancsfájlt futtatja (a Windows NT 4.0 rendszerhez hasonlóan normál ablakban).
  10. A csoportházirend által előírt operációs rendszeri felhasználói felület megjelenése.

Fontos

  • Az áttéréssel kapcsolatos három megfontolandó speciális eset:
    • Amennyiben a számítógép fiókobjektuma Windows NT 4.0 tartományban, de a felhasználó fiókobjektuma Active Directoryban van, a rendszer csak a számítógép (nem pedig a felhasználó) Rendszerházirendjét dolgozza fel a felhasználó bejelentkezésekor. Ezután a rendszer feldolgozza a felhasználó (nem pedig a számítógép) csoportházirendjét.
    • Ha a számítógép fiókobjektuma az Active Directoryban, de a felhasználó fiókobjektuma a Windows NT 4.0 tartomány van, akkor a rendszer a számítógép (nem pedig a felhasználó) csoportházirendjét dolgozza fel a számítógép indításakor. A felhasználó bejelentkezésekor a rendszer feldolgozza a felhasználó (nem a számítógép) Rendszerházirendjét.
    • Ha a Windows 2000 számítógép és felhasználó fiókjai Windows NT 4.0 tartomány tagjai, a rendszer csak a számítógép és a felhasználó Rendszerházirendjét (csoportházirendet) alkalmazza a felhasználó bejelentkezésekor.

Megjegyzések

  • Ezen események közül számos módosítható. Házirendek az alábbi feladatokra állíthatók be:
    • A parancsfájlok futtatásának és a házirend alkalmazásának szinkron vagy az aszinkron módjára való átkapcsolás.
    • Parancsfájlok időtúllépésének megadása. Alapértelmezés szerint a parancsfájlok időtúllépése 600 másodperc után következik be.
    • Parancsfájlok rejtett, kis méretű vagy normál ablakú futásának beállítására.


Beállítások feldolgozásának sorrendje

Ez a témakör tájékoztatást nyújt a feldolgozási sorrendről, amellyel a Windows 2000 a felhasználók és számítógépek csoportházirend-beállításait feldolgozza. Tanulmányozza az Események sorrendje rendszerindításkor és bejelentkezéskor témakör 3. és 8. lépését, hogy megértse, hol helyezkedik el a házirend-beállítás feldolgozása a számítógép indításának és a felhasználó bejelentkezésének folyamatában.

A rendszer az alábbi sorrendben hajtja végre a csoportházirend-beállításokat:

  1. Helyi csoportházirend-objektumok. Minden Windows 2000 számítógép helyileg egy csoportházirend-objektumot tárol.
  2. Hely. A következő lépés a helyhez csatolt csoportházirend-objektumok feldolgozása. A feldolgozás szinkron módon megy végbe, a rendszergazda által megadott sorrendben.
  3. Tartomány. Több, tartományhoz csatolt csoportházirend-objektum feldolgozása szinkron módon történik, a rendszergazda által megadott sorrendben.
  4. Szervezeti egységek. A szervezeti egységhez az Active Directory hierarchiájában a legmagasabb szinten csatolt csoportházirend-objektumok feldolgozása történik elsőként, ezután a gyerek szervezeti egységekhez csatolt csoportházirend-objektumok következnek és így tovább. Végül a felhasználót vagy a számítógépet tartalmazó szervezeti egységhez csatolt csoportházirend-objektumok feldolgozását végzi a rendszer.

    Az Active Directory hierarchiában az egyes szervezeti egységek szintjén egy vagy több csoportházirend-objektum csatolható, vagy egy sem. Ha a szervezeti egységhez több csoportházirend-objektum van csatolva, azok feldolgozása szinkron módon megy végbe, a rendszergazda által előírt sorrendben.

Ez a sorrend a következőt jelenti: először a helyi csoportházirend-objektum feldolgozása történik, majd azon szervezeti egységhez csatolt csoportházirend-objektumok következnek, melyek számítógépe vagy felhasználója közvetlen tagként szerepel; ily módon ez felülírja a korábbi csoportházirend-objektumokat.

Az alapértelmezett sorrend kivételei

Az alapértelmezett feldolgozási sorrendbeállítások az alábbi kivételekkel rendelkeznek:

  • Egy helyhez, tartományhoz vagy szervezeti egységhez csatolt bármely csoportházirend-objektumban (nem helyi csoportházirend-objektum) megadható a Nincs felülbírálás beállítás az adott helyre, tartományra vagy szervezeti egységre vonatkozóan, így annak egy házirend-beállítása sem írható felül. Amikor több csoportházirend-objektumhoz adja meg a Nincs felülbírálás beállítást, az Active Directory hierarchiában legmagasabb szinten szereplő (vagy magasabban az egyes rögzített szinteken az Active Directoryban, a rendszergazda által megadott hierarchiában) elem rendelkezik elsőbbségi joggal.

    Ne feledje, hogy a Nincs felülbírálás és a Letiltva beállítások a csoportházirend-objektum hivatkozásaira vonatkoznak, nem pedig a csoportházirend-objektumra. Egy csoportházirend-objektum akár többször is csatolható ugyanahhoz a szervezeti egységhez, és a Nincs felülbírálás és a Letiltva beállítások külön is konfigurálhatók az egyes hivatkozásokon. (Annak ellenére, hogy a csoportházirend-objektum egy szervezeti egységre vonatkozó többszörös hivatkozásai ritkán használhatók, ez a lehetőség a csoportházirend infrastruktúra rugalmasságát szemlélteti.)

    A Nincs felülbírálás és a Letiltva hivatkozásbeállítások létrehozásával kapcsolatos további tudnivalókért tanulmányozza a Csoportházirend-objektum érvénytelenítésének megakadályozás és a Hely, tartomány vagy szervezeti egység csoportházirend-objektumának letiltása témaköröket.

  • Bármely helyen, tartományban vagy szervezeti egységben a csoportházirend öröklés szelektív módon megjelölhető a Házirend öröklődésének blokkolása beállítással. A csoportházirend-objektum hivatkozások Nincs felülbírálás beállítása mindig érvényben van és nem blokkolható.

    A Házirend öröklődésének blokkolása beállítás közvetlenül a helyre, tartományra vagy szervezeti egységre vonatkozóan van érvényben. A rendszer ezt nem alkalmazza a csoportházirend-objektumokra, és a csoportházirend-objektum hivatkozásaira sem. Emiatt a Házirend öröklődésének blokkolása beállítás blokkol minden olyan csoportházirend-beállítást, mely a helyet, tartományt vagy szervezeti egységet fentről érné el (szülőkhöz való hivatkozások által az Active Directory hierarchiában), függetlenül a csoportházirend-objektumok beállításainak eredetétől. A Házirend öröklődésének blokkolása beállítás azonban nem blokkolja az olyan csoportházirend-objektumok csoportházirend-beállításait, melyek a Házirend öröklődésének blokkolása beállítású helyhez, tartományhoz vagy szervezeti egységhez közvetlenül csatlakoznak.

  • A Visszacsatolás egy olyan speciális csoportházirend-beállítás, amely gondosan kezelt környezetben (például nyilvános helyek, laboratóriumok, tantermek és recepciós helyiségek) lévő számítógépeken hasznos. A visszacsatolás leírása megtalálható a Felhasználói Csoportházirend visszacsatolás-feldolgozó mód tulajdonságlap Magyarázat lapján.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend

    A visszacsatolás lehetőség segítségével többféle módon beszerezhető azon csoportházirend-objektumok rendezett listája, melyek felhasználó-konfigurációs beállításai egy felhasználót érintenek. Alapértelmezés szerint egy felhasználó beállításai a felhasználó Active Directoryban elfoglalt helyétől függő csoportházirend-objektum listából származnak. A rendezett lista tartalma a helyhez csatolt csoportházirend-objektumokkal kezdődik, majd a tartományhoz csatolt, végül a szervezeti egységhez csatolt csoportházirend-objektumok következnek. Ezek öröklődését a felhasználó Active Directoryban elfoglalt helyzete határozza meg, a rendszergazda által az egyes szinteken előírt sorrendben.

    Bármely más csoportházirend beállításhoz hasonlóan a visszacsatolás beállításai a következők lehetnek: Nem konfigurált, Engedélyezve vagy Letiltva. Az Engedélyezve beállítás kiválasztásakor a visszacsatolás lehetséges beállításai az Összefésülés vagy a Csere.

    Visszacsatolás cserével. Ebben az esetben a rendszer teljes egészében lecseréli a felhasználó csoportházirend-objektum listáját a számítógép számára a számítógép indításakor megszerzett csoportházirend-objektum listával (az Események sorrendje rendszerindításkor és bejelentkezéskor témakör 2. lépésében). A rendszer a felhasználóra alkalmazza a listában lévő Felhasználó konfigurációja beállításokat.

    Visszacsatolás összefésüléssel. Ebben az esetben a csoportházirend-objektum egy összefűzés (konkatenáció). A számítógépek 2. lépésbeli alapértelmezett listáját a rendszer hozzáfűzi a felhasználók 7. lépésbeli listájához, továbbá a felhasználó megkapja a felhasználó-konfigurációs beállításokat az összefűzött listában. Ne feledje, hogy a számítógép számára megszerzett csoportházirend-objektum alkalmazása később történik, így az fog érvényre jutni, ha a felhasználó listájában lévő beállításokkal ütközik.

  • A munkacsoport tagjaként szereplő számítógép csak a helyi csoportházirend-objektumot dolgozza fel.


A Rendszerházirend-szerkesztő szerepe

Bár a Rendszerházirend-szerkesztőt (Poledit.exe) legtöbbször felváltja a csoportházirend, az bizonyos körülmények között még mindig hasznos lehet.

  • Windows 95 vagy Windows 98 rendszert futtató számítógépek kezelése. A Rendszerházirend-szerkesztő Windows 2000-es verzióját helyileg kell futtatni a Windows 98 vagy Windows 95 rendszert használó számítógépeken a helyi operációs rendszerrel kompatibilis Config.pol fájlok létrehozásához.
  • Windows NT 4.0 Workstation és Windows NT 4.0 Server rendszert futtató számítógépek kezelése. Ezeknek a számítógépeknek saját stílusú .pol fájlokra is szükségük van: NTConfig.pol.
  • Windows 2000 rendszert futtató egyedülálló számítógépek kezelése. Tartományhoz nem csatlakozó Windows 2000 rendszert használó számítógépre nem érvényes az Active Directory nem helyi csoportházirendje. Az ilyen számítógépekre egyetlen csoportházirend érvényes csupán: az egy felhasználó beállításait tartalmazó helyi csoportházirend. (A csoportházirenddel kapcsolatos további tudnivalókért tanulmányozza a Helyi csoportházirend témakört.) Több felhasználó beállításainak biztosítása érdekében használja a Rendszerházirend-szerkesztőt a Registry.pol fájlok írására. A Rendszerházirend-szerkesztőnek csak a Windows 2000-es verziója kompatibilis a Windows 2000 rendszerrel.

Bár a Rendszerházirend-szerkesztő korábbi verziói csak ASCII-kódolású .adm fájlokat használtak, a Windows 2000 verziójú Rendszerházirend-szerkesztő támogatja a Unicode-kódolású .adm fájlokat is.


Csoportházirend replikált környezetben

Több tartományvezérlőt tartalmazó tartományban időt vesz igénybe az Active Directory adatainak továbbítása egyik tartományvezérlőről a másikra. Ez a fejezet a csoportházirend replikációs eljárásait taglalja.

Az Active Directory - felhasználók és számítógépek beépülő modul segítségével a rendszergazda bármely tartományvezérlőn létrehozhat egy szervezeti egységet.

Alapértelmezés szerint a csoportházirend-objektumok létrehozása és szerkesztése azon a tartományvezérlőn történik, amely az elsődleges tartományvezérlőt emuláló műveleti főkiszolgáló tokenjét tárolja. A token az egyik tartományvezérlőről a másikra lép, míg az Active Directory adatainak replikálása történik, ezzel megtartja a tartományvezérlők szinkronizáltságát.

Egy szervezeti egységet replikálni kell a tokent tároló tartományvezérlőre, mielőtt az abban a tartományban létrehozott csoportházirend-objektum csatolható a tokenhez, lehetővé téve a csoportházirend-beállítások érvényesítését.

Ezen megfontolások nagyobb jelentőséget kapnak, ha a belső tartomány hivatkozásai lassúak.

Egy tartományvezérlő kiválasztását meghatározó beállítások

A csoportházirend Nézet menüje egy Tartományvezérlő beállításai menüpontot tartalmaz, amely megnyitja Lehetőségek tartományvezérlő választásához párbeszédpanelt. Ennek segítségével megadható a csoportházirend szerkesztésére használt tartományvezérlő. A Lehetőségek tartományvezérlő választásához párbeszédpanelen választható beállítások a következők:

  • Az elsődleges tartományvezérlő emulációját irányító műveleti főkiszolgáló. Ez az alapértelmezett és javasolt beállítás, mely az adatbiztonságra nézve a legbiztonságosabb.
  • Az Active Directory beépülő moduljai által használt kiszolgáló. Azt a tartományvezérlőt használja, melyet a Csoportházirend konzolból automatikusan elindított segédprogram jelenleg használ, amennyiben a csoportházirend indítása ily módon történt.
  • Bármely elérhető tartományvezérlő. Lehetővé teszi a Csoportházirend beépülő modul számára bármely rendelkezésre álló tartományvezérlő kiválasztását. Ez a legkevésbé biztonságos beállítás, mivel különböző rendszergazdák elméletileg egyidejűleg is szerkeszthetnek egy csoportházirend-objektumot, ami beláthatatlan következménnyel járhat. Másrészt a beállítás használatakor valószínű, hogy egy saját helyen lévő tartományvezérlő lesz kiválasztva. Ha csak egy rendszergazda felügyelheti a csoportházirendet egy több hellyel rendelkező, nagy tartományban, akkor az így nyert teljesítmény miatt esetleg érdemes fontolóra venni a beállítás használatát.

Tartományvezérlő kiválasztása a csoportházirend segítségével

A Nézet menü előzőekben leírt lehetőségein kívül egy csoportházirend-beállítás is használható a tartományvezérlő kiválasztásához. Ez a Csoportházirend konzolba alapértelmezés szerint betöltődő System.adm felügyeleti sablon része.

A beállítás használatához kattintson a konzolfán a csoportházirend csomópontjára.

Helye:

  • Csoportházirend-objektum_neve
  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Csoportházirend
A részletek ablaktáblán kattintson duplán a Csoportházirend tartományvezérlőjének kiválasztása ikonra, majd válassza ki a megfelelő beállítást a legördülő menüből.


Feladatlista: A Szoftvertelepítő beépülő modul megnyitása

Lépés | Segédkönyvek
Áttekinti az Szoftvertelepítéssel, Csoportházirenddel és az Active Directoryval kapcsolatos kulcsfogalmakat. | Active Directory - felhasználók és számítógépek; Csoportházirend – áttekintés; Szoftver telepítése
Csoportházirend létrehozása a szervezetben. | Feladatlista: Csoportházirend megvalósítása az Active Directoryban
Nyissa meg a Csoportházirendet, hogy azt alkalmazhassa a felhasználókat és számítógépeket tartalmazó, a szoftvert fogadó helyre, tartományra vagy szervezeti egységre. | Csoportházirend megnyitása; Csoportházirend beépülő modul megnyitásának módjai
Szerezze be a szoftver Windows Installer csomagjait (.msi). | Forduljon a szoftverforgalmazóhoz
Nyissa meg a Szoftvertelepítő beépülő modult. | A Szoftvertelepítő beépülő modul megnyitása


Szoftvertelepítés ismertetése

A Szoftvertelepítő beépülő modul a Windows 2000 szoftverkezelés egyik jellemzője; ez a szervezetben a rendszergazda elsődleges szoftverkezelési eszköze a szoftver teljes élettartama során.

A Szoftvertelepítés együttműködik a csoportházirenddel és az Active Directory-val. Ez a Windows 2000 Server rendszerben szereplő három szoftvertelepítő és -karbantartó eszköz egyike. Ezeket a következő táblázat szemlélteti.

Összetevő | Szerepkör
Csoportházirend beépülő modul Szoftvertelepítési bővítménye. | Ezt a rendszergazdák a szoftver kezelésére használják.
Windows Installer | Telepíti a Windows Installer fájlokba csomagolt szoftvert.
A Vezérlőpult Programok telepítése/törlése segédprogramja | A felhasználók használják a szoftverek kezelésére saját számítógépükön.

Telepítésre kijelölés felhasználók számára

Amikor egy alkalmazást egy felhasználó számára telepítésre kijelöl, a felhasználó munkaállomásra történő következő bejelentkezésekor az alkalmazás a felhasználó számára meghirdetésre kerül. Az alkalmazás meghirdetése után a felhasználó bárhol is jelentkezik be, az alkalmazás telepítése akkor is végrehajtható. A rendszer akkor telepíti az alkalmazást, ha a felhasználó a számítógépen először indítja el az alkalmazást – a Start menü segítségével, vagy az alkalmazással társított dokumentum aktiválásával.

Telepítésre kijelölés számítógépek számára

Amikor egy alkalmazást a számítógép számára telepítésre kijelöl, az alkalmazás a számítógép számára meghirdetésre kerül, majd biztonságos esetben a rendszer elvégzi a telepítést. Általában ez a számítógép indításakor megy végbe, és így a számítógépnek nincsenek elvégzésre váró folyamatai.

Közzététel felhasználók számára

Az alkalmazás felhasználók számára történő közzétételekor a rendszer nem hajtja végre az alkalmazás telepítését. Az Asztalon vagy a Start menüben nem jelenik meg parancsikon, és a felhasználó számítógépének helyi rendszerleíró adatbázisában sem történik változás. Ehelyett a közzétett alkalmazások az Active Directoryban tárolják közzétételi attribútumaikat. Majd olyan adatokat, mint például az alkalmazás nevét és annak fájl-társításait a rendszer a felhasználó számára feljegyzi az Active Directory tárolójában. Ekkor az alkalmazás rendelkezésre áll a felhasználó számára telepítésre, amely a Vezérlőpult Programok telepítése/törlése segédprogrammal, vagy az alkalmazással társított fájlra való kattintással végezhető el (például a Microsoft Excel esetében ez egy .xls kiterjesztésű fájl).

Alkalmazás telepítésre kijelölő parancsfájljai

Egy bizonyos csoportházirend-objektumban lévő összes közzétett vagy telepítésre kijelölt alkalmazás számára a rendszer létrehoz egy telepítésre kijelölő parancsfájlt (.aas) és azt a tartomány csoportházirend-objektumában tárolja. Ezek a parancsfájlok tartalmazzák az alkalmazás konfigurációjának közzétételi adatait.

Active Directory

A Windows 2000 Active Directory tárolókból és egy bővíthető sémából álló hierarchikus gyűjteményt tartalmaz. Az Active Directory tárolóiba helyek, tartományok, szervezeti egységek, felhasználók, számítógépek, és nyomtatók is beletartoznak. Mivel a séma az Active Directory objektumok tulajdonságait határozza meg és új Active Directory objektumok meghatározására is bővíthető, így az bármilyen tetszőleges objektum tárolására használható.

A Szoftverkezelés sémára kiterjesztett objektumokat biztosít az Active Directoryban. Ezek az objektumok az osztálybeállítások használatát támogató alkalmazáscsomagok különböző osztálybeállításainak hozzárendeléséhez szükséges adatokat tárolják.

Szoftver telepítése a felhasználó szemszögéből

A felhasználó számítógépén, a rendszerösszetevők, többek között a Winlogon, a héjprogram, az objektumcsatolás és beágyazás (OLE), a Lightweight Directory Access Protocol (LDAP) ügyfél, valamint a helyi rendszerleíró adatbázis biztosítja a szoftvertelepítés felhasználói oldalát. A szoftvertelepítési házirend alkalmazására a Winlogon a kitüntetett ügynök. A héjprogram és az objektumcsatolás és beágyazás a továbbfejlesztésük következtében a telepítési műveletek elvégzéséhez támogatja az Active Directory használatát és a Windows Installer programmal történő kommunikációt. Az LDAP (Lightweight Directory Access Protocol) ügyfél támogatja az Active Directoryban való keresést és lekérdezést.

A Programok telepítése/törlése segédprogram használatával egy kezelt környezetben a felhasználó kereshet és telepíthet szoftvereket az Active Directory-ból, illetve helyi adathordozóról (nem kezelt környezetben, vagy kezelt környezetben, ha a házirend lehetővé teszi a helyi adathordozóról való telepítést).

A következő szakasz tartalma:

  • Szoftver telepítése a rendszergazda szemszögéből
  • A Vezérlőpult Programok telepítése/törlése segédprogramja
  • A szoftvertelepítés során gyakran előforduló fájltípusok


Szoftver telepítése a rendszergazda szemszögéből

A rendszergazdának a szervezetben a szoftverek kezelése érdekében el kell végeznie az alábbi lépéseket: előkészítés, kezelés és eltávolítás.

Előkészítés

A Szoftver telepítése segédprogram használatát megelőzően szükség van a telepíteni kívánt program Windows Installer csomagjára. A csomag legtöbbször a szoftverrel együtt kapható. Ha a program nem rendelkezik Windows Installer csomaggal, azt létre kell hozni. Külső cég által írt olyan segédprogramok is kaphatók, melyek segítségével a telepíteni kívánt program csomagja újra létrehozható. Ezután az átalakító fájlok segítségével a csomag testreszabása tovább folytatható.

A következő lépés a csomagokat, alakító fájlokat, valamint a program fájljait és összetevőit tartalmazó hálózati megosztás, más néven szoftverterjesztési pont létrehozása. Nem szükségszerű, de ha a csomagok és programfájlok tárolása egy helyen történik, a felügyeleti műveletek elvégzése egyszerűbb. (A csomagokat és az átalakító fájlokat nem kell egy helyen tárolni.) További előny az is, hogy a rendszergazdák az elosztott fájlrendszereket használhatják e szoftverterjesztési pontok kezelésének megkönnyítésére.

Végül szükséges, hogy a felhasználók a szoftverterjesztési pontokról olvasni, valamint a telepítés célhelyére írni tudjanak, különösen akkor, ha a rendszer éppen hálózati fájlkiszolgálóra írja a programot.

Szoftverek kezelése

A szervezetben a programok kezeléséhez használja a Szoftver telepítése segédprogramot. A számítógépek vagy a felhasználók számára a program telepítésre kijelölhető, vagy a felhasználók számára közzétehető.

A felhasználó számára történő telepítésre kijelölés és közzététel az alábbi szoftverélettartam fázisokból áll:

  • Próbafázis: Kipróbálás céljára elképzelhető, hogy csupán néhány felhasználó számára kíván új programokat közzétenni. Ezen fázisban a program régebbi verziója az alapértelmezett verzió, és a felhasználók többsége még mindig azt használja. Ebben az esetben egy új felhasználó még a telepítésre kijelölt vagy a közzétett verziót fogja telepíti. Ezt gyakran próbatelepítésnek nevezik. A próbatelepítés a legjobb alkalom a Szoftver telepítése segédprogram lehetőségeinek megismerésére (Telepítésre kijelöl/Közzétesz, Automatikus telepítés/Nem automatikus telepítés és Látható telepítés/Rejtett telepítés).
  • Bevezetési fázis: A bevezetési fázisban a rendszergazda elkezdi az új programot több felhasználó számára is elérhetővé tenni. A program új verziója lesz ekkor az alapértelmezett, és a felhasználók többsége az új verziót használja. Ebben az esetben az új felhasználónak nincs más választása, mint az új program telepítése. A rendszergazda bizonyos felhasználókat mentesíthet e telepítés alól, amennyiben a telepítés a felhasználó munkáját akadályozná.

A program eltávolítási fázisa

Amikor a rendszergazda egy programot eltávolít, az alábbi választási lehetőségek közül kell választania (a választási lehetőségek kölcsönösen kizáró jellegűek):

  • Azonnali eltávolítás: Ennek végrehajtásához szükséges, hogy egy felhasználó se használja a programot. Azok a felhasználók, akiknek számítógépén még megtalálható a program, egy hirdetményt kapnak, amely a programot eltávolítja.
  • Új telepítések megakadályozása: Ez lehetővé teszi a felhasználó számára, hogy a már telepített szoftver használatát folytathassa.

Program törlése a kiszolgálóról

Amikor a rendszergazda biztos abban, hogy a program régebbi verziójára a szervezetnek már nincs szüksége, törölheti a Windows Installer csomagokat, valamint a programfájlokat és az összetevőket. Ajánlatos a csomag, a programfájlok és az összetevők archiválása, majd a szoftverelosztói pontról a fájlok törlése.


A Vezérlőpult Programok telepítése/törlése segédprogramja

A Vezérlőpulton lévő Programok telepítése/törlése segédprogram révén számos feladat, elsősorban egy alkalmazás helyi adathordozóról (például CD-ROM vagy hajlékony lemezről), egy meghatározott Active Directory helyről (vállalati hálózaton lévő telepítésre kijelölt és közzétett alkalmazás) vagy az Internetről történő telepítése végezhető el. A Programok telepítése/törlése segédprogram a meglévő alkalmazások eltávolítására és módosítására, illetve a megsérült alkalmazások kijavítására is használható.

A Programok telepítése/törlése továbbá az alábbi szolgáltatásokat biztosítja:

  • A programok kezelésére és karbantartására a felhasználó számára egy egységes felhasználói felületet biztosít.
  • Hasznos felületet nyújt mind haladó, mind kezdő Microsoft Windows felhasználók számára.
  • Támogatja a programok telepítését mind a felhasználó birtokában lévő programcsomagról (helyi adathordozón), mind vállalati vagy Internetes erőforrásokról.
  • A Windows Installer összetevőit rendelkezésre bocsátja más telepítési technológiák támogatása mellett.


Házirend öröklése

Általában a rendszer a szülőtárolóról a gyermektárolóra továbbítja Csoportházirendet. Ha egy adott csoportházirendet egy magas szintű szülőtárolóhoz társított, a csoportházirend a szülőtároló alatti összes tárolóra érvényben lesz – beleértve az egyes tárolókban lévő felhasználó és számítógép objektumokat is. Ha viszont egy gyermektárolóra adja meg a csoportházirend-beállítást, a gyermektároló csoportházirend-beállításai felülbírálják a szülőtároló beállításait.

Ha a szülő szervezeti egység nem konfigurált házirend-beállításokkal rendelkezik, a gyermek szervezeti egység nem örökli azokat. A letiltott házirend-beállítások ugyanúgy öröklődnek, letiltottként. Ha egy szülő szervezeti egység egyik konfigurált házirendje a gyermek szervezeti egységben nincs konfigurálva, a gyermek szervezeti egység örökli a szülő házirend-beállítását.

Ha a szülőházirend és a gyermekházirend kompatibilis, a gyermek örökli a szülőházirendet és a rendszer alkalmazza a gyermek beállításait is. Csak a kompatibilis házirendek örökölhetők. Ha például a szülő házirendje azt határozza meg, hogy valamilyen mappa az Asztalra kerüljön, és a gyermek beállításai is meghatároznak egy másik mappát, akkor a felhasználó mindkét mappát látni fogja.

Ha a szülő szervezeti egység számára konfigurált házirend nem kompatibilis a gyermek szervezeti egység számára konfigurált ugyanazon házirenddel, a gyermek szervezeti egység nem örökli a szülőtől a házirend-beállításokat. A rendszer a gyermek szervezeti egység beállításait alkalmazza.

Öröklés blokkolása

A Házirend öröklődésének blokkolása jelölőnégyzet segítségével hely, tartomány vagy szervezeti egység szintjén a házirendek öröklése blokkolható. Ha ezt a beállítást egy gyermekszintű csoportházirend-objektum számára választotta ki, a gyermek nem örököl semmilyen házirendet a szülő csoportházirend-objektumtól.

Öröklés kikényszerítése

A Nincs felülbírálás jelölőnégyzet kiválasztásakor minden gyermekházirend-tároló örökli a szülő házirendjeit, akkor is, ha azok a házirendek ütköznek a gyermekházirendekkel, és akkor is, ha a Házirend öröklődésének blokkolása jelölőnégyzet az adott gyermeknél be van jelölve.


Gyakorlati tanácsok

Csoportházirend

  • A csoportházirend-objektum nem használt részeinek letiltása
    Ha egy csoportházirend-objektum a konzolon a Felhasználó konfigurációja vagy a Számítógép konfigurációja csomópontokon csak Nem konfigurált beállításokkal rendelkezik, a beállítások feldolgozása elkerülhető a csomópont letiltásával. Ily módon a rendszerindítás és a bejelentkezés e csoportházirend-objektumok felhasználói és számítógépei számára gyorsabb lesz. További tudnivalókért tanulmányozza a Csoportházirend-objektum Felhasználó konfigurációja beállításainak letiltása és a Csoportházirend-objektum Számítógép konfigurációja beállításainak letiltása témaköröket.
  • A Házirend öröklődésének blokkolása és a Nincs felülbírálás beállítások korlátolt használata
    E beállítások gyakori használata megnehezíti a házirendek hibaelhárítását.
  • A tartományban vagy a szervezeti egységekben lévő felhasználókhoz társított csoportházirend-objektumok számának minimálisra csökkentése
    Minél több csoportházirend-objektum van érvényben egy felhasználóra, annál hosszabb ideig tart a bejelentkezése.

  • Házirend szűrése biztonsági csoporttagság alapján
    Ha a felhasználó nem rendelkezik olyan Hozzáférés vezérlése bejegyzéssel (ACE), amelyik a felhasználóra egy meghatározott csoportházirend-objektumot alkalmaz, akkor elkerülheti a várakozást a bejelentkezés során, mivel ebben az esetben a rendszer a felhasználó esetében a csoportházirend-objektumot nem dolgozza fel.

    A szűrés csak a biztonságicsoport-tagság használatával végezhető el.

    A Hozzáférés vezérlése bejegyzés (ACE) a Csoportházirend-objektum Tulajdonságok lapján, a Biztonság lapon jelenik meg.

  • Szükség esetén a felhasználótól függő csoportházirend felülbírálása a számítógéptől függő csoportházirendekkel
    Használja ezt a lehetőséget, ha a bejelentkező felhasználóktól függetlenül egyféle Asztal-konfigurációra van szüksége.
  • Tartományok közötti csoportházirend-objektum hozzárendelések elkerülése
    A csoportházirend-objektumok feldolgozása lelassítja a bejelentkezést és a rendszerindítást, ha a csoportházirendet egy másik tartományról kapja a rendszer.

Szoftver telepítése és kezelése

  • Alkalmazáskategóriák megadása a szervezet számára
    A kategóriák használata megkönnyíti a felhasználók számára az alkalmazások keresését a Vezérlőpult Programok telepítése/törlése segédprogramjában. Létrehozhatók olyan kategóriák, mint például Értékesítési alkalmazások, Számviteli alkalmazások stb. További tudnivalókért tanulmányozza az Alkalmazások kategóriáinak megadása témakört.
  • A Windows Installer csomagok megfelelő átalakításának biztosítása közzétételük vagy telepítésre kijelölésük előtt
    Ne feledje, hogy a rendszer az átalakító fájlokat a telepítésre kijelöléskor vagy a közzétételkor alkalmazza a csomagokra. Az átalakító fájlok vagy .mst fájlok valójában a Windows Installer csomagokra alkalmazott egyedi beállítások. A rendszer az átalakító fájlt a telepítésre való kijelöléskor vagy a közzététel végrehajtásakor alkalmazza, nem pedig a telepítés ideje alatt. Tulajdonképpen ez azt jelenti, hogy még egyszer ellenőrizni kell a csomag tulajdonságai párbeszédpanel Módosítások lapján lévő beállításokat az OK gombra kattintás előtt. Ha nem így tesz, és a teljes konfigurálás előtt telepítésre kijelöl vagy közzétesz egy átalakított csomagot, akkor a szoftver eltávolítható, illetve újra közzétehető, telepítésre kijelölhető vagy frissíthető egy teljesen átalakított verzióval. Ha az eljárással kapcsolatban további információra van szüksége, tanulmányozza a Kezelt alkalmazás eltávolítása és a Kezelt alkalmazás frissítése témaköröket.
  • Csoportházirend-objektumonként csak egy telepítésre kijelölés vagy közzététel végrehajtása
    Egy Windows Installer csomag csak egyszer jelölhető ki telepítésre vagy tehető közzé ugyanabban a csoportházirend-objektumban. Ha például a számítógépre érvényes csoportházirend-objektumhoz rendeli hozzá a Microsoft Office alkalmazást, a felhasználókra érvényes csoportházirend-objektumhoz azt ne rendelje hozzá.
  • A szerkesztőeszközök előnyeinek kihasználása
    A fájlokat, rendszerleíróadatbázis-bejegyzéseket és az alkalmazások megfelelő működéséhez szükséges egyéb követelményeket ismerő fejlesztők számos, szoftverforgalmazók által kínált eszköz segítségével létrehozhatnak natív Windows Installer csomagokat.
  • Létező szoftverek újracsomagolása
    Kereskedelmi forgalomban beszerezhető eszközök használhatók a natív .msi kiterjesztésű fájlokat nem tartalmazó szoftverek Windows Installer csomagjainak létrehozására. Ezek az eszközök összehasonlítják a számítógép telepítés előtti és utáni állapotát. A legjobb eredmény elérése érdekében a szoftvert olyan számítógépre érdemes telepíteni, amely nem tartalmaz más alkalmazást (tiszta telepítés).
  • SMS és DFs használata
    A Microsoft Systems Management Server (SMS) program és a Windows 2000 elosztott fájlrendszere (Dfs) hasznos eszköz a szoftverterjesztési pontok kezelésében (az a hálózati megosztás, melyről a felhasználók a kezelt szoftvereket telepítik).
  • Az Active Directory hierarchiában magas szinten telepítésre kijelölés vagy közzététel
    Mivel a csoportházirend-beállítások alapértelmezés szerint érvényesek a gyermek Active Directory tárolókra, a hatékonyságot növeli, ha a telepítésre kijelölést vagy a közzétételt úgy végzi, hogy a csoportházirend-objektumot a szülő szervezeti egységhez vagy tartományhoz csatolja. A csoportházirend-objektumok biztonsági leírókkal (hozzáférés vezérlése bejegyzés vagy ACE) való használata által a szoftvert fogadó személyek vagy számítógépek jobban felügyelhetők. További tudnivalókért tanulmányozza a Biztonsági csoportok használata a Csoportházirend szűrésére témakört.

    Megjegyzések

    • A szoftverterjesztési pontból történő telepítéshez a Hitelesített felhasználók csoport számára az Olvasás és a Csoportházirend alkalmazása hozzáférés-vezérlési bejegyzések (ACE-k) szükségesek.
    • A rendszergazdáknak Teljes hozzáférés jogokkal kell rendelkezniük a szoftverek kezeléséhez.
  • A Szoftvertelepítés modul tulajdonságainak használata széles hatókörű felügyelethez
    A Csoportházirend konzolon kattintson a jobb oldali egérgombbal a Szoftvertelepítés csomópontra, majd a helyi menün kattintson a Tulajdonságok parancsra.

    Helye:

    • Csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
    • Ez megkönnyíti a rendszergazda munkáját, ha sok csomagot jelöl ki telepítésre vagy tesz közzé hasonló tulajdonságokkal egyetlen csoportházirend-objektumban. Például amikor minden szoftver ugyanazon a terjesztési ponton lesz közzétéve.
  • A Windows Installer csomag tulajdonságainak használata részletes felügyelethez
    Az előzőek szerint lépjen a Szoftvertelepítés csomópontra, és kattintson a jobb oldali egérgombbal a részletek ablaktáblán a csomagra, majd a Tulajdonságok parancsra. Használja ezt az eljárást egyetlen csomag telepítésre kijelöléséhez vagy közzétételéhez.

Mappa átirányítása

  • Ügyféloldali gyorsítótár engedélyezése
    Ez különösen fontos a laptopot használó felhasználók számára.
  • Az univerzális elnevezési konvenciónak (UNC) megfelelő teljes elérési útba a %username% változó befoglalása
    Ez lehetővé teszi a felhasználók számára, hogy saját mappáikkal mindig rendelkezzenek. Például \\kiszolgáló\megosztás\%username%\Dokumentumok
  • Képek mappa követi a Dokumentumok mappát
    Ez javasolt, hacsak nincs olyan ok, ami miatt ezt meg kell változtatni, például a fájlmegosztás méretezhetősége miatt.
  • Házirend eltávolításával kapcsolatos megfontolások
    Házirend eltávolításakor ne feledkezzen meg a Mappa átirányítása házirendek viselkedéséről, ahogy azt a Vigyázat! szakaszban megtalálhatja.
  • Alapértelmezések elfogadása
    Általában fogadja el az alapértelmezett mappaátirányítási beállításokat.


Csoportházirend elsőbbségi sorrend

A Windows 2000 rendszer a csoportházirendet az Active Directory objektumaival (helyek, tartományok vagy szervezeti egységek) társított csoportházirend-objektumokra alkalmazza. A csoportházirend felhasználókra és számítógépekre is alkalmazható. Bár bizonyos beállítások a felhasználói felületre vonatkoznak – például a háttér bitképe, vagy a Start menü Futtatás parancsának használhatósága – egyes számítógépekre is alkalmazhatók.

A rendszer hierarchikus felépítés szerint alkalmazza a csoportházirendet a legkevésbé korlátozó csoporttól kezdve (hely) a legkorlátozóbb csoportig (szervezeti egység). A csoportházirend egyben öröklődik is. A gyermek címtárszolgáltatás tárolók öröklik a szülőtárolók csoportházirendjét. A csoportházirend alkalmazása az alábbi sorrendben történik: hely, tartomány és szervezeti egység. Ez azt jelenti, hogy ha egy magas szintű szülőtárolóhoz hozzárendelt egy adott csoportházirendet, az a csoportházirend a szülőtároló alatti összes tárolóra érvényes lesz – beleértve az egyes tárolókban lévő felhasználó és számítógép objektumokat is. Ha azonban egy gyermektárolóhoz rendel egy csoportházirendet, a gyermektároló csoportházirendje felülbírálja a szülőtároló csoportházirendjét.

Amennyiben szükséges, a csoportházirend rákényszeríthető a gyermekkönyvtár tárolóira is a csoportházirend-objektum Nincs felülbírálat jelölőnégyzetének bejelölésével. A szülőkönyvtár tárolók csoportházirendjének öröklése is megakadályozható.

Ütközés esetén a csoportházirend elsőbbségi joggal rendelkezik a profilbeállításokkal szemben.

A következő szakasz tartalma:

  • Események sorrendje indításkor és bejelentkezéskor
  • Beállítások feldolgozásának sorrendje
  • Az alkalmazások szerepe a csoportházirend elsőbbségi sorrendjében


Helyi csoportházirend

A Windows 2000 rendszert használó minden egyes számítógép egyetlen csoportházirend-objektummal rendelkezik. Ezen objektumok használatával a csoportházirend beállítások egyedi számítógépeken tárolhatók, függetlenül attól, hogy azok az Active Directory környezetnek vagy a hálózati környezetnek részei.

Mivel a helyi csoportházirend-objektum beállításait a helyekkel, tartományokkal és szervezeti egységekkel társított csoportházirend-objektumok felülírhatják, a helyi csoportházirend-objektumnak van a legkisebb befolyása az Active Directory környezetben. Nem hálózati környezetben (vagy Windows 2000 tartományvezérlővel nem rendelkező hálózati környezetben) a helyi csoportházirend-objektum beállításai nagyobb jelentőségűek, mivel ezeket a csoportházirend-objektumok nem írják felül.

A Csoportházirend beépülő modul megnyitásával a helyi számítógépen tárolt helyi csoportházirend-objektum szerkeszthető. Ha az eljárással kapcsolatban további tudnivalókra van szüksége, tanulmányozza a Helyi csoportházirend-objektum megnyitása témakört.

A hálózaton egy másik számítógépen tárolt csoportházirend-objektum szerkesztéséhez nyissa meg a Csoportházirendet a Microsoft Management Console (MMC) önálló beépülő moduljaként, majd keresse meg a kívánt csoportházirend-objektumot. Ha az eljárással kapcsolatban további tudnivalókra van szüksége, tanulmányozza a Csoportházirend önálló MMC beépülő modulkénti megnyitása témakört.

A helyi csoportházirend-objektum a SystemRoot\System32\GroupPolicy könyvtárban található.

A Windows NT 4.0 vagy korábbi rendszert használó számítógépeknek nincs helyi csoportházirend-objektuma.


Ügyfél operációs rendszerek

Ez a témakör számos kérdéssel foglalkozik a különféle operációs rendszerű házirend ügyfelekkel kapcsolatban.

Windows 2000 Server

A Windows 2000 Server rendszert használó számítógépek az Active Directory egyszerű tagkiszolgálói vagy tartományvezérlők lehetnek. A csoportházirend mindkét esetet teljes mértékben támogatja.

Windows 2000 Professional

A csoportházirend teljes mértékben támogatja a Windows 2000 Professional rendszert használó ügyfélszámítógépek használatát.

Windows NT 4.0 Workstation és Server

A beépített Rendszerházirend-szerkesztő (Poledit.exe) segítségével a Windows NT 4.0 Rendszerházirendje továbbra is teljes mértékben támogatja ezen ügyfeleket. A rendszergazda a Poledit.exe programot használja a Windows NT 4.0-rendszerű .adm fájlok írásához.

A Windows NT 4.0 rendszer nem használja az Active Directory-t. Mivel a Windows NT 4.0 rendszert használó számítógépeknek nincs helyi csoportházirend-objektumuk, a csoportházirend sincs érvényben.

Windows 95 és Windows 98

A Windows 95 és Windows 98 ügyfeleknek a helyi számítógépen kell futtatniuk a Rendszerházirend-szerkesztőt (Poledit.exe). Ez biztosítja azt, hogy a létrehozott Config.pol fájl kompatibilis legyen ezekkel az operációs rendszerekkel. Másolja át az eredményül kapott Config.pol fájlt a Windows 2000 Server tartományvezérlőjének SysVol mappájába.

A csoportházirend nincs érvényben.

Windows NT 3.51, Windows 3.1 és MS-DOS

A csoportházirend nincs érvényben.

Megjegyzés

  • A Windows 2000 rendszert használó egyes számítógépeken csak egy helyi csoportházirend-objektum található, továbbá az azt tartalmazó Felhasználókonfigurációs beállítások is ugyanazok a számítógép összes felhasználójára vonatkozóan. Egyetlen csoportházirend-objektumot használó Windows 2000 rendszert futtató számítógépen (ha az nem része Windows 2000 tartománynak, mert például egy különálló számítógép) házirendek alkalmazásával több felhasználói beállítás kezeléséhez a rendszergazda a Rendszerházirendet a Rendszerházirend-szerkesztő (Poledit.exe) segítségével szerkesztheti. A Poledit.exe program a helyi számítógépen fut, és segítségével létrehozható egy megfelelő formátumú .pol kiterjesztésű fájl. Ha sem a rendszerházirend, sem a csoportházirend nem használatos, a felhasználói profilok segítségével lehet az egyes felhasználók számára egyéni beállítású Asztalokról gondoskodni.


Biztonsági csoportok használata a csoportházirend szűrésére

Mivel a csoportházirend több csoportházirend-objektum beállításait alkalmazhatja egy helyre, tartományra vagy szervezeti egységre, más könyvtárobjektumokkal társított csoportházirend-objektumok is hozzáadhatók. Elsőbbségi sorrend használható annak megadására, hogy ezek a csoportházirend-objektumok hogyan befolyásolják azokat a könyvtárobjektumokat, amelyekre érvényesek.

A Windows 2000 rendszerben a számítógépek biztonsági csoportokhoz tartozhatnak. A rendszergazdák a biztonsági csoportokat felhasználva tovább finomíthatják a csoportházirend-objektum által befolyásolt számítógépek és felhasználók körét. Bármely csoportházirend-objektumra vonatkozóan a rendszergazdák megszűrhetik a csoportházirend-objektum hatását egy adott biztonsági csoport tagjaként szereplő számítógépekre. Ezt a szűrést a szabványos hozzáférési jogok listájának (ACL) szerkesztője végzi. Ha a hozzáférési jogok listájának (ACL) szerkesztőjét kívánja használni, kattintson a csoportházirend-objektum tulajdonságlapjára, majd kattintson a Biztonság elemre. A hozzáférési jogok listájának (ACL) szerkesztőjét a rendszergazda is használhatja, hogy meghatározza, ki módosíthatja a csoportházirend-objektumot.


Speciális módszerek a csoportházirend hatókörének kibővítésére

A következő speciális módszerek használhatók a csoportházirend hatókörének kibővítésére.

Módszer Előnyök Hátrányok
Speciális módszer a rendszergazda számára: .adm fájl írása.
  • Egyszerűbb lehetőség.
  • Minden, amire szükség van, megtalálható a Windows 2000 rendszerben.
  • Az .adm kiterjesztésű fájlok ASCII fájlok, melyek a Jegyzettömbben szerkeszthetők.
  • Új fájl létrehozásával vagy meglévő sablon módosításával is elérhető a kívánt végeredmény.
  • Csak a rendszerleíró adatbázison alapuló házirendekhez megfelelő.
  • A felhasználói felület korlátozott. Lehetséges, hogy nehéz feladat megkeresni az egyedi házirendek beállításának helyét.
Egy módszer csak szoftverfejlesztők számára: írjon egy csoportházirend-bővítményt.
  • Részletesebb felhasználói felület.
  • A Csoportházirend beépülő modul teljes alkalmazásprogramozási felületét (API) használhatják a fejlesztők.
  • Nem korlátozódik a rendszerleíró adatbázison alapuló házirendekre.
  • Mivel a bővítmény megírása sok időt vehet igénybe, a módszert csak akkor érdemes alkalmazni, ha a bővítményt széles körre kiterjedően vagy gyakran fogja használni.
  • Software Development Kit anyagok szükségesek a fejlesztéshez, melyek nem részei a Windows 2000 rendszernek.

Testreszabott .adm fájlok létrehozása

A rendszergazda létrehozhat testreszabott .adm fájlokat is, ha a rendelkezésre álló sablon (System.adm) nem megfelelő. Bár ha lehetséges, ajánlott a rendelkezésre bocsátott sablon használata.

A Felügyeleti sablonok a rendszerleíróadatbázis-beállításokat nagy számú számítógépre továbbítják anélkül, hogy szükség lenne a rendszerleíró adatbázis alapos ismeretére. A Windows 2000 rendszerben a Csoportházirend beépülő modul használható a rendszerleíró adatbázison alapuló házirendek megadására. A Windows NT 4.0 rendszerben a Rendszerházirend-szerkesztő (Poledit.exe) tette lehetővé a Rendszerházirend megadását.

További információt a következő témakörökben talál: Testreszabott .adm fájlok létrehozása.

Microsoft Management Console (MMC) beépülő modulbővítmények létrehozása

Ez a szoftverfejlesztők feladata, nem pedig a rendszergazdáké.

A szoftverfejlesztők a csoportházirendek beállítását biztosító programspecifikus felhasználói felületek létrehozásához fejleszthetnek MMC beépülő modulbővítményeket.

A Microsoft Management Console (MMC) eszközzel kapcsolatos tudnivalókért látogassa meg a következő címet (Microsoft Platform): SDK dokumentáció (http://msdn.microsoft.com/) (a telepítéssel kapcsolatos és a rendszerfelügyeleti szolgáltatások fejlesztői számára hasznos információkat találhatja itt meg).


Csoportházirend felügyeletének átadása

Csoportházirend felügyeletének átadásához először hozza létre, majd mentse el a csoportházirendet a Microsoft Management Console-ban (.msc fájlok). A következő lépésben meg kell határoznia, hogy a csoportházirend-objektumhoz, a helyhez, a tartományhoz és a szervezeti egységhez melyik felhasználó és csoport rendelkezzen hozzáférési engedélyekkel.

A csoportházirend olvasási és írási engedélyeinek megadása

Egy csoportházirend-objektum biztonsági hozzáférés-szabályozási listájának (ACL) szerkesztőlapja a csoportházirend-objektum Tulajdonságok párbeszédpanelén található. A hozzáférés-szabályozási lista (ACL) szerkesztőjének megnyitásához kattintson a jobb oldali egérgombbal a csoportházirend gyökércsomópontjára, majd a Tulajdonságok parancsra, végül a Biztonság elemre. A Biztonság tulajdonságlap a kiválasztott csoportházirend-objektum engedélyeinek megadására használható. Ezek az engedélyek engedélyezik vagy letiltják az egyes csoportok hozzáférését a csoportházirend-objektumhoz.

A szervezet hálózati főrendszergazdái (a Tartományi rendszergazdák csoport tagjai) a hozzáférés-szabályozási lista (ACL) szerkesztőjét használhatják annak meghatározásához, hogy melyik rendszergazdai csoport módosíthatja a csoportházirend-objektumokban tárolt házirendeket. A művelet végrehajtásához a hálózati rendszergazda rendszergazdai csoportokat határozhat meg (például Naplózási rendszergazdák), és elláthatja azokat a csoportházirend-objektumokra vonatkozó Olvasás és Írás jogokkal. Ily módon a hálózati rendszergazda a csoportházirend-objektumban lévő házirendek felügyeletét átadhatja másoknak.

Megjegyzés

A csoportházirend-objektumhoz Olvasás joggal rendelkező, de Írás joggal nem rendelkező felhasználó vagy rendszergazda nem használhatja a Csoportházirend beépülő modult a csoportházirend-objektumban lévő beállítások megtekintéséhez. A csoportházirend minden bővítménye feltételezi, hogy az a csoportházirend-objektum tárolási helyeihez Írás joggal rendelkezik. Így a Csoportházirend beépülő modul nem nyitja meg a csoportházirend-objektumot, ha ahhoz az aktuális felhasználó nem rendelkezik Írás joggal.


Haladó felhasználóknak: Testreszabott .adm fájlok létrehozása

Az .adm fájl határozza meg, hogy a rendszerleíró adatbázissal kapcsolatos csoportházirend-beállítások hogyan jelennek meg a csoportházirend felhasználói felületén a Felügyeleti sablonok csomópontok alatt. Az .adm fájl további szerepe:

  • Meghatározza azokat a rendszerleíró adatbázis helyeket, ahol módosításokat kell végezni, ha a rendszergazda egy bizonyos kijelölést végez. (Ezek a rendszerleíró adatbázis helyek nem jelennek meg a csoportházirend felhasználói felületén, mivel a rendszergazdának általában nem kell azokon közvetlenül dolgoznia.)
  • Megadhat a kijelöléssel kapcsolatos bármilyen beállítást vagy (értékbeli) korlátozást.
  • Megadhatja a kijelölés aktiválásakor használatos alapértelmezett értéket.

Az alábbi témakörök az .adm fájl összetevőit írják le:

  • STRING
  • CLASS
  • CATEGORY
  • POLICY
  • EXPLAIN
  • PART
  • PartTypes
  • NUMERIC


Karakterlánc-változók

Egy .adm fájlban karakterlánc-változók akkor használatosak, ha a változót szöveges karakterlánc megadására kell alkalmazni a felhasználói felülethez. Ez a hosszú, az .adm fájlban több helyen használt karakterláncok esetén hasznos. A módszer továbbá más nyelvekre történő könnyű konverziót (honosítás) tesz lehetővé.

Karakterlánc-változók használhatók a CATEGORY, a POLICY, a PART és a DEFAULT kulcsszavak esetén. Ha a változó neve elé két felkiáltójelet ír (!!), hozzárendelheti a változónevet az összetevőhöz. Ezután a fájl [strings] szakaszában csatolja a változót a felhasználó felületen ténylegesen használt karakterlánchoz. A karakterláncot idézőjelek közé kell tenni.

összetevő !!változó

ahol az összetevő a CATEGORY, POLICY, PART vagy DEFAULT kulcs, a változó pedig az adott karakterlánchoz használni kívánt változó.

Választhatóan a változó neve dupla idézőjelbe is tehető ("). A szóközökkel ellátott neveket idézőjelek közé kell tenni.

A fájl [strings] szakaszában a változót az alábbi módon kell megadni:

változó = "karakterlánc"

Példa karakterlánc-változóra

Tegyük fel, hogy a következő kategórianevet kívánja használni számos helyen a felhasználó felületen:

Az első kategóriám

Az alábbi változót ehhez a karakterlánchoz rendeli:

ElsőKategória

Ebben az esetben a következőt kell használnia:

CATEGORY !!ElsőKategória

Majd a [strings] szakaszban az ElsőKategória változót kell definiálni:

ElsőKategória="Az első kategóriám"

Eredmény: Az első kategóriám karakterlánc idézőjelek nélkül megjelenik a Csoportházirend beépülő modul felhasználói felületen.


CLASS

Az .adm fájlban lévő első bejegyzésnek a következőnek kell lennie: CLASS xxxx, melyben az xxxx paraméter a következők egyike lehet:

MACHINE: Ez a szakasz a csoportházirendben lévő Számítógép konfigurációja csomópontban található bejegyzéseket tartalmazza.

USER: Ez a szakasz a csoportházirendben lévő Felhasználó konfigurációja csomópontban található bejegyzéseket tartalmazza.

Az .adm fájlban csak ez a két osztály érvényes. A Csoportházirend beépülő modul figyelmen kívül hagyja az érvénytelen osztályokat.

A CLASS bejegyzés érvényes kulcsszavai a következők:

  • CLASS
  • CATEGORY
  • StringsSect
  • USER
  • MACHINE


CATEGORY

A kategórianév a csoportházirendben csomópontként jelenik meg vagy a Számítógép konfigurációja, vagy a Felhasználó konfigurációja csomópontban, attól függően, hogy a MACHINE vagy a USER osztályban van-e definiálva.

A CATEGORY szintaxisa a következő:

CATEGORY !!"változónév"

[KEYNAME "kulcsnév"]

[... házirenddefiníciós_utasítások ...]

END CATEGORY

ahol:

A változónév a kategória neve, ahogy az a Csoportházirend listában megjelenik. A szóközökkel ellátott neveket idézőjelek közé kell tenni.

A kulcsnév a kategóriához használandó választható rendszerleíró kulcsnév. Ha a kulcsnév meg van adva, akkor azt minden gyermekkategória, gyermekházirend és gyermekrész használja, hacsak azok nem adnak meg egy saját kulcsnevet. A szóközökkel ellátott neveket idézőjelek közé kell tenni.

Házirend-definíciós utasítás egynél többször nem jelenhet meg egy kategóriában.

A következő példa az ÚjKategória kategória egy kategórianevét mutatja be:

CATEGORY !!ÚjKategória

A beállítások megadása után a kategória bezárásához adja meg a következőt:

END CATEGORY ; ÚjKategória

Ne feledje, hogy a kategóriák egymásba ágyazhatók alkategóriák létrehozásához, például az alábbiak szerint:

CATEGORY !!ElsőKategória
   CATEGORY !!MásodikKategória
     CATEGORY !!HarmadikKategória
     ...
     ...
     END CATEGORY ; HarmadikKategória
   END CATEGORY ; MásodikKategória
END CATEGORY ; ElsőKategória

A CATEGORY kulcsszó érvényes kulcsszavai a következők:

  • KEYNAME
  • CATEGORY
  • POLICY
  • END


POLICY

A felhasználó által módosítható házirend megadásához használja a POLICY kulcsszót:

POLICY !!ElsőHázirendem
...adja meg az összes, házirenddel kapcsolatos adatot
...végül adja meg a következőt:
END POLICY

Egy KEYNAME alatt több POLICY kulcsnév használható. Az előző példában az .adm fájl [strings] szakaszában kell megadni az ElsőHázirendem változót.

A POLICY kulcsszó érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUENAME
  • PART
  • VALUEON
  • VALUEOFF
  • ACTIONLISTON
  • ACTIONLISTOFF
  • END
  • HELP
  • CLIENTEXT
  • POLICY

VALUENAME

A házirendben használható beállításokat határozza meg. Először a rendszerleíróadatbázis-értéket kell megadni, amely módosításra kerül az VALUENAME kulcsszó használatával. Például VALUENAME ElsőÉrtékem.

Ha a felhasználó kiválasztja vagy törli ezt a beállítást, a rendszer a következő formában – kivéve ha másképp adja meg – írja az értéket:

  • Bejelölt: REG_DWORD, melynek értéke 1.
  • Nem bejelölt: az értéket eltávolítja.

További beállítások a következő szakaszokban találhatók. Ha a beállítást a Csoportházirend beépülő modul alsó ablaktábláján kell kiválasztani, a VALUENAME elemnek a PART hatókörben kell lennie, ahogy ezt a PART témakörben megtalálhatja.

CLIENTEXT

A CLIENTEXT kulcsszó meghatározza, hogy a Csoportházirend beépülő modul melyik ügyféloldali bővítménye (például egy .dll fájl a felhasználó számítógépén) szükséges bizonyos beállítások feldolgozására az ügyfélszámítógépen. Alapértelmezés szerint a Rendszerleíró adatbázis bővítmény dolgozza fel a Felügyeleti sablonok csomópont alatt meghatározott összes beállítást. A CLIENTEXT kulcsszó megváltoztatja az alapértelmezett viselkedést, mely azt eredményezi, hogy miután a Rendszerleíró adatbázis bővítmény a rendszerleíró adatbázisba helyezte ezeket a beállításokat, a megadott bővítmény feldolgozza azokat.

A CLIENTEXT kulcsszót vagy a POLICY, vagy a PART hatókörben kell használni, melyet a VALUENAME utasításnak kell követnie.

Például:

POLICY !!DQ_Enforce
        EXPLAIN !!DQ_Enforce_Help
            VALUENAME "Enforce"
            CLIENTEXT {3610eda5-77ef-11d2-8dc5-00c04fa31a66}
           PART !!DQ_EnforceTip1                         TEXT
        END PART
END POLICY

A CLIENTEXT kulcsszót követő GUID elem az ügyféloldali bővítmény GUID eleme. A rendszer felsorolja az ügyféloldali bővítményeket a rendszerleíró adatbázisban a következő bejegyzésnél:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon\GPExtensions.

VALUEOFF/VALUEON

A VALUEOFF/VALUEON kulcsszavak a beállítás állapotán alapuló specifikus értékek írására használatosak. Ez a lehetőség engedélyezhető, ha az .adm fájlt következő példa szerinti szerkeszti át:

KEYNAME ....
   POLICY !!Házirend
   VALUENAME MódosítaniKívántÉrték
   VALUEON "Bekapcsolva" VALUEOFF "Kikapcsolva"
   END POLICY

vagy

KEYNAME ....
   POLICY !!Házirend
   VALUENAME MódosítaniKívántÉrték
   VALUEON 5 VALUEOFF 10
   END POLICY

Egyszerű házirendek, és a VALUEOFF/VALUEON utasításokkal ellátott házirendek használata

Ez a szakasz két olyan példát mutat be, mely az alapértelmezett házirendállapotok és a VALUEON/VALUOFF utasításokkal ellátott házirendek közötti különbséget szemlélteti.

1. példa

Ebben a példában nincsenek VALUEON / VALUEOFF utasítások. Ez azt jelenti, hogy a Felügyeleti sablonok az alapértelmezett viselkedést használják, ha a felhasználó megváltoztatja e házirend állapotát.

POLICY !!EnableSlowLinkDetect
    EXPLAIN !!EnableSlowLinkDetect_Help
    KEYNAME "Software\Policies\Microsoft\Windows\System"
    VALUENAME "SlowLinkDetectEnabled"
END POLICY

Az alábbi táblázat felsorolja az alapértelmezett viselkedéseket.

Állapot | Viselkedés
Engedélyezett házirend-beállítás | A rendszer DWORD típusú bejegyzést ír a rendszerleíró adatbázisba, 1 értékkel.
Letiltott házirend-beállítás | A rendszerleíróadatbázis-értéket törli.
Nem konfigurált házirend-beállítás | Nem történik módosítás a rendszerleíró adatbázisban.

Fontos kitérni a házirend Letiltva állapotára Az érték nem kerül a rendszerleíró adatbázisba 0 értékkel, hanem törölve lett. Ez azt jelenti, hogy a rendszerleíró adatbázist olvasó összetevő nem fogja azt megtalálni a rendszerleíró adatbázisban, így az alapértelmezett értéket használja. Lényegében így, ha a házirend letiltott állapotban van, akkor az pontosan ugyanaz, mintha az inaktív állapotban lenne.

2. példa
Ebben a példában a felhasználó konkrétan megadta az állapotértékeket, így a Felügyeleti sablonok ezeket az értékeket fogják használni, ha a felhasználó a házirendet módosítja.

POLICY !!EnableSlowLinkDetect
    EXPLAIN !!EnableSlowLinkDetect_Help
    KEYNAME "Software\Policies\Microsoft\Windows\System"
    VALUENAME "SlowLinkDetectEnabled"
        VALUEON NUMERIC 1
        VALUEOFF NUMERIC 0
END POLICY

Az alábbi táblázat bemutatja az utóbbi példában megadott viselkedéseket.

Állapot | Viselkedés
Engedélyezett házirend-beállítás | A rendszer DWORD típusú bejegyzést ír a rendszerleíró adatbázisba, 1 értékkel.
Letiltott házirend-beállítás | A rendszer DWORD típusú bejegyzést ír a rendszerleíró adatbázisba, 0 értékkel.
Nem konfigurált házirend-beállítás | Nem történik módosítás a rendszerleíró adatbázisban.


PART

A PART bejegyzés használható különböző beállítások, többek között legördülő listák, beviteli mezők és a Csoportházirend beépülő modul alsó ablakában megjelenő szöveg megadására.

A PART szintaxisa a következő:

PART [!!]név  rész_típusa
  típusfüggő adat
  [KEYNAME Kulcsnév ]
  VALUENAME Értéknév
END PART

ahol:

a név a rész neve úgy, ahogy az a Csoportházirend listában megjelenik. A szóközökkel ellátott neveket idézőjelek közé kell tenni. A felhasználói felületen látható szöveges karakterlánchoz a [STRINGS] !! változót kell használnia.

A rész_típusa a házirendrész jelzője. A jelzőket egyenként tárgyalja a PartTypes témakör.

A típusfüggő adatok a házirendrésszel kapcsolatos adatok. A típusfüggő adatokat a következő témakör tárgyalja.

A Kulcsnév a használathoz választható kulcsnév. Ha nincs megadva kulcsnév, a rendszer a hierarchiában lévő előző kulcsnevet használja.

Az Értéknév az ehhez a házirendrészhez használatra megadható értéknév.

Példa a PART bejegyzés használatára:

PART !!Változó	JELZŐ(k)  {egy vagy több, később definiálva}
...
    END PART

vagy

PART !!Változó	JELZŐ(k)		END PART

A PART bejegyzés érvényes kulcsszavai a következők:

  • CHECKBOX
  • TEXT
  • EDITTEXT
  • NUMERIC
  • COMBOBOX
  • DROPDOWNLIST
  • LISTBOX
  • END
  • CLIENTEXT
  • PART


PartTypes

Az alapszintű ADM nyelv lehetővé teszi egy egyszerű .adm fájl létrehozását, amely létrehoz egy REG_DWORD típusú VALUENAME bejegyzést 1 értékkel, vagy az értéket teljes mértékben eltávolítja. Az alábbi módosítók segítségével további beállítások használhatók.

TEXT

Egysornyi statikus (felirat) szöveget jelenít meg. Nincs létező rendszerleíró érték erre a házirendrész típusra. A TEXT résztípus nem fogad el típusspecifikus adatokat. Ez egy leírás megjelenítésénél hasznos.

A TEXT módosítóhoz csak az END kulcsszó érvényes.

EDITTEXT

Megjelenít egy olyan szerkesztőmezőt, amely alfanumerikus szövegeket fogad el. A szöveg a rendszerleíró adatbázisba kerül, REG_SZ típussal. A EDITTEXT házirendrész típus a következő beállításokat fogadja el:

  • DEFAULT érték. Megadja a kezdeti karakterláncot a szerkesztőmezőben. Ha ez a beállítás nincs megadva, a mező kezdéskor üres lesz.
  • MAXLEN érték. Megadja a karakterlánc maximális hosszát. A szerkesztőmezőben lévő karakterlánc erre a maximális hosszra lesz korlátozva.
  • REQUIRED. Megadja, hogy a csoportházirend nem teszi lehetővé ilyen házirendrészt tartalmazó házirend engedélyezését, hacsak nincs megadva egy érték erre a részre vonatkozóan.
  • OEMCONVERT. Beállítja az ES_OEMCONVERT stílust a szerkesztőmezőben, így a beírt szöveget ANSI karakterkészletről OEM karakterkészletre, illetve OEM-ről ANSI-ra konvertálja. Az ES_OEMCONVERT stílus konvertálja a szerkesztőben megadott szöveget. A rendszer a szöveget a Windows karakterkészletéről (ASCII) OEM karakterkészletre konvertálja, majd vissza a Windows karakterkészletre. Ez biztosítja a megfelelő karakterkonvertálást a szerkesztőben lévő ASCII karakterlánc OEM karakterkészletre való konvertálásához, amikor egy alkalmazás a CharToOem <JavaScript:hhobj_1.Click()> függvényt meghívja. Ez a stílus főleg a fájlneveket tartalmazó szerkesztő vezérlők számára hasznos.

Az EDITTEXT módosító érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUENAME
  • DEFAULT
  • REQUIRED
  • MAXLENGTH
  • OEMCONVERT
  • END
  • EXPANDABLETEXT
  • CLIENTEXT

COMBOBOX

Megjelenít egy kombinált listát. A COMBOBOX házirendrész típus elfogadja ugyanazt beállítás, amit az EDITTEXT elfogad, valamint az alábbi beállítást:

SUGGESTIONS. Indítja a legördülő menübe helyezendő javaslati listát. Szóközök választják el a SUGGESTIONS kulcsszavakat, melyeket idézőjelekbe kell tenni a szóközöket tartalmazó értékek esetén. A felsorolás az END SUGGESTIONS kulcsszóval fejeződik be.

Például:

SUGGESTIONS
  Alaszka Alabama Mississippi "New York"
END SUGGESTIONS

CHECKBOX

Egy jelölőnégyzetet jelenít meg. A szöveg a rendszerleíró adatbázisba kerül, REG_DWORD típussal. Az érték nullától eltérő lesz, ha a jelölőnégyzet be van jelölve; ha nincs bejelölve, akkor nulla. A CHECKBOX házirendrész típus a következő beállításokat fogadja el:

  • ACTIONLISTOFF. Megad egy műveleti listát, mely a jelölőnégyzet nem jelölt állapotában használatos.
  • ACTIONLISTON. Megad egy műveleti listát, mely a jelölőnégyzet jelölt állapotában használatos.
  • DEFCHECKED. A kulcsszó használatával a jelölőnégyzet kezdeti állapotban be lesz jelölve.
  • VALUEOFF. A kulcsszó megadásakor a rendszer felülbírálja a jelölőnégyzet alapértelmezett “ki” viselkedést.
  • VALUEON. A kulcsszó megadásakor a rendszer felülbírálja a jelölőnégyzet alapértelmezett “be” viselkedését.

Ha a jelölőnégyzet be van jelölve, az alapértelmezett viselkedés szerint 1-et ír a rendszerleíró adatbázisba, ha nincs bejelölve, 0-t. A VALUEON és a VALUEOFF kulcsszavak használatosak e viselkedés felülbírálásához. Például az alábbi beállítás a "Fred" szöveget írja a rendszerleíró adatbázisba a jelölőnégyzet bejelölésekor.

VALUEON "Fred"

Az alábbi beállítás 12-t ír a rendszerleíró adatbázisba a jelölőnégyzet bejelölésének törlésekor.

VALUEOFF NUMERIC 12

A CHECKBOX módosító érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUENAME
  • VALUEON
  • VALUEOFF
  • ACTIONLISTON
  • ACTIONLISTOFF
  • DEFCHECKED
  • CLIENTEXT
  • END

DROPDOWNLIST

Megjelenít egy kombinált listát, legördülő menü stílusban. A felhasználó csak a rendelkezésre bocsátott bejegyzésekből választhat. A legördülő menü stílusú kombinált lista fő előnye, hogy a felhasználó számos további rendszerleíróadatbázis-szerkesztést jelölhet ki. A DROPDOWNLIST házirendrész típus az ITEMLIST és a REQUIRED beállításokat fogadja el.

  • ITEMLIST. Indítja a legördülő menüben lévő elemek listáját. A felsorolást az END ITEMLIST kulcsszóval kell bejezni.

    • Az ITEMLIST beállításban lévő egyes elemeket az alábbi módon kell megadni:

    NAME név VALUE érték
    [ACTIONLIST műveleti_lista]
    ...

    ahol:

    a név a legördülő menüben megjelenítendő szöveg az elemhez.

    Az érték az elem kijelölésekor a házirendrész értékeként írásra kerülő számot jelenti. A rendszer az értékeket karakterláncoknak feltételezi, kivéve ha azt a NUMERIC kulcsszó előzi meg. A következő példa mind a karakterláncot, mind a numerikus értékeket szemlélteti.

    VALUE "egy bizonyos érték"
    VALUE NUMERIC 1

    Ha a VALUE kulcsszót a DELETE kulcsszó követi (például VALUE DELETE), a rendszer törli a rendszerleíró adatbázisbeli név-érték párt.

    A műveleti_lista az a választható műveleti lista, amely használatra kerül az érték kiválasztásakor.

  • A REQUIRED kulcsszó megadja, hogy a Csoportházirend nem teszi lehetővé ilyen házirendrészt tartalmazó házirend engedélyezését, hacsak nincs megadva egy érték a részre vonatkozóan.

A DROPDOWNLIST összetevő érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUENAME
  • REQUIRED
  • ITEMLIST
  • END
  • NOSORT
  • CLIENTEXT

LISTBOX

Megjelenít egy listát Hozzáadás és Eltávolítás gombokkal ellátva. Ez az egyetlen házirendrész típus, amely több értékekre használható egy kulcs alatt. A VALUENAME beállítás nem használható a LISTBOX házirendrész típussal, mivel nincs ezzel a típussal társított egyedi értéknév. Alapértelmezés szerint csak egy oszlop jelenik meg a listában, és a rendszer az egyes bejegyzésekhez létrehoz egy értéket, melynek név és érték eleme megegyezik. Például a listában a "Fred" bejegyzés egy olyan fred nevű értéket hozna létre, melyhez kapcsolódó adat tartalma is "fred" lenne.

A LISTBOX házirendrész típus a következő beállításokat fogadja el:

  • ADDITIVE. Alapértelmezés szerint a listák tartalma a cél rendszerleíró adatbázisban lévő minden értéket felülír. Ez azt jelenti, hogy a vezérlő értékét a rendszer beszúrja a házirendfájlba, mely a meglévő értékek törlését eredményezi a házirendfájlban történő az értékek egyesítése előtt. A beállítás megadása esetén a rendszer nem törli a meglévő értékeket, és a listában megadott értékeket a cél rendszerleíró adatbázisbeli értékekhez hozzáadja.
  • EXPLICITVALUE. Ez a beállítás lehetővé teszi a felhasználó számára, hogy megadja az értékhez kapcsolódó adatot és nevet. A lista két oszlopot jelenít meg, egyet a nevekhez, egyet pedig az adatokhoz. Ne feledje, hogy ez a beállítás nem használható a VALUEPREFIX beállítással együtt.
  • VALUEPREFIX előtag. A megadott előtag az értéknevek meghatározásához használatos. Ha egy előtagot tartalmaz a fájl, akkor az előtag, valamint egy megnövelt egész szám használatos az előzőekben leírt alapértelmezett elnevezési séma helyett. Például a "Név" előtag megadása a következő értékneveket állítja elő: names Név1, Név2 stb. Az előtag üres is lehet (""), így az értéknevek a következők lesznek: 1, 2 stb.

Az LISTBOX összetevő érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUEPREFIX
  • ADDITIVE
  • NOSORT
  • EXPLICITVALUE
  • EXPANDABLETEXT
  • END
  • CLIENTEXT


NUMERIC

Megjelenít egy üres mezőt választható léptetőnyíllal együtt (egy fel-le vezérlő), amely numerikus értékeket fogad el. A szöveg a rendszerleíró adatbázisba kerül, REG_DWORD típussal.

A NUMERIC házirendrész típus a következő beállításokat fogadja el:

  • DEFAULT érték. Megadja a kezdeti numerikus értéket a szerkesztési mező számára. Ha ez a beállítás nincs megadva, a mező kezdéskor üres lesz.
  • MAX érték. Megadja a szám maximális értékét. Az alapértelmezett érték 9999.
  • MIN érték. Megadja a szám minimális értékét. Az alapértelmezett érték 0.
  • REQUIRED. Megadja, hogy a csoportházirend nem teszi lehetővé ilyen házirendrészt tartalmazó házirend engedélyezését, hacsak nincs megadva egy érték erre a részre vonatkozóan.
  • SPIN érték. Megadja a léptetőnyíl növekményeit.
  • A SPIN 0 beállítás törli a léptetőnyíl elemet. Az alapértelmezett beállítás a SPIN 1.
  • A TXTCONVERT kulcsszó REG_SZ beállítás szerinti karakterláncokat ír ("1," "2," vagy "128"), nem pedig bináris értékeket.

Például:

PART !!Változó	NUMERIC
VALUENAME MódosítaniKívántÉrték
END PART

Az NUMERIC összetevő érvényes kulcsszavai a következők:

  • KEYNAME
  • VALUENAME
  • MIN
  • MAX
  • SPIN
  • DEFAULT
  • REQUIRED
  • TXTCONVERT
  • END
  • CLIENTEXT

TEXT

Csak szöveget jelenít meg.

Például:

PART !!Változó	TEXT
END PART

NUMERIC

A rendszerleíró adatbázisba egy értéket ír be REG_DWORD adattípussal. Ez az alapértelmezés szerinti, kivéve ha más típust választ ki.

Például:

PART !!Változó	NUMERIC
VALUENAME MódosítaniKívántÉrték
END PART

EXPANDABLETEXT

A rendszerleíró adatbázisba egy értéket ír be REG_EXPAND_SZ adattípussal.

Például:

PART !!Változó	EDITTEXT EXPANDABLETEXT
VALUENAME MódosítaniKívántÉrték
END PART

EDITTEXT

A rendszerleíró adatbázisba egy értéket ír be REG_SZ adattípussal.

Például:

PART !!Változó	EDITTEXT
VALUENAME MódosítaniKívántÉrték
END PART

REQUIRED

Hibát vált ki, ha a felhasználó nem ad meg értéket.

Például:

PART !!Változó	EDITTEXT REQUIRED
VALUENAME MódosítaniKívántÉrték
END PART

MAXLEN

A szöveg maximális hosszát adja meg.

Például:

PART !!Változó	EDITTEXT
VALUENAME MódosítaniKívántÉrték
MAXLEN 4
END PART

DEFAULT

Egy alapértelmezett értéket ad meg. Ez szöveghez vagy numerikus adatokhoz is használható.

Például:

PART !!Változó	EDITTEXT
DEFAULT !!SzövegMinta
VALUENAME MódosítaniKívántÉrték
END PART

vagy

PART !!Változó	NUMERIC
DEFAULT 5
VALUENAME MódosítaniKívántÉrték
END PART

MIN/MAX

A legkisebb és legnagyobb érvényes értéket adja meg.

Például:

PART !!Változó	NUMERIC
MIN 100 MAX 999 DEFAULT 55
VALUENAME MódosítaniKívántÉrték
END PART

DROPDOWNLIST

Választható beállításokat tartalmazó listát jelenít meg.

Például:

PART !!Változó 	DROPDOWNLIST
VALUENAME MódosítaniKívántÉrték
  ITEMLIST
    NAME "Első"	VALUE NUMERIC 1
    NAME "Második" VALUE NUMERIC 2
    NAME "Harmadik"	VALUE NUMERIC 3
    NAME "Negyedik" 	VALUE NUMERIC 4
  END ITEMLIST
END PART

ACTIONLIST

Választható műveleti lista, amely ezen érték kiválasztásakor használatos.

Az ACTIONLIST kulcsszó csak egy ITEMLIST kulcsszó részeként használható. Tanulmányozza az ITEMLIST szakaszban leírt példát.

Az ACTIONLIST kulcsszónak két változata létezik (ACTIONLISTON és ACTIONLISTOFF), melyeket a POLICY és a CHECKBOX kódokkal kell használni. Tanulmányozza az CHECKBOX szakaszban leírt példát.


EXPLAIN

Az EXPLAIN kulcsszó súgószövegek biztosítására használható.

Az egyes házirendeknek egy EXPLAIN kulcsszóra van szükségük, melyet legalább egy szóköznek kell követnie, utána pedig vagy az idézőjelben lévő magyarázó karakterlánc, vagy a magyarázó karakterláncra való hivatkozás következik.

Például:

POLICY !!NetCache KEYNAME Software\Policies\Microsoft\Windows\NetCache #if VERSION >= 3 HELP !!IntelliMirrorExplain #endif ..... [Strings] IntelliMirrorHelp="Magyarázat a Windows 2000 IntelliMirror programhoz\n\n Ezt a házirendet a fájlrendszer gyorsítótár-beállításainak konfigurálásához használhatja."

Az \n\n elem egy sort emel a megjelenített szövegben.

A példában a Kapcsolat nélküli fájlok egy beállításához biztosítottunk magyarázatot. Az alábbi karakterlánc azt jelenti, hogy ez a Windows 2000 (3-as verzió) vagy újabb Windows verziókkal is használható:

#if VERSION >= 3


Ismerős feladatok elvégzésének új lehetőségei

A Windows NT 4.0 vezette be a Rendszerházirend-szerkesztőt, melynek segítségével a felhasználói munkakörnyezet és tevékenységek szabályozására rendszerházirend hozható létre, továbbá a rendszerkonfigurációs beállítások kényszeríthetők a Windows NT 4.0 rendszert használó minden számítógépre. A házirendek a munkakörnyezet különböző összetevőit határozzák meg, többek között a felhasználók számára rendelkezésre álló, a felhasználó Asztalán megjelenő alkalmazásokat, valamint a Start menüben lévő ikonokat.

A Windows NT 4.0 rendszerről Windows 2000 operációs rendszerre frissítő felhasználók tapasztalják, hogy a Csoportházirend és annak bővítményei számos ismert eszközt pótolnak, egységesebben használható módon.

Teendő: Windows NT 4.0 esetén ezt használja: Windows 2000 esetén ezt használja:
Házirendek megadása egy hely felhasználói és számítógépei számára Nem alkalmazható A csoportházirend az
Active Directory - helyek és szolgáltatások segédprogram révén érhető el.
Házirendek megadása egy tartomány felhasználói és számítógépei számára Rendszerházirend-szerkesztő (poledit.exe) A csoportházirend az
Active Directory - felhasználók és számítógépek segédprogram révén érhető el.
Házirendek megadása egy szervezeti egység felhasználói és számítógépei számára Nem alkalmazható A csoportházirend az
Active Directory - felhasználók és számítógépek segédprogram révén érhető el.
A biztonsági csoportok használata a házirendek hatókörének szűrésére Nem alkalmazható Adja meg a Csoportházirend alkalmazása engedélybejegyzést a csoportházirend-objektum tulajdonságlapján szereplő Biztonság lapon.
Szoftverkezelés Rendszergazda számára a Systems Management Server segítségével. Felhasználó számára a Vezérlőpult Programok telepítése/törlése segédprogram segítségével. A Systems Management Server és a három Szoftverek telepítése és karbantartása eszköz:
  • Szoftvertelepítés — a Csoportházirend beépülő modul bővítménye
  • Windows Installer
  • A Vezérlőpult Programok telepítése/törlése segédprogramja
Biztonságosabb felhasználó felületet hoz létre a rendszerleíró adatbázis szerkesztéséhez A Rendszerházirend-szerkesztő Windows NT 4.0 stílusú Felügyeleti sablonjai A csoportházirend Windows 2000 stílusú Felügyeleti sablonjai

Az .adm fájlok Windows 2000-ben történő használatával kapcsolatosan tanulmányozza A Felügyeleti sablonok szerepe témakört.
Általános felügyeleti feladatok elvégzése Felügyeleti varázslók, Felhasználókezelő és Kiszolgálókezelő Microsoft Management Console (MMC) beépülő modul, főleg az
Active Directory - felhasználók és számítógépek,
Active Directory - helyek és szolgáltatások,
valamint a Csoportházirend beépülő modul és annak bővítményei.


Hibaelhárítás

A Csoportházirend beépülő modullal kapcsolatos hibaelhárítás során fontos, hogy vegye figyelembe az összetevők közötti függőségeket. A Szoftvertelepítés beépülő modul például függ a csoportházirendtől, a Csoportházirend beépülő modul pedig az Active Directorytól. Az Active Directory a hálózati szolgáltatások megfelelő konfigurálásán alapul. Egy összetevővel kapcsolatos hibák javításánál általában segítséget nyújt, ha leellenőrzi az adott összetevőtől függő más összetevők, szolgáltatások és erőforrások működését. Az eseménynaplók az ilyen, hierarchikus függőség által okozott problémák azonosításához hasznosak.

Problémák merülnek fel a Csoportházirend beépülő modul használata során?

Egy csoportházirend-objektumot nem tudok a konzolon megnyitni, még akkor sem, ha ahhoz Olvasás joggal rendelkezem.

Ok: Egy rendszergazdának a csoportházirend-objektumhoz nemcsak Olvasás, hanem Teljes hozzáférés joggal kell rendelkeznie a csoportházirend konzolban való megnyitáshoz.

Megoldás: Fel kell vennie magát tagnak a biztonsági csoportba a csoportházirend-objektumra vonatkozó Teljes hozzáféréssel. Például egy tartományi rendszergazda az Active Directory alapú csoportházirendet kezelheti. Egy számítógép rendszergazdája szerkesztheti a számítógép helyi csoportházirend-objektumát.

Csoportházirend-objektum szerkesztésekor a „Nem lehetett megnyitni a csoportházirend-objektumot” hibaüzenet jelenik meg.

Ok: Ezt általában egy hálózati probléma okozza, főleg a tartománynév-rendszer (DNS) konfigurációjával kapcsolatos problémák.

Megoldás: Győződjön meg arról, hogy a tartománynév-rendszer (DNS) működése megfelelő. További tudnivalókért tanulmányozza a Tartománynév-rendszer (DNS) témakört.

Nincsenek hatással a rendszerre a csoportházirend-beállítások?

A rendszer még akkor sem alkalmazza a csoportházirendet a biztonsági csoport felhasználóira és számítógépeire, ha a csoportházirend-objektum a biztonsági csoportot tartalmazó szervezeti egységhez van csatolva.

Ok: Ez a normál működés. A csoportházirend csak a helyen, tartományban és szervezeti egységben található felhasználókra és számítógépekre érvényes. Csoportházirend-objektumok nem alkalmazhatók biztonsági csoportokra.

Megoldás: Csoportházirend-objektumokat csak helyekhez, tartományokhoz és szervezeti egységekhez csatoljon. Ne feledje, hogy az Active Directoryban egy biztonsági csoport helye nem függ attól, hogy a biztonsági csoportban a csoportházirend érvényben van-e a felhasználókra és a számítógépekre.

A csoportházirend nem befolyásolja ez egy helyen, tartományban vagy szervezeti egységben lévő felhasználókat vagy számítógépeket.

Ok: Többféle módon megakadályozható a felhasználókra vagy a számítógépekre a csoportházirend-beállítások szándékos vagy véletlenül történő alkalmazása. A csoportházirend-objektum felhasználókra, számítógépekre, illetve mindkettőre történő alkalmazása letiltható. Továbbá szükség van arra, hogy a csoportházirend-objektum csatolva legyen vagy közvetlenül egy a felhasználókat és a számítógépeket tartalmazó szervezeti egységhez, vagy egy szülőtartományhoz vagy szervezeti egységhez, hogy a rendszer a csoportházirend beállításokat öröklődés útján alkalmazni tudja.

Több csoportházirend-objektum érvényessége esetén azok feldolgozása a következő sorrendben történik: számítógép, hely, tartomány, szervezeti egység. Alapértelmezés szerint az utoljára alkalmazott beállítások elsőbbségi joggal rendelkeznek. Ezen felül a csoportházirend blokkolható bármely szervezeti egység szintjén, illetve a csoportházirend a Nincs felülbírálás beállításnak egy bizonyos csoportházirend-objektum hivatkozásra történő alkalmazásával kikényszeríthető.

Végül a felhasználónak vagy a számítógépnek a megfelelő engedélyekkel beállított egy vagy több biztonsági csoporthoz kell tartoznia.

Megoldás: Gondoskodjon arról, hogy az alkalmazni kívánt házirend ne legyen blokkolva.

Gondoskodjon arról, hogy magasabb Active Directory hierarchia szinten ne legyen a felülbírálási házirend a Nincs felülbírálás beállításra megadva.

Amennyiben mind a Blokkolás, mind a Nincs felülbírálás beállítások ki vannak választva, ne feledje, hogy a Nincs felülbírálás beállítás elsőbbségi joggal rendelkezik.

Ellenőrizze, hogy a felhasználó vagy a számítógép nem tagja-e valamelyik biztonsági csoportnak, melynek Csoportházirend alkalmazás Hozzáférés-vezérlés bejegyzése (ACE) Megtagadva beállításra van állítva.

Ellenőrizze, hogy a felhasználó vagy a számítógép tagja-e legalább egy biztonsági csoportnak, melynek Csoportházirend alkalmazás Hozzáférés-vezérlés bejegyzése (ACE) Megtagadva beállításra van állítva.

Ellenőrizze, hogy a felhasználó vagy a számítógép tagja-e legalább egy biztonsági csoportnak, melynek ACE olvasási beállítása Engedélyezve beállításra van állítva.

A csoportházirend nincs hatással az Active Directory tárolóban lévő felhasználókra és a számítógépekre.

Ok: A csoportházirend-objektumok nem csatolhatók Active Directory tárolókhoz csak helyhez, tartományhoz és szervezeti egységhez.

Megoldás: Csatolja a csoportházirend-objektumot egy olyan szervezeti egységhez, amely az Active Directory tárolónak egy szülőobjektuma. Így öröklődés útján alapértelmezés szerint ezek a beállítások lesznek érvényben a tárolóban lévő felhasználókra és számítógépekre.

A csoportházirendnek nincs hatása a helyi számítógépre.

Ok: A helyi házirendek rendelkeznek a legkisebb prioritással. Azokat bármely Active Directory alapú házirend felbírálhatja.

Megoldás: Ellenőrizze, hogy melyek az Active Directory révén érvényes csoportházirend-objektumok, és e csoportházirend-objektumok beállításai nem ütköznek-e a helyi beállításokkal.

Problémák merülnek fel a Szoftvertelepítés beépülő modul használata során?

A közzétett alkalmazások nem jelennek meg a Vezérlőpult Programok telepítése/törlése paneljén.

Ok: Ennek a problémának számos oka lehet:

  • A rendszer nem alkalmazta a csoportházirendet.
  • Az Active Directory nem érhető el.
  • A csoportházirend-objektumban a felhasználóra nincs érvényben egyetlen közzétett alkalmazás sem.
  • Az ügyfél terminálkiszolgálót futtat.

Megoldás: Vizsgálja meg sorjában az egyes lehetőségeket. Ne feledje, hogy a rendszer nem támogatja a Szoftvertelepítés beépülő modul használatát a terminálkiszolgáló ügyfelek számára.

A közzétett alkalmazásokhoz társított dokumentumok megnyitásával a rendszer nem telepíti az alkalmazást.

Ok: A rendszergazda nem adta meg az automatikus telepítés beállítást.

Megoldás: Tanulmányozza az Alkalmazások automatikus telepítésének beállítása témakört.

A felhasználó „A telepíteni próbált jellemző nem található a forráskönyvtárban” hibaüzenetet kapja.

Ok: Ezt hálózattal vagy engedélyekkel kapcsolatos problémák okozhatják.

Megoldás: Győződjön meg a hálózat megfelelő működéséről. További tudnivalókért tanulmányozza az Engedélyek megadása szoftvertelepítéséhez témakört, különösképp a lap alján szereplő második megjegyzést.

Egy alkalmazás eltávolítását követően az alkalmazás parancsikonjai még mindig megmaradnak a felhasználó Asztalán.

Ok: A Windows Installer segédprogram nem tud a felhasználó által létrehozott parancsikonokról.

Megoldás: A felhasználónak kell kézzel eltávolítania a parancsikonokat.

A felhasználó „Egy másik telepítés folyamatban van” hibaüzenetet kap.

Ok: A rendszergazda a felhasználó által nem látható módon végez programeltávolítást, vagy elképzelhető, hogy a felhasználó egy időben véletlenül két telepítést indított el (ezt a rendszer nem támogatja).

Megoldás: Később a művelet elvégezhető.

A felhasználó megnyit egy már telepített alkalmazást, és a Windows Installer elindul.

Ok: Elképzelhető, hogy a rendszer az alkalmazás automatikus javítását végzi, vagy a felhasználó számára szükséges funkció hozzáadása történik.

Megoldás: Nincsen tennivaló.

A felhasználó ilyen hibaüzenteket kap: „Az Active Directory nem teszi lehetővé a csomag központi telepítését” vagy a „A csomag nem készíthető elő központi telepítésre”.

Ok: Elképzelhető, hogy a csomag sérült, vagy hálózati probléma merülhetett fel.

Megoldás: Vizsgálja meg a problémát, majd tegye meg a megoldásához szükséges lépéseket.

Megjegyzés

  • A hibaelhárítással kapcsolatos legfrissebb tudnivalókért látogassa meg az Interneten a következő webcímet: Microsoft személyes tanácsadó szolgálat webhely (http://www.microsoft.com/).


Parancsfájlok

A parancsfájlok központi telepítéséhez a Csoportházirend beépülő modul két bővítmény tartalmaz:

  • Parancsfájlok – indítás/leállítás. Használja a Számítógép konfigurációja csomópont alatti bővítményt a számítógép indításakor és leállításakor futtatni kívánt parancsfájlok megadására. Ezen parancsfájlok futtatása a Helyi rendszerfiók fiók jogaival történik.
  • Parancsfájlok – bejelentkezés/kijelentkezés. Használja a Felhasználó konfigurációja csomópont alatti bővítményt a felhasználó bejelentkezésekor és kijelentkezésekor futtatni kívánt parancsfájlok megadására. Ezen parancsfájlok futtatása Felhasználó, nem pedig Rendszergazda fiók jogaival történik.

A Windows 2000 rendszer a Windows Script Host programot is tartalmazza, amely a 32 bites Windows platformok nyelvtől független parancsfájlfuttatója. Ez magában foglalja a Visual Basic Scripting Edition (VBScript) és a JScript parancsfájlfuttatókat. A .vsb és a .js parancsfájlok futtatáshoz a Windows Script Host a Windows Asztalon vagy parancssorból használható, így nem szükséges a parancsfájlok HTML dokumentumba való beágyazása.

A Windows Script Host programmal kapcsolatos további tudnivalókért tanulmányozza a Windows Script Host – áttekintés témakört. A Windows Script Host, és az Object Model programokkal, valamint a parancsfájlminták beszerzésével kapcsolatos további tudnivalókért látogassa meg a következő webhelyet: Microsoft webhely (http://www.microsoft.com/).

Kapcsolódó témakörök


Parancsfájlok használata

  • Parancsfájlok beállítása a tartományvezérlőn
  • Számítógépindítási parancsfájlok hozzárendelése
  • Számítógépleállítási parancsfájlok hozzárendelése
  • Bejelentkezési parancsfájlok hozzárendelése
  • Kijelentkezési parancsfájlok hozzárendelése


Biztonsági beállítások

A Csoportházirendben két Biztonsági beállítások csomópont található. A \Számítógép konfigurációja\Windows beállításai\Biztonsági beállítások csomópont a számítógépre bejelentkező bármely felhasználóra érvényes biztonsági beállításokra vonatkozik. Ebből a csomópontból két alcsomópont nyílik: Az Active Directory IP-biztonsági házirendje, és a Nyilvános kulcs házirendje csomópont.

A \Felhasználó konfigurációja\Windows beállításai\Biztonsági beállítások csomópont bármely számítógépre bejelentkező felhasználóra érvényes biztonsági beállításokra vonatkozik. Ez a csomópont egy Nyilvános kulcs házirendje alcsomóponttal rendelkezik.

E csomópontok használatával kapcsolatos további tudnivalókért tanulmányozza a Biztonsági beállítások témakört.


Csoportházirend egyéb házirendjeinek beállítása

  1. Nyissa meg a Csoportházirend beépülő modult a System.adm fájl telepítése után. (Mivel a rendszer a System.adm fájlt alapértelmezés szerint telepítette, általában semmit nem kell tennie.)
  2. Ha egy felhasználói házirendet kíván szerkeszteni, kattintson konzolfán a Csoportházirend csomópont felhasználó házirendek elemére.

    3. Helye:

    • házirendnév házirend
    • Felhasználó konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend
  3. Ha egy számítógép házirendet kíván szerkeszteni, kattintson konzolfán a Csoportházirend csomópont számítógép-házirendek elemére.

    4. Helye:

    • házirendnév házirend
    • Számítógép konfigurációja
    • Felügyeleti sablonok
    • Rendszer
    • Csoportházirend
  4. Kattintson duplán a megadni kívánt házirend ikonjára.
  5. A Házirend lapon végezze el a kívánt beállításokat, majd kattintson az OK gombra.

Megjegyzések

  • A Csoportházirend beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.
  • Ha az .adm kiterjesztésű fájl szerzője ellátta a házirendet leírással, a csoportházirendben lévő házirendek leírását a Magyarázat lapon találhatja meg A házirendek leírásával kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csoportházirend különböző helyeken

Az Active Directory helyein lévő objektumokra alkalmazott csoportházirend-objektumok a helyen lévő minden számítógépre érvényesek. A rendszer replikálja és elérhetővé teszi a könyvtáradatokat a helyen lévő tartományvezérlők között, továbbá a helyhivatkozással ellátott bármely tartományvezérlő számára. Ezáltal a helyhez csatolt bármely csoportházirend-objektum hatással van a hely minden számítógépére a számítógépet tartalmazó (az erdőben lévő) tartománytól függetlenül.

Ez lehetővé teszi az egy erdőben lévő tartományok számára, hogy egyidejűleg megkapják ugyanazt a csoportházirend-objektumot (és azok házirendjeit), ellenben a csoportházirend-objektum csak egy tárolt egyedként létezik egyetlen tartományon, így az érintett ügyfeleknek a házirendeket arról a tartományról kell olvasni a helyhivatkozással ellátott csoportházirend olvasásakor.

Amennyiben a gyermektartományok nagy kiterjedésű hálózatok (WAN) közötti használatra lettek beállítva, a hely beállításainak ezt figyelembe kell vennie. Ha a beállítások ezt nem veszik figyelembe, a gyermektartomány számítógépei a nagy kiterjedésű hálózaton (WAN) keresztül érik el a helyhivatkozással ellátott csoportházirend-objektumokat. Ez megnöveli a csoportházirend feldolgozási idejét.


Csoportházirend használata lassú kapcsolaton keresztül

Ha a számítógép az Útválasztás és távelérés kiszolgáló tartományának tagja, vagy a kiszolgáló meghatalmazott tartományának tagja, a csoportházirend a számítógépre távolról érvényesül. Ez így van, ha a rendszerbe az Útválasztás és távelérés kiszolgáló segítségével jelentkezik be és akkor is, ha a számítógépre gyorsítótárban tárolt hitelesítő adatokkal jelentkezik be az útválasztás és távelérés kapcsolat létrehozása előtt.

A csoportházirend nem érvényes olyan számítógépekre, melyek egy idegen tartomány (a számítógépet nem tartalmazó, és a számítógép tartományával meghatalmazotti kapcsolatban álló tartomány) vagy munkacsoport tagjai. Bár lehetséges, hogy a kapcsolat még mindig létrejön, a tartományforrások elérését hátrányosan érinthetik a nem egyező IPSEC biztonsági szintek.

Alapértelmezés szerint a rendszerleíró adatbázison alapuló házirendek mindig érvényben vannak, és azok kikapcsolása nem lehetséges. Alapértelmezés szerint a biztonsági beállítások is érvényben vannak, de a többi beállítás nincs. A rendszerleíró adatbázis beállításainak kivételével az alapértelmezett érvényesítési viselkedés ki- és bekapcsolható.

A távelérési csatlakozás nem feltétlenül lassú kapcsolat, és a helyi hálózat (LAN) sem feltétlenül gyors. Alapértelmezés szerint a csatolás állapota a kiszolgáló ping programmal való tesztelésén alapul. Ha ez 2000 ezredmásodpercnél (két másodperc) kevesebb időt vesz igénybe, a kapcsolat gyors csatolású, ellenkező esetben lassú. Ez az érték beállítható a Felhasználói profilok hálózati kapcsolatának időtúllépése csoportházirend beállításainak megadásával.

Helye:

  • csoportházirend-objektum_neve
  • Számítógép konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Bejelentkezés

A lassú kapcsolatra vonatkozó számos egyéb csoportházirend-beállítás is megjelenik. Nézze meg a Lassú csoportházirend-kapcsolat felismerése csoportházirend-beállítást is.

Helye:

  • csoportházirend-objektum_neve
  • Számítógép konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Csoportházirend


Szoftverbeállítások

A Csoportházirendben két Szoftverbeállítások csomópont található.

A \Számítógép konfigurációja\Szoftverbeállítások\ csomópont a számítógépre bejelentkező bármely felhasználóra érvényes szoftverbeállításra vonatkozik. Ez a csomópont egy Szoftver telepítése alcsomóponttal, valamint valószínűleg további más alcsomópontokkal is rendelkezik, melyeket független szoftverforgalmazók helyeztek ide.

A \Felhasználó konfigurációja\Szoftverbeállítások csomópont bármely számítógépre bejelentkező felhasználóra érvényes szoftverbeállításokra vonatkozik. Ez a csomópont egy Szoftver telepítése alcsomóponttal, valamint valószínűleg további más alcsomópontokkal is rendelkezik, melyeket független szoftverforgalmazók helyeztek ide.

Lásd még:

  • Szoftvertelepítés
  • Felhasználó konfigurációja
  • Számítógép konfigurációja


A Szoftvertelepítés beépülő modul használata

  • A Szoftvertelepítés beépülő modul megnyitása
  • A Szoftvertelepítés beépülő modul beállításainak megadása
  • Műveletek alkalmazásokkal
  • Alkalmazások tulajdonságainak megadása
  • Csomagmódosítási műveletek


A helyi csoportházirend-objektum szerkesztése

  1. Nyissa meg a Csoportházirend beépülő modult.
  2. Végezze el a kívánt házirend-beállításokat a Csoportházirend konzolon.

Megjegyzések

  • A helyi Csoportházirend-objektum szerkesztése érdekében a csoportházirendet megnyithatja, ha a Start gombra, majd a Futtatás menüparancsra kattint, beírja a gpedit.msc fájlnevet, végül megnyomja az ENTER billentyűt.
  • A helyi csoportházirenddel kapcsolatos további tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Csoportházirend-objektumok tárolása

A Windows 2000 rendszert használó minden egyes számítógép egyetlen csoportházirend-objektummal rendelkezik. A rendszer ezt a következő helyen tárolja: %systemroot%System32\GroupPolicy.

A helyi csoportházirend-objektumoktól különböző csoportházirend-objektumok két külön helyen tárolt részből állnak: a csoportházirend-tároló és a csoportházirend-sablon. A rendszer a kis méretű és ritkán módosított adatokat a csoportházirend-sablonban tárolja, míg a nagy méretű és gyakran módosított adatokat a csoportházirend-tárolóban. A Csoportházirend beépülő modul felhasználói felülete együtt használja ezeket.

Csoportházirend-tároló

A csoportházirend-tároló egy címtárszolgáltatás objektum. Ez a tároló más altárolókat tartalmaz a számítógép és a felhasználó csoportházirend-adatainak tárolására. A csoportházirend-tároló az alábbi adatokat tárolja:

  • Verzióinformáció. Ez biztosítja, hogy az adatok kezelése a csoportházirend-sablon adataival szinkronizálva történjen.
  • Állapotjelző információ. Azt jelzi, hogy a csoportházirend-objektum a helyre, tartományra vagy szervezeti egységre engedélyezett vagy letiltott állapotban van-e.
  • Komponensek listája. Azt adja meg, hogy a Csoportházirend beépülő modul melyik bővítménye rendelkezik beállításokkal a csoportházirend-objektumban.

A csoportházirend-tároló a Csoportházirend beépülő modul két bővítményének, a Szoftver telepítése és a Mappa átirányítása beépülő modulnak az adatait tárolja.

Csoportházirend-sablon

A csoportházirend-sablon a tartományvezérlők mappája, mely a csoportházirend-objektum tárolási tartományához használatos. Egy általános csoportházirend-sablon mappáját az alábbi példa szemlélteti:

rendszergyökér\Sysvol\SYSVOL\Streetmarket.com\Policies\
{34975054-fd77-df75-54fe-074936850457}

A csoportházirend-sablon almappái

A csoportházirend-sablon mappája az alábbi almappákat tartalmazhatja, de nem korlátozódik csak ezekre a mappákra:

  • adm. A csoportházirend-sablon minden .adm fájlját tartalmazza.
  • Parancsfájlok. A csoportházirend-sablon minden parancsfájlját és kapcsolódó fájljait tartalmazza.
  • User. Tartalmazza a felhasználókra érvényes rendszerleíróadatbázis-beállításokat tartalmazó Registry.pol fájlt. Amikor egy felhasználó a számítógépre bejelentkezik, a rendszer letölti a Regisrty.pol fájlt, majd azt a rendszerleíró adatbázis HKEY_CURRENT_USER részére alkalmazza. A User mappa az alábbi almappákat tartalmazza:
  • User\Applications. Tartalmazza az operációs rendszeren alapuló telepítő szolgáltatás által használatos .ass kiterjesztésű fájlokat (alkalmazás közzétételi parancsfájljai). Ezek a fájlok a felhasználókra érvényesek.
  • Machine. Tartalmazza a számítógépekre érvényes rendszerleíró adatbázis beállításait tartalmazó Registry.pol fájlt. A számítógép indításakor a rendszer letölti a Registry.pol fájlt, majd alkalmazza azt a rendszerleíró adatbázis HKEY_LOCAL_MACHINE részére. A Machine mappa az alábbi almappákat tartalmazza:
  • Machine\Applications. Tartalmazza az operációs rendszeren alapuló telepítő szolgáltatás által használatos .ass kiterjesztésű fájlokat. Ezek a fájlok számítógépekre érvényesek.


Windows NT 4.0 Rendszerházirendek

Ha a Windows NT 4.0 rendszert használó ügyfélszámítógépet Windows 2000 kiszolgáló kezeli, és a rendszert a Windows 2000 operációs rendszerre frissíti, a frissítés után a számítógép csak a Számítógép konfigurációja csoportházirendet kapja meg, a Windows NT 4.0 Rendszerházirendet nem. Amennyiben a felhasználói fiók az Active Directoryban található, a bejelentkező felhasználóra a Felhasználó konfigurációja csoportházirend lesz érvényben. Ha a felhasználói fiókot a Windows NT 4.0 tartományvezérlő kezeli, akkor a felhasználó a Windows NT 4.0 felhasználói Rendszerházirendet kapja meg.

A Windows 2000 rendszerben található házirendek csak az alábbi négy fenntartott fa egyikében lévő rendszerleíró kulcsokat és értékeket állítják be:

  • HKEY_LOCAL_MACHINE\Software\Policies
  • HKEY_CURRENT_USER\Software\Policies
  • HKEY_LOCAL_MACHINE\Software\Microsoft\
    Windows\CurrentVersion\Policies
  • HKEY_CURRENT_USER\Software\Microsoft\
    Windows\CurrentVersion\Policies

Az első kettő az ajánlott terület. Mind a négy fa biztonságos, és azokat csak a rendszergazda módosíthatja, felhasználó nem.

Ha bármely okból a csoportházirend megváltozik, ezek a fák teljes mértékben törlődnek és a rendszer újraírja az új házirendeket.

A Windows NT 4.0 házirendek nincsenek tekintettel ezekre a speciális fákra, így a rendszerleíró adatbázis bármely részébe írhatnak. Ilyen házirend alkalmazásakor a házirend addig érvényben marad, míg az értékeinek visszavonása meg nem történik a Windows NT 4.0 stílusú házirend hatástalanításával vagy a rendszerleíró adatbázis átszerkesztése révén.

Vigyázat!

  • Hozzáadható egy Felügyeleti sablon (.adm fájl) ahhoz a csoportházirendhez, mely megadja a rendszerleíró adatbázis értékeit a Windows 2000 stílusú jóváhagyott csoportházirendfákon kívül, még akkor is, ha a Windows 2000 nem tartalmaz ilyen .adm fájlt. Ha a rendszergazda úgy dönt, hogy Windows NT 4.0 rendszerű .adm fájlt kíván telepíteni, nem szabad elfelednie, hogy ez esetleg nem kívánt tartós rendszerleíróadatbázis-beállításokhoz vezethet.


Csoportházirend ismertetése

A rész tartalma:

  • Csoportházirend-objektumok
  • Házirend öröklése
  • Csoportházirend-objektumok tárolása
  • Csoportházirend elsőbbségi sorrend
  • Szoftvertelepítés ismertetése


Alkalmazások frissítése

  1. Nyissa meg a Szoftvertelepítés beépülő modult, majd kattintson a Szoftvertelepítés csomópontra.

    Helye:

    • csoportházirend-objektum_neve
    • Számítógép konfigurációja (vagy Felhasználó konfigurációja)
    • Szoftverbeállítások
    • Szoftvertelepítés
  2. A részletek ablaktáblán kattintson a jobb oldali egérgombbal a Windows Installer csomagra, mely frissítésként működik majd (nem pedig frissítendő csomagként). Előzőleg már telepítésre ki kell jelölnie vagy közzé kell tennie a csomagot.
  3. Kattintson a Tulajdonságok parancsra, majd a Frissítések fülre.
  4. A jelenlegi csomag által frissítendő csomagok listájának létrehozásához, vagy a listához való hozzáadáshoz kattintson a Hozzáadás gombra.
  5. A Frissítési csomag hozzáadása párbeszédpanelen adja meg a frissítendő csomag forrásaként a Jelenlegi csoportházirend-objektum vagy a Speciális GPO beállítást. Az utóbbi esetben kattintson a Tallózás gombra, majd a kívánt csoportházirend-objektumra, végül a Tallózás csoportházirend-objektumok között párbeszédpanelen kattintson az OK gombra.

    A kijelölt csoportházirend-objektumban telepítésre kijelölt vagy közzétett többi csomagot tartalmazó lista a Frissítendő csomag cím alatt jelenik meg. A csoportházirend-objektumtól függően ez a lista állhat nulla vagy több bejegyzésből.

  6. Kattintson a frissítendő csomagra.
  7. Kattintson A meglévő csomag eltávolítása, majd a frissítés telepítése vagy a Csomag létező csomagon felül is tud frissíteni választógombra. Általában az eltávolítás lehetőség egy alkalmazás egy teljesen különböző alkalmazással történő cseréjére szolgál (lehetséges, hogy az más forgalmazótól is származik). A frissítési lehetőség pedig ugyanazon termék egy újabb verziójának telepítésére szolgál, miközben a rendszer megtartja a felhasználó alkalmazásának beállításait, a dokumentumtípusok hozzárendeléseit stb.
  8. Ha a frissítést kötelezően kívánja elvégezni, jelölje be A létező csomagokhoz szükséges frissítés jelölőnégyzetet, majd kattintson az OK gombra.

    Ha a frissítés a Csoportházirend konzol Számítógép konfigurációja csomópontjáról történik, a jelölőnégyzet inaktív állapotban, bejelölve jelenik meg, mivel a csomagokat a számítógépekhez csak telepítésre kijelölni lehet, nem pedig közzétenni.

Megjegyzés

  • A Szoftvertelepítés beépülő modul megnyitásával kapcsolatos tudnivalókért tanulmányozza a Kapcsolódó témaköröket.

Kapcsolódó témakörök


Felhasználó konfigurációja

Használja a Csoportházirend Felhasználó konfigurációja csomópontját a felhasználókra érvényes házirendek megadására, melyek függetlenek attól, hogy a felhasználó melyik számítógépre jelentkezik be.

A Felhasználó konfigurációja általában a Szoftverbeállítások, a Windows beállításai és a Felügyeleti sablonok alcsomópontokat tartalmazza, de mivel a csoportházirendhez beépülő modulok adhatók vagy abból el is távolíthatók, így a látható alcsomópontok eltérőek lehetnek.

Lásd még:

  • Számítógép konfigurációja
  • Felügyeleti sablonok
  • Szoftverbeállítások
  • Windows beállításai
  • Bejelentkezési parancsfájlok hozzárendelése
  • Kijelentkezési parancsfájlok hozzárendelése
  • Csoportházirend-objektum Felhasználó konfigurációja beállításainak letiltása


Csoportházirendek házirendjei: Felhasználó konfigurációja

Ez a témakör azokat a házirendeket írja le, melyek a Csoportházirend beépülő modulban felhasználók kezelésére használatosak. Mivel a System.adm fájl tartalmazza ezeket a házirendeket, azoknak alapértelmezés szerint a konzolon kell lenni. Az itt tárgyalt házirendek megadásához nyissa meg a Csoportházirend beépülő modult a Csoportházirend beépülő modul megnyitása témakörben leírtak szerint. A konzolfán kattintson a csoportházirend-objektum csomópontra.

Helye:

  • házirendnév házirend
  • Felhasználó konfigurációja
  • Felügyeleti sablonok
  • Rendszer
  • Csoportházirend

Felhasználók csoportházirendjének frissítési időköze

Megadja, hogy a rendszer frissítse-e a felhasználók csoportházirendjét a számítógép használatakor (a háttérben). Ez a beállítás csak a Felhasználó konfigurációja csomóponton lévő csoportházirend-beállításokra vonatkozóan adja meg a háttérben történő frissítés gyakoriságát.

A frissítési időközökön kívül a felhasználók csoportházirendje a felhasználók bejelentkezésekor mindig frissül.

Alapértelmezés szerint a felhasználó csoportházirendje a háttérben 90 percenként frissül, mely 0-30 perccel eltolódhat.

A frissítési időköz 0 és 64 800 perc (45 nap) között adható meg. Ha 0 percet választ, a számítógép a felhasználó csoportházirendjét 7 másodpercenként próbálja meg frissíteni. A frissítés félbeszakíthatja a felhasználó munkáját és növelheti a hálózat leterheltségét, így a rövid frissítési időköz legtöbb telepítéshez nem javasolt.

Ha ezt a beállítást letiltja, a felhasználó csoportházirendje 90 percenként frissül (alapértelmezés szerint). Ha meg szeretné adni, hogy a számítógép használata közben a rendszer ne frissítse a felhasználók csoportházirendjét, válassza a Csoportházirend háttérben történő frissítésének letiltása beállítást.

A beállítás használható a tényleges frissítési időköz változásának megadásához is. Ugyanolyan frissítési időköz beállítású ügyfelek frissítésének egyidejű kérését a rendszer úgy akadályozza meg, hogy véletlenszerű időtartammal elcsúsztatja az egyes ügyfelek frissítési időközeit. A véletlenszerű időközt megadó mezőben lévő szám megadja az időköz módosításának felső határát. Például a mezőben 30 perc megadásakor a rendszer az időköz megváltoztatására 0 és 30 perc közötti értéket választ ki. Nagy szám megadása széles tartományt eredményez, így kisebb az esély az ügyfelek kéréseinek átfedésére. Ez azonban a frissítések jelentős mértékű késésével járhat.

Ez a beállítás adja meg a frissítési időközt a felhasználói csoportházirend számára. A számítógép-csoportházirendek frissítési időközének beállításához használja a Számítógépek csoportházirendjének frissítési időköze beállítást (megtalálható a Felhasználó konfigurációja\Felügyeleti sablonok\Rendszer\Csoportházirend csomóponton).

Ez a beállítás csak akkor használatos, amikor a Csoportházirend háttérben történő frissítésének letiltása beállítás nincs bejelölve.

Megjegyzés

  • Hogy a csoportházirend frissítéséről tudomással legyenek, javasolt a felhasználók értesítése arról, hogy házirendjük időközönként frissül. A csoportházirend frissítésekor a Windows Asztal is frissül oly módon, hogy rövid ideig villog, és a megnyitott menük bezárulnak. A csoportházirendekben megszabott korlátozások (például a felhasználók által futtatható programok korlátozása) a folyamatban lévő feladatok elvégzését is gátolhatják.

Lassú csoportházirend-kapcsolat felismerése

Meghatározza a lassú kapcsolatot, a csoportházirend alkalmazására és frissítésére vonatkozóan.

Ha a tartományvezérlőről átvitt adat – amely a számítógép házirendfrissítését biztosítja ebben a csoportban – átviteli sebessége lassabb, mint az ebben a beállításban meghatározott átviteli sebesség, a rendszer a kapcsolatot lassúnak tekinti.

A házirendek átvitelére lassú kapcsolat esetén a rendszer válaszideje változhat, a házirendektől függően. A házirendet megvalósító program megadhatja a lassú kapcsolatra adott választ. A mappa házirend-feldolgozó házirendjei felhasználhatók a program által a lassú kapcsolatokra meghatározott válaszok érvénytelenítésére.

A házirend használatához a Kapcsolat sebessége mezőbe írjon be egy 0 és 4 294 967 200 (0xFFFFFFA0) közötti számot, mely az átviteli sebességet jelenti kilobit/másodpercben. Az ennél lassabb átviteli sebességű kapcsolatokat a rendszer lassúnak tekinti. Ha a mezőben nullát ad meg, a rendszer minden kapcsolatot gyorsnak tekint.

Ha ezt a házirendet letiltja vagy nem állítja be, a rendszer az 500 kilobit/másodperces értéket használja alapértelmezettként.

Ez a házirend a Számítógép konfigurációja és Felhasználó konfigurációja csomóponton jelenik meg. A Számítógép konfigurációja csomóponton található házirend a Számítógép konfigurációja csomóponton lévő házirendekre határozza meg a lassú kapcsolatot. A Felhasználó konfigurációja mappában található házirend a mappában lévő házirendekre határozza meg a lassú kapcsolatot.

Csoportházirend tartományvezérlőjének kiválasztása

Meghatározza, hogy a rendszer melyik tartományvezérlőt használja a csoportházirend felhasználókra történő alkalmazásakor.

Az Elsődleges tartományvezérlő használata beállítás azt jelzi, hogy az elsődleges tartományvezérlő érvényesíti a házirendet abban a tartományban, amelybe a felhasználó bejelentkezett.

Az Öröklés az Active Directory beépülő moduljaiból beállítás azt jelzi, hogy a házirendet a Csoportházirend beépülő modult tároló tartományvezérlő érvényesíti.

Az Elérhető tartományvezérlő használata beállítás azt jelzi, hogy a rendszer a tartományban elsőként talált rendelkezésre álló tartományvezérlőt használhatja.

Ha ezt a házirendet letiltja vagy nem állítja be, az elsődleges tartományvezérlő érvényesíti a csoportházirendet.

Alapértelmezés szerint letiltott új csoportházirend-objektum hivatkozások létrehozása

E házirend engedélyezésekor az Active Directory - felhasználók és számítógépek, illetve az Active Directory - helyek és szolgáltatások beépülő modulokban használható Új csoportházirend-objektum jelölőnégyzet alapértelmezés szerint nincs bejelölve. A rendszergazda ebben az esetben is bejelölheti a jelölőnégyzetet.

Ha ezt a házirendet letiltja, vagy nem állítja be, az Új csoportházirend-objektum beállítás alapértelmezés szerint bejelölt állapotban jelenik meg, így a rendszergazdának annak jelölését törölnie kell.

Csak a házirendek megjelenítésének kényszerítése

Ez a házirend csak a Csak a házirendek megjelenítése nézet menübeállítására van hatással a Csoportházirend beépülő modul Felügyeleti sablonok csomópontjában.

A házirend engedélyezése megakadályozza a felhasználót, hogy törölhesse a Csak a házirendek megjelenítése menüpont bejelölését. A házirend letiltásakor a felhasználó nem tudja kiválasztani a menüpontot.

Ebben a környezetben a házirendek a Windows 2000 csoportházirendjeire vonatkoznak, nem pedig a Windows NT 4.0 stílusú rendszerházirendekre. Ha magyarázatot szeretne kapni arról, hogy ez a megkülönböztetés miért fontos, tanulmányozza a Windows NT 4.0 Rendszerházirendek témakört.

ADM-fájlok automatikus frissítésének letiltása

Megakadályozza, hogy a rendszer a Felügyeleti sablonok forrásfájljait automatikusan frissítse a Csoportházirend beépülő modul megnyitásakor.

Alapértelmezés szerint a Csoportházirend beépülő modul indításakor a rendszer betölti a %systemroot%\inf mappában lévő Felügyeleti sablonok forrásfájljainak (.adm) legutóbb felülvizsgált másolatait. Az .adm fájl létrehozza a Csoportházirend beépülő modul Felügyeleti sablonok csomópontja alatt megjelenő házirendek listáját.

Ennek a házirendnek az engedélyezésekor a rendszer Csoportházirend beépülő modul futtatásakor legutóbb használt .adm fájlt tölti be. A művelet után az .adm fájlokat kézzel kell frissíteni.

Megjegyzések

  • Az .adm fájlok frissítése nem írja felül a házirend-konfigurációs beállításokat. A rendszer az Active Directoryban tárolja a beállításokat, nem pedig az .adm fájlokban.
  • Az .adm fájlok kézzel történő frissítéséhez a Csoportházirend beépülő modulban kattintson a jobb oldali egérgombbal a Felügyeleti sablonok csomópontra, majd a Sablon hozzáadása/eltávolítása parancsra.

Hiányzó COM-komponensek letöltése

Arra utasítja a rendszert, hogy az Active Directoryban a programok által igényelt hiányzó Component Object Model (COM) elemeket keresse.

Számos Windows alapú program, például a Microsoft Management Console beépülő modulok, a COM által biztosított illesztőket használja. Ezek a programok csak akkor képesek minden funkciójukat végrehajtani, ha a szükséges összetevők a Windows 2000 rendszerben jegyezve lettek.

Ha ezt a házirendet engedélyezi és egy összetevőbejegyzés hiányzik, a rendszer az Active Directoryban keresi a hiányzó elemet, és ha megtalálta, letölti azt. Az ebből adódó keresési eljárások bizonyos programok indítását vagy futását lelassíthatják.

Ha ezt a házirendet letiltja vagy be sem állítja, a program regisztráció nélkül folytatódik. Következésképpen lehetséges, hogy a program nem képes végrehajtani összes funkcióját, sőt a futása is leállhat.

Ez a házirend a felhasználókra vonatkozik. A házirend számítógépekre történő alkalmazásához használja a Számítógép konfigurációja\Felügyeleti sablonok\Rendszer\Csoportházirend csomóponton lévő Hiányzó COM összetevők letöltése házirendet.


Windows beállítások

A Csoportházirend beépülő modulban két Windows-beállítás csomópont található.

A \Számítógép konfigurációja\Windows beállításai csomópont a számítógépre bejelentkező bármely felhasználóra érvényes Windows beállításokra vonatkozik. Ebből a csomópontból két alcsomópont nyílik: a Biztonsági beállítások és Parancsfájlok.

A \Felhasználó konfigurációja\Windows beállításai csomópont bármely számítógépre bejelentkező felhasználóra érvényes Windows beállításokra vonatkozik. Ebből a csomópontból három alcsomópont nyílik: Mappa átirányítása, Biztonsági beállítások és Parancsfájlok.

Lásd még:

  • Felhasználó konfigurációja
  • Számítógép konfigurációja
  • Biztonsági beállítások
  • Parancsfájlok
  • Mappa átirányítása


Műveletek alkalmazásokkal

  • Alkalmazás kijelölése telepítésre
  • Alkalmazás közzététele
  • Alkalmazások frissítése
  • Kezelt alkalmazás eltávolítása